QEMU-Devel Archive on lore.kernel.org
 help / color / Atom feed
* ERROR: glib-2.48 gthread-2.0 is required to compile QEMU
@ 2020-10-18 14:21 Lee
  2020-10-18 16:23 ` Peter Maydell
  0 siblings, 1 reply; 3+ messages in thread
From: Lee @ 2020-10-18 14:21 UTC (permalink / raw)
  To: qemu-devel


[-- Attachment #1: Type: text/plain, Size: 410 bytes --]



Ubuntu 14.04.6 LTS, X86_64
I  make source code of version qemu 5.1\5.0\4.2,and foud the error:glib-2.48 gthread-2.0 is required to compile QEMU
try apt-get install libglib2.0-dev,and it is sucess :
Reading state information... Done
libglib2.0-dev is already the newest version.
but the error is  not fix; and i found that version qemu 4.1 is OK,the same environment;
hi all ,is there some suggestion for me?

[-- Attachment #2: Type: text/html, Size: 1049 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: ERROR: glib-2.48 gthread-2.0 is required to compile QEMU
  2020-10-18 14:21 ERROR: glib-2.48 gthread-2.0 is required to compile QEMU Lee
@ 2020-10-18 16:23 ` Peter Maydell
  2020-10-21 16:32   ` Lee
  0 siblings, 1 reply; 3+ messages in thread
From: Peter Maydell @ 2020-10-18 16:23 UTC (permalink / raw)
  To: Lee; +Cc: QEMU Developers

On Sun, 18 Oct 2020 at 15:38, Lee <380121850@163.com> wrote:
> Ubuntu 14.04.6 LTS, X86_64
> I  make source code of version qemu 5.1\5.0\4.2,and foud the error:glib-2.48 gthread-2.0 is required to compile QEMU
> try apt-get install libglib2.0-dev,and it is sucess :
> Reading state information... Done
> libglib2.0-dev is already the newest version.

I believe that Ubuntu 14.04 shipped with libglib2.0-dev
version 2.40.2 -- this is too old, as the QEMU error
message says.

The simplest thing to do would be for you to upgrade your Ubuntu
install -- 14.04 is now very old (it reached "end of standard
support", ie no more security fixes unless you're paying
Canonical for extended security maintenance, in April 2019).

QEMU's distro support policy is documented here:
https://www.qemu.org/docs/master/system/build-platforms.html
For distros like Ubuntu with a 'long-lifetime' type release
(like LTS), we support the most recent major version, and
the previous major version up until 2 years after the next
major version was released. So we support 20.04 LTS (the
most recent) and also will support 18.04 LTS until at least
April 2022 (since 20.04 was released in April 2020), but
anything older than that is not officially supported and
may or may not work.

> i found that version qemu 4.1 is OK,the same environment

QEMU 4.1 did not require the newer version of glib. (As we
develop QEMU we want to be able to use the extra features
in newer versions of our dependent libraries and to be able
to remove backwards-compatibility code that is needed only
when using older versions of those libraries, so sometimes
when all the distros and versions we support ship with a
new enough version of a library we will increase the
minimum required version that QEMU needs to build.)

thanks
-- PMM


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re:Re: ERROR: glib-2.48 gthread-2.0 is required to compile QEMU
  2020-10-18 16:23 ` Peter Maydell
@ 2020-10-21 16:32   ` Lee
  0 siblings, 0 replies; 3+ messages in thread
From: Lee @ 2020-10-21 16:32 UTC (permalink / raw)
  To: Peter Maydell; +Cc: QEMU Developers


[-- Attachment #1: Type: text/plain, Size: 2461 bytes --]

thanks
i think you are maybe right; 


root@ubuntu-upstart-1:~# dpkg -l libglib2.0-dev
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                 Version         Architecture    Description
+++-====================-===============-===============-==============================================
ii  libglib2.0-dev       2.40.2-0ubuntu1 amd64           Development files for the GLib library



















At 2020-10-19 00:23:14, "Peter Maydell" <peter.maydell@linaro.org> wrote:
>On Sun, 18 Oct 2020 at 15:38, Lee <380121850@163.com> wrote:
>> Ubuntu 14.04.6 LTS, X86_64
>> I  make source code of version qemu 5.1\5.0\4.2,and foud the error:glib-2.48 gthread-2.0 is required to compile QEMU
>> try apt-get install libglib2.0-dev,and it is sucess :
>> Reading state information... Done
>> libglib2.0-dev is already the newest version.
>
>I believe that Ubuntu 14.04 shipped with libglib2.0-dev
>version 2.40.2 -- this is too old, as the QEMU error
>message says.
>
>The simplest thing to do would be for you to upgrade your Ubuntu
>install -- 14.04 is now very old (it reached "end of standard
>support", ie no more security fixes unless you're paying
>Canonical for extended security maintenance, in April 2019).
>
>QEMU's distro support policy is documented here:
>https://www.qemu.org/docs/master/system/build-platforms.html
>For distros like Ubuntu with a 'long-lifetime' type release
>(like LTS), we support the most recent major version, and
>the previous major version up until 2 years after the next
>major version was released. So we support 20.04 LTS (the
>most recent) and also will support 18.04 LTS until at least
>April 2022 (since 20.04 was released in April 2020), but
>anything older than that is not officially supported and
>may or may not work.
>
>> i found that version qemu 4.1 is OK,the same environment
>
>QEMU 4.1 did not require the newer version of glib. (As we
>develop QEMU we want to be able to use the extra features
>in newer versions of our dependent libraries and to be able
>to remove backwards-compatibility code that is needed only
>when using older versions of those libraries, so sometimes
>when all the distros and versions we support ship with a
>new enough version of a library we will increase the
>minimum required version that QEMU needs to build.)
>
>thanks
>-- PMM

[-- Attachment #2: Type: text/html, Size: 3455 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, back to index

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-18 14:21 ERROR: glib-2.48 gthread-2.0 is required to compile QEMU Lee
2020-10-18 16:23 ` Peter Maydell
2020-10-21 16:32   ` Lee

QEMU-Devel Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/qemu-devel/0 qemu-devel/git/0.git
	git clone --mirror https://lore.kernel.org/qemu-devel/1 qemu-devel/git/1.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 qemu-devel qemu-devel/ https://lore.kernel.org/qemu-devel \
		qemu-devel@nongnu.org
	public-inbox-index qemu-devel

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.nongnu.qemu-devel


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git