qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: Peter Maydell <peter.maydell@linaro.org>
To: Eduardo Habkost <ehabkost@redhat.com>
Cc: "Paolo Bonzini" <pbonzini@redhat.com>,
	"Daniel P. Berrangé" <berrange@redhat.com>,
	"QEMU Developers" <qemu-devel@nongnu.org>
Subject: Re: [PULL 00/34] QOM boilerplate cleanup (v2)
Date: Tue, 8 Sep 2020 21:20:43 +0100	[thread overview]
Message-ID: <CAFEAcA9WEjne5TfwggVWPuBprkRs-a2-iNc43Xa_jBamaf9t8A@mail.gmail.com> (raw)
In-Reply-To: <20200908200123.3402311-1-ehabkost@redhat.com>

On Tue, 8 Sep 2020 at 21:01, Eduardo Habkost <ehabkost@redhat.com> wrote:
>
> The following changes since commit b95ba83fc56ebfc4b6869f21db0c757c0c191104:
>
>   Merge remote-tracking branch 'remotes/dgibson/tags/ppc-for-5.2-20200908' in=
> to staging (2020-09-08 16:18:48 +0100)
>
> are available in the Git repository at:
>
>   git://github.com/ehabkost/qemu.git tags/machine-next-pull-request
>
> for you to fetch changes up to 86f08d9faa5c05bff56c84ead337063e50e7eb4d:
>
>   virtio-vga: Use typedef name for instance_size (2020-09-08 15:32:38 -0400)
>
> Changes included in v2:
> * memory: Remove kernel-doc comment marker (Eduardo Habkost)
>
> ----------------------------------------------------------------
> QOM boilerplate cleanup
>
> Documentation build fix:
> * memory: Remove kernel-doc comment marker (Eduardo Habkost)
>
> QOM cleanups:
> * Rename QOM macros for consistency between
>   TYPE_* and type checking constants (Eduardo Habkost)
>
> QOM new macros:
> * OBJECT_DECLARE_* and OBJECT_DEFINE_* macros (Daniel P. Berrang=C3=A9)
> * DECLARE_*_CHECKER macros (Eduardo Habkost)
>
> Automated QOM boilerplate changes:
> * Automated changes to use DECLARE_*_CHECKER (Eduardo Habkost
> * Automated changes to use OBJECT_DECLARE* (Eduardo Habkost)

Compile failure, Windows:

In file included from /home/petmay01/qemu-for-merges/include/exec/memory.h:28:0,
                 from /home/petmay01/qemu-for-merges/include/sysemu/dma.h:13,
                 from ../../hw/nvram/fw_cfg.c:28:
/home/petmay01/qemu-for-merges/include/sysemu/accel.h:65:22: error:
'ACCEL' redeclared as different kind of symbol
                      ACCEL, TYPE_ACCEL)
                      ^
/home/petmay01/qemu-for-merges/include/qom/object.h:571:5: note: in
definition of macro 'DECLARE_INSTANCE_CHECKER'
     OBJ_NAME(const void *obj) \
     ^
/home/petmay01/qemu-for-merges/include/sysemu/accel.h:64:1: note: in
expansion of macro 'DECLARE_OBJ_CHECKERS'
 DECLARE_OBJ_CHECKERS(AccelState, AccelClass,
 ^
In file included from
/usr/lib/mxe/usr/x86_64-w64-mingw32.shared/include/windows.h:72:0,
                 from
/usr/lib/mxe/usr/x86_64-w64-mingw32.shared/include/winsock2.h:23,
                 from
/home/petmay01/qemu-for-merges/include/sysemu/os-win32.h:29,
                 from /home/petmay01/qemu-for-merges/include/qemu/osdep.h:119,
                 from ../../hw/nvram/fw_cfg.c:25:
/usr/lib/mxe/usr/x86_64-w64-mingw32.shared/include/winuser.h:1757:5:
note: previous declaration of 'ACCEL' was here
   } ACCEL,*LPACCEL;
     ^
Compiling C object libcommon.fa.p/hw_misc_aspeed_scu.c.obj


Compile failure, Linux, NetBSD, FReeBSD:

In file included from ../../hw/riscv/sifive_u.c:51:0:
/home/petmay01/linaro/qemu-for-merges/include/hw/riscv/sifive_u.h:80:5:
error: ‘SIFIVE_U_PRCI’ redeclared as different kind of symbol
     SIFIVE_U_PRCI,
     ^~~~~~~~~~~~~
In file included from
/home/petmay01/linaro/qemu-for-merges/include/exec/memory.h:28:0,
                 from
/home/petmay01/linaro/qemu-for-merges/include/hw/boards.h:6,
                 from ../../hw/riscv/sifive_u.c:39:
/home/petmay01/linaro/qemu-for-merges/include/hw/riscv/sifive_u_prci.h:63:44:
note: previous definition of ‘SIFIVE_U_PRCI’ was here
 DECLARE_INSTANCE_CHECKER(SiFiveUPRCIState, SIFIVE_U_PRCI,
                                            ^
/home/petmay01/linaro/qemu-for-merges/include/qom/object.h:571:5:
note: in definition of macro ‘DECLARE_INSTANCE_CHECKER’
     OBJ_NAME(const void *obj) \
     ^~~~~~~~
In file included from ../../hw/riscv/sifive_u.c:51:0:
/home/petmay01/linaro/qemu-for-merges/include/hw/riscv/sifive_u.h:84:5:
error: ‘SIFIVE_U_OTP’ redeclared as different kind of symbol
     SIFIVE_U_OTP,
     ^~~~~~~~~~~~
In file included from
/home/petmay01/linaro/qemu-for-merges/include/exec/memory.h:28:0,
                 from
/home/petmay01/linaro/qemu-for-merges/include/hw/boards.h:6,
                 from ../../hw/riscv/sifive_u.c:39:
/home/petmay01/linaro/qemu-for-merges/include/hw/riscv/sifive_u_otp.h:54:43:
note: previous definition of ‘SIFIVE_U_OTP’ was here
 DECLARE_INSTANCE_CHECKER(SiFiveUOTPState, SIFIVE_U_OTP,
                                           ^
/home/petmay01/linaro/qemu-for-merges/include/qom/object.h:571:5:
note: in definition of macro ‘DECLARE_INSTANCE_CHECKER’
     OBJ_NAME(const void *obj) \
     ^~~~~~~~


and the similar

Compiling C object libqemu-riscv32-softmmu.fa.p/hw_riscv_sifive_e.c.o
In file included from
/home/petmay01/linaro/qemu-for-merges/include/exec/memory.h:28:0,
                 from
/home/petmay01/linaro/qemu-for-merges/include/hw/boards.h:6,
                 from ../../hw/riscv/sifive_e.c:35:
/home/petmay01/linaro/qemu-for-merges/include/hw/riscv/sifive_e_prci.h:56:44:
error: ‘SIFIVE_E_PRCI’ redeclared as different kind of symbol
 DECLARE_INSTANCE_CHECKER(SiFiveEPRCIState, SIFIVE_E_PRCI,
                                            ^
/home/petmay01/linaro/qemu-for-merges/include/qom/object.h:571:5:
note: in definition of macro ‘DECLARE_INSTANCE_CHECKER’
     OBJ_NAME(const void *obj) \
     ^~~~~~~~
In file included from ../../hw/riscv/sifive_e.c:45:0:
/home/petmay01/linaro/qemu-for-merges/include/hw/riscv/sifive_e.h:65:5:
note: previous definition of ‘SIFIVE_E_PRCI’ was here
     SIFIVE_E_PRCI,
     ^~~~~~~~~~~~~
../../hw/riscv/sifive_e.c:63:6: error: array index in initializer not
of integer type
     [SIFIVE_E_PRCI] =     { 0x10008000,     0x8000 },
      ^~~~~~~~~~~~~
../../hw/riscv/sifive_e.c:63:6: note: (near initialization for
‘sifive_e_memmap’)
../../hw/riscv/sifive_e.c: In function ‘sifive_e_soc_realize’:
../../hw/riscv/sifive_e.c:218:32: error: array subscript is not an integer
     sifive_e_prci_create(memmap[SIFIVE_E_PRCI].base);
                                ^
Makefile.ninja:4285: recipe for target
'libqemu-riscv32-softmmu.fa.p/hw_riscv_sifive_e.c.o' failed


thanks
-- PMM


  parent reply	other threads:[~2020-09-08 20:21 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-08 20:00 [PULL 00/34] QOM boilerplate cleanup (v2) Eduardo Habkost
2020-09-08 20:00 ` [PULL 01/34] memory: Remove kernel-doc comment marker Eduardo Habkost
2020-09-08 20:00 ` [PULL 02/34] qom: make object_ref/unref use a void * instead of Object * Eduardo Habkost
2020-09-08 20:00 ` [PULL 03/34] qom: provide convenient macros for declaring and defining types Eduardo Habkost
2020-09-08 20:00 ` [PULL 04/34] qom: Allow class type name to be specified in OBJECT_DECLARE* Eduardo Habkost
2020-09-08 20:00 ` [PULL 05/34] qom: DECLARE_*_CHECKERS macros Eduardo Habkost
2020-09-08 20:00 ` [PULL 06/34] qom: Make type checker functions accept const pointers Eduardo Habkost
2020-09-08 20:00 ` [PULL 07/34] codeconverter: script for automating QOM code cleanups Eduardo Habkost
2020-09-08 20:00 ` [PULL 08/34] Delete duplicate QOM typedefs Eduardo Habkost
2020-09-08 20:00 ` [PULL 09/34] Move QOM typedefs and add missing includes Eduardo Habkost
2020-09-08 20:00 ` [PULL 10/34] Use DECLARE_*CHECKER* macros Eduardo Habkost
2020-09-08 20:01 ` [PULL 11/34] Use DECLARE_*CHECKER* when possible (--force mode) Eduardo Habkost
2020-09-08 20:01 ` [PULL 12/34] Use OBJECT_DECLARE_TYPE where possible Eduardo Habkost
2020-09-08 20:01 ` [PULL 13/34] Use OBJECT_DECLARE_SIMPLE_TYPE when possible Eduardo Habkost
2020-09-08 20:01 ` [PULL 14/34] gpex: Fix type checking function name Eduardo Habkost
2020-09-08 20:01 ` [PULL 15/34] chardev: Rename TYPE_CHARDEV_* to TYPE_*_CHARDEV Eduardo Habkost
2020-09-08 20:01 ` [PULL 16/34] ap-device: Rename AP_DEVICE_TYPE to TYPE_AP_DEVICE Eduardo Habkost
2020-09-08 20:01 ` [PULL 17/34] dev-smartcard-reader: Rename CCID_DEV_NAME to TYPE_USB_CCID_DEV Eduardo Habkost
2020-09-08 20:01 ` [PULL 18/34] vfio: Rename VFIO_AP_DEVICE_TYPE to TYPE_VFIO_AP_DEVICE Eduardo Habkost
2020-09-08 20:01 ` [PULL 19/34] vmgenid: Rename VMGENID_DEVICE to TYPE_VMGENID Eduardo Habkost
2020-09-08 20:01 ` [PULL 20/34] ahci: Rename ICH_AHCI to ICH9_AHCI Eduardo Habkost
2020-09-08 20:01 ` [PULL 21/34] esp: Rename ESP_STATE to ESP Eduardo Habkost
2020-09-08 20:01 ` [PULL 22/34] filter-rewriter: Rename FILTER_COLO_REWRITER to FILTER_REWRITER Eduardo Habkost
2020-09-08 20:01 ` [PULL 23/34] rs6000_mc: Rename RS6000MC_DEVICE to RS6000MC Eduardo Habkost
2020-09-08 20:01 ` [PULL 24/34] sabre: Rename SABRE_DEVICE to SABRE Eduardo Habkost
2020-09-08 20:01 ` [PULL 25/34] usb: Rename USB_SERIAL_DEV to USB_SERIAL Eduardo Habkost
2020-09-08 20:01 ` [PULL 26/34] vfio: Rename PCI_VFIO to VFIO_PCI Eduardo Habkost
2020-09-08 20:01 ` [PULL 27/34] pc87312: Rename TYPE_PC87312_SUPERIO to TYPE_PC87312 Eduardo Habkost
2020-09-08 20:01 ` [PULL 28/34] tusb6010: Rename TUSB to TUSB6010 Eduardo Habkost
2020-09-08 20:01 ` [PULL 29/34] xilinx_axidma: Use typedef name for instance_size Eduardo Habkost
2020-09-08 20:01 ` [PULL 30/34] omap_intc: " Eduardo Habkost
2020-09-08 20:01 ` [PULL 31/34] lpc_ich9: " Eduardo Habkost
2020-09-08 20:01 ` [PULL 32/34] xilinx_axienet: " Eduardo Habkost
2020-09-08 20:01 ` [PULL 33/34] vhost-user-vga: " Eduardo Habkost
2020-09-08 20:01 ` [PULL 34/34] virtio-vga: " Eduardo Habkost
2020-09-08 20:20 ` Peter Maydell [this message]
2020-09-08 21:29   ` [PULL 00/34] QOM boilerplate cleanup (v2) Eduardo Habkost

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAFEAcA9WEjne5TfwggVWPuBprkRs-a2-iNc43Xa_jBamaf9t8A@mail.gmail.com \
    --to=peter.maydell@linaro.org \
    --cc=berrange@redhat.com \
    --cc=ehabkost@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).