On Mon, 26 Sep 2022, Cédric Le Goater wrote: > On 9/24/22 14:27, BALATON Zoltan wrote: >> This is the end of the QOMify series started by Cédric. This series >> handles the SDRAM controller models to clean them up, QOMify and unify >> them and at least partially clean up the mess that has accumulated >> around these in the past. This includes the not yet merged patches >> from the last series and new ones that change the DDR2 version used by >> sam460ex. >> >> v6: Split patch moving sdram controller models together into smaller steps >> v5: Add functions the enable sdram controller and call it from boards >> v4: address more review comments >> v3: Fix patches that got squashed during rebase >> v2: address some review comments and try to avoid compile problem with >> gcc 12.2 (untested) >> >> BALATON Zoltan (25): >> ppc440_bamboo: Remove unnecessary memsets >> ppc4xx: Introduce Ppc4xxSdramBank struct >> ppc4xx_sdram: Get rid of the init RAM hack >> ppc4xx: Use Ppc4xxSdramBank in ppc4xx_sdram_banks() >> ppc440_bamboo: Add missing 4 MiB valid memory size >> ppc4xx_sdram: Move size check to ppc4xx_sdram_init() >> ppc4xx_sdram: QOM'ify >> ppc4xx_sdram: Drop extra zeros for readability >> ppc440_sdram: Split off map/unmap of sdram banks for later reuse >> ppc440_sdram: Implement enable bit in the DDR2 SDRAM controller >> ppc440_sdram: Get rid of the init RAM hack >> ppc440_sdram: Rename local variable for readability >> ppc4xx_sdram: Rename functions to prevent name clashes >> ppc440_sdram: Move RAM size check to ppc440_sdram_init >> ppc440_sdram: QOM'ify >> ppc440_uc.c: Move some macros to ppc4xx.h >> ppc440_uc.c: Remove unneeded parenthesis >> ppc440_uc.c: Move DDR2 SDRAM controller model to ppc4xx_sdram.c >> ppc4xx_devs.c: Move DDR SDRAM controller model to ppc4xx_sdram.c >> ppc4xx_sdram: Move ppc4xx_sdram_banks() to ppc4xx_sdram.c >> ppc4xx_sdram: Use hwaddr for memory bank size >> ppc4xx_sdram: Rename local state variable for brevity >> ppc4xx_sdram: Generalise bank setup >> ppc4xx_sdram: Convert DDR SDRAM controller to new bank handling >> ppc4xx_sdram: Add errp parameter to ppc4xx_sdram_banks() >> >> hw/ppc/meson.build | 3 +- >> hw/ppc/ppc405.h | 8 +- >> hw/ppc/ppc405_boards.c | 13 +- >> hw/ppc/ppc405_uc.c | 33 +- >> hw/ppc/ppc440.h | 4 - >> hw/ppc/ppc440_bamboo.c | 25 +- >> hw/ppc/ppc440_uc.c | 267 +------------- >> hw/ppc/ppc4xx_devs.c | 413 ---------------------- >> hw/ppc/ppc4xx_sdram.c | 753 ++++++++++++++++++++++++++++++++++++++++ >> hw/ppc/sam460ex.c | 44 +-- >> hw/ppc/trace-events | 1 + >> include/hw/ppc/ppc4xx.h | 65 +++- >> 12 files changed, 859 insertions(+), 770 deletions(-) >> create mode 100644 hw/ppc/ppc4xx_sdram.c > > Zoltan, > > Could we add you as a MAINTAINER of these files ? You know them well now. > At least the ppc44* ones. I may know some things now but I forget quickly :-) I already maintain the files I've written but don't really want to get cc-d on others. I read the list though and if I see something I can help with I'll try to do so like with this series. That's all I can commit to now, not taking other orphan files, so no thanks but I'll try to review what I can informally. Regards, BALATON Zoltan