All of lore.kernel.org
 help / color / mirror / Atom feed
From: Anand Jain <anand.jain@oracle.com>
To: linux-btrfs@vger.kernel.org
Cc: dsterba@suse.cz
Subject: [PATCH 1/6] btrfs-progs: spatial rearrange subvolume functions together
Date: Mon, 21 Mar 2016 15:21:00 +0800	[thread overview]
Message-ID: <1458544865-16467-2-git-send-email-anand.jain@oracle.com> (raw)
In-Reply-To: <1458544865-16467-1-git-send-email-anand.jain@oracle.com>

Signed-off-by: Anand Jain <anand.jain@oracle.com>
---
 utils.c | 24 +++++++++++++-----------
 1 file changed, 13 insertions(+), 11 deletions(-)

diff --git a/utils.c b/utils.c
index c0c564e2f69b..fb549ee923c7 100644
--- a/utils.c
+++ b/utils.c
@@ -2784,17 +2784,6 @@ int test_minimum_size(const char *file, u32 nodesize)
 	return 0;
 }
 
-/*
- * test if name is a correct subvolume name
- * this function return
- * 0-> name is not a correct subvolume name
- * 1-> name is a correct subvolume name
- */
-int test_issubvolname(const char *name)
-{
-	return name[0] != '\0' && !strchr(name, '/') &&
-		strcmp(name, ".") && strcmp(name, "..");
-}
 
 /*
  * Test if path is a directory
@@ -3146,3 +3135,16 @@ void clean_args_no_options(int argc, char *argv[], const char * const *usagestr)
 		}
 	}
 }
+
+/* Subvolume helper functions */
+/*
+ * test if name is a correct subvolume name
+ * this function return
+ * 0-> name is not a correct subvolume name
+ * 1-> name is a correct subvolume name
+ */
+int test_issubvolname(const char *name)
+{
+	return name[0] != '\0' && !strchr(name, '/') &&
+		strcmp(name, ".") && strcmp(name, "..");
+}
-- 
2.7.0


  reply	other threads:[~2016-03-21  7:21 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-03-21  7:20 [PATCH 0/6 v3] btrfs-progs: subvolume functions reorg Anand Jain
2016-03-21  7:21 ` Anand Jain [this message]
2016-03-21  7:21 ` [PATCH 2/6] btrfs-progs: move test_issubvolume() to utils.c Anand Jain
2016-03-21  7:21 ` [PATCH 3/6] btrfs-progs: remove duplicate function __is_subvol() Anand Jain
2016-03-21  7:21 ` [PATCH 4/6] btrfs-progs: move get_subvol_name() to utils.c Anand Jain
2016-03-21  7:21 ` [PATCH 5/6] btrfs-progs: create get_subvol_info() Anand Jain
2016-03-21  7:21 ` [PATCH 6/6] btrfs-progs: rename get_subvol_name() to subvol_minus_mnt() Anand Jain
2016-03-22 16:11 ` [PATCH 0/6 v3] btrfs-progs: subvolume functions reorg David Sterba

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1458544865-16467-2-git-send-email-anand.jain@oracle.com \
    --to=anand.jain@oracle.com \
    --cc=dsterba@suse.cz \
    --cc=linux-btrfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.