All of lore.kernel.org
 help / color / mirror / Atom feed
From: Gene Chen <gene.chen.richtek@gmail.com>
To: sre@kernel.org, matthias.bgg@gmail.com, robh+dt@kernel.org
Cc: linux-pm@vger.kernel.org, devicetree@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	linux-mediatek@lists.infradead.org, linux-kernel@vger.kernel.org,
	gene_chen@richtek.com, Wilma.Wu@mediatek.com,
	shufan_lee@richtek.com, cy_huang@richtek.com,
	benjamin.chao@mediatek.com
Subject: [PATCH v7 0/11] mfd: mt6360: Merge different sub-devices I2C read/write
Date: Thu, 12 Nov 2020 18:39:47 +0800	[thread overview]
Message-ID: <1605177598-23501-1-git-send-email-gene.chen.richtek@gmail.com> (raw)

This patch series merge different sub-device I2C read/write into one Regmap and
fix coding style for well-organized.

Gene Chen (11)
  mfd: mt6360: Rearrange include file
  mfd: mt6360: Remove redundant brackets around raw numbers
  mfd: mt6360: Indicate sub-dev compatible name by using
  mfd: mt6360: Combine mt6360 pmic/ldo resources into mt6360
  mfd: mt6360: Rename mt6360_pmu_data by mt6360_ddata
  mfd: mt6360: Rename mt6360_pmu by mt6360
  mfd: mt6360: Remove handle_post_irq callback function
  mfd: mt6360: Fix flow which is used to check ic exist
  mfd: mt6360: Merge header file into driver and remove unuse register define
  mfd: mt6360: Merge different sub-devices I2C read/write
  mfd: mt6360: Remove MT6360 regulator of_compatible

 b/drivers/mfd/Kconfig       |    1 
 b/drivers/mfd/mt6360-core.c |  554 +++++++++++++++++++++++++++++---------------
 include/linux/mfd/mt6360.h  |  240 -------------------
 3 files changed, 376 insertions(+), 419 deletions(-)

changelogs between v2 & v3
- Replace mt6360_data to mt6360_ddata
- Split I2C read/write to regmap driver

changelogs between v3 & v4
- Merge back mt6360 regmap driver to MFD driver

changelogs between v4 & v5
- use devm_regmap_init
- define crc calculation magic number

changelogs between v5 & v6
- Remove unrelated change
- Remove regulator device of_compatible

changelogs between v6 & v7
- Replace OF_MFD_CELL by MFD_CELL_RES


WARNING: multiple messages have this Message-ID (diff)
From: Gene Chen <gene.chen.richtek@gmail.com>
To: sre@kernel.org, matthias.bgg@gmail.com, robh+dt@kernel.org
Cc: gene_chen@richtek.com, devicetree@vger.kernel.org,
	linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org,
	cy_huang@richtek.com, benjamin.chao@mediatek.com,
	linux-mediatek@lists.infradead.org, Wilma.Wu@mediatek.com,
	linux-arm-kernel@lists.infradead.org, shufan_lee@richtek.com
Subject: [PATCH v7 0/11] mfd: mt6360: Merge different sub-devices I2C read/write
Date: Thu, 12 Nov 2020 18:39:47 +0800	[thread overview]
Message-ID: <1605177598-23501-1-git-send-email-gene.chen.richtek@gmail.com> (raw)

This patch series merge different sub-device I2C read/write into one Regmap and
fix coding style for well-organized.

Gene Chen (11)
  mfd: mt6360: Rearrange include file
  mfd: mt6360: Remove redundant brackets around raw numbers
  mfd: mt6360: Indicate sub-dev compatible name by using
  mfd: mt6360: Combine mt6360 pmic/ldo resources into mt6360
  mfd: mt6360: Rename mt6360_pmu_data by mt6360_ddata
  mfd: mt6360: Rename mt6360_pmu by mt6360
  mfd: mt6360: Remove handle_post_irq callback function
  mfd: mt6360: Fix flow which is used to check ic exist
  mfd: mt6360: Merge header file into driver and remove unuse register define
  mfd: mt6360: Merge different sub-devices I2C read/write
  mfd: mt6360: Remove MT6360 regulator of_compatible

 b/drivers/mfd/Kconfig       |    1 
 b/drivers/mfd/mt6360-core.c |  554 +++++++++++++++++++++++++++++---------------
 include/linux/mfd/mt6360.h  |  240 -------------------
 3 files changed, 376 insertions(+), 419 deletions(-)

changelogs between v2 & v3
- Replace mt6360_data to mt6360_ddata
- Split I2C read/write to regmap driver

changelogs between v3 & v4
- Merge back mt6360 regmap driver to MFD driver

changelogs between v4 & v5
- use devm_regmap_init
- define crc calculation magic number

changelogs between v5 & v6
- Remove unrelated change
- Remove regulator device of_compatible

changelogs between v6 & v7
- Replace OF_MFD_CELL by MFD_CELL_RES


_______________________________________________
Linux-mediatek mailing list
Linux-mediatek@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-mediatek

WARNING: multiple messages have this Message-ID (diff)
From: Gene Chen <gene.chen.richtek@gmail.com>
To: sre@kernel.org, matthias.bgg@gmail.com, robh+dt@kernel.org
Cc: gene_chen@richtek.com, devicetree@vger.kernel.org,
	linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org,
	cy_huang@richtek.com, benjamin.chao@mediatek.com,
	linux-mediatek@lists.infradead.org, Wilma.Wu@mediatek.com,
	linux-arm-kernel@lists.infradead.org, shufan_lee@richtek.com
Subject: [PATCH v7 0/11] mfd: mt6360: Merge different sub-devices I2C read/write
Date: Thu, 12 Nov 2020 18:39:47 +0800	[thread overview]
Message-ID: <1605177598-23501-1-git-send-email-gene.chen.richtek@gmail.com> (raw)

This patch series merge different sub-device I2C read/write into one Regmap and
fix coding style for well-organized.

Gene Chen (11)
  mfd: mt6360: Rearrange include file
  mfd: mt6360: Remove redundant brackets around raw numbers
  mfd: mt6360: Indicate sub-dev compatible name by using
  mfd: mt6360: Combine mt6360 pmic/ldo resources into mt6360
  mfd: mt6360: Rename mt6360_pmu_data by mt6360_ddata
  mfd: mt6360: Rename mt6360_pmu by mt6360
  mfd: mt6360: Remove handle_post_irq callback function
  mfd: mt6360: Fix flow which is used to check ic exist
  mfd: mt6360: Merge header file into driver and remove unuse register define
  mfd: mt6360: Merge different sub-devices I2C read/write
  mfd: mt6360: Remove MT6360 regulator of_compatible

 b/drivers/mfd/Kconfig       |    1 
 b/drivers/mfd/mt6360-core.c |  554 +++++++++++++++++++++++++++++---------------
 include/linux/mfd/mt6360.h  |  240 -------------------
 3 files changed, 376 insertions(+), 419 deletions(-)

changelogs between v2 & v3
- Replace mt6360_data to mt6360_ddata
- Split I2C read/write to regmap driver

changelogs between v3 & v4
- Merge back mt6360 regmap driver to MFD driver

changelogs between v4 & v5
- use devm_regmap_init
- define crc calculation magic number

changelogs between v5 & v6
- Remove unrelated change
- Remove regulator device of_compatible

changelogs between v6 & v7
- Replace OF_MFD_CELL by MFD_CELL_RES


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

             reply	other threads:[~2020-11-12 10:40 UTC|newest]

Thread overview: 63+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-12 10:39 Gene Chen [this message]
2020-11-12 10:39 ` [PATCH v7 0/11] mfd: mt6360: Merge different sub-devices I2C read/write Gene Chen
2020-11-12 10:39 ` Gene Chen
2020-11-12 10:39 ` [PATCH v7 01/11] mfd: mt6360: Rearrange include file Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39 ` [PATCH v7 02/11] mfd: mt6360: Remove redundant brackets around raw numbers Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39 ` [PATCH v7 03/11] mfd: mt6360: Indicate sub-dev compatible name by using "-" Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39 ` [PATCH v7 04/11] mfd: mt6360: Combine mt6360 pmic/ldo resources into mt6360 regulator resources Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen
2021-01-12 12:32   ` Matthias Brugger
2021-01-12 12:32     ` Matthias Brugger
2021-01-12 12:32     ` Matthias Brugger
2021-01-15  3:55     ` Gene Chen
2021-01-15  3:55       ` Gene Chen
2021-01-15  3:55       ` Gene Chen
2021-01-15  7:32       ` Lee Jones
2021-01-15  7:32         ` Lee Jones
2021-01-15  7:32         ` Lee Jones
2021-03-02  7:16         ` Gene Chen
2021-03-02  7:16           ` Gene Chen
2021-03-02  7:16           ` Gene Chen
2021-03-22 11:00           ` Gene Chen
2021-03-22 11:00             ` Gene Chen
2021-03-22 11:00             ` Gene Chen
2021-03-23  9:38           ` Lee Jones
2021-03-23  9:38             ` Lee Jones
2021-03-23  9:38             ` Lee Jones
2021-05-11 12:14             ` Gene Chen
2021-05-11 12:14               ` Gene Chen
2021-05-11 12:14               ` Gene Chen
2021-05-12  6:24               ` Lee Jones
2021-05-12  6:24                 ` Lee Jones
2021-05-12  6:24                 ` Lee Jones
2021-03-29 15:38           ` Matthias Brugger
2021-03-29 15:38             ` Matthias Brugger
2021-03-29 15:38             ` Matthias Brugger
2020-11-12 10:39 ` [PATCH v7 05/11] mfd: mt6360: Rename mt6360_pmu_data by mt6360_ddata Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39 ` [PATCH v7 06/11] mfd: mt6360: Rename mt6360_pmu by mt6360 Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39 ` [PATCH v7 07/11] mfd: mt6360: Remove handle_post_irq callback function Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39 ` [PATCH v7 08/11] mfd: mt6360: Fix flow which is used to check ic exist Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39 ` [PATCH v7 09/11] mfd: mt6360: Merge header file into driver and remove unuse register define Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39 ` [PATCH v7 10/11] mfd: mt6360: Merge different sub-devices I2C read/write Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39 ` [PATCH v7 11/11] mfd: mt6360: Remove MT6360 regulator of_compatible attribute Gene Chen
2020-11-12 10:39   ` Gene Chen
2020-11-12 10:39   ` Gene Chen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1605177598-23501-1-git-send-email-gene.chen.richtek@gmail.com \
    --to=gene.chen.richtek@gmail.com \
    --cc=Wilma.Wu@mediatek.com \
    --cc=benjamin.chao@mediatek.com \
    --cc=cy_huang@richtek.com \
    --cc=devicetree@vger.kernel.org \
    --cc=gene_chen@richtek.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=matthias.bgg@gmail.com \
    --cc=robh+dt@kernel.org \
    --cc=shufan_lee@richtek.com \
    --cc=sre@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.