All of lore.kernel.org
 help / color / mirror / Atom feed
From: Arthur Simchaev <Arthur.Simchaev@wdc.com>
To: martin.petersen@oracle.com
Cc: beanhuo@micron.com, linux-scsi@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	Arthur Simchaev <Arthur.Simchaev@wdc.com>
Subject: [PATCH v5 0/4] ufs: core: Always read the descriptors with max length
Date: Sun, 11 Dec 2022 15:05:07 +0200	[thread overview]
Message-ID: <1670763911-8695-1-git-send-email-Arthur.Simchaev@wdc.com> (raw)

v4--v5:
  Change patch 2 according to Bart's comment

v3--v4:
  Add "Reviewed-by" to patch's commits
  Use kzalloc instead of kmalloc in drivers/ufs/core/ufshcd.c - patch 2/4

v2--v3:
  Based on Bean's comments:
  1)Use kzalloc instead of kmalloc in ufshcd_set_active_icc_lvl - patch 2/4
  2)Delete  UFS_RPMB_UNIT definition - patch 2/4
  3)Delete len description - patch 3/4

v1--v2:
  Fix argument warning in ufshpb.c

Read any descriptor with a maximum size of QUERY_DESC_MAX_SIZE.
According to the spec the device rerurns the actual size.
Thus can improve code readability and save CPU cycles.
While at it, cleanup few leftovers around the descriptor size parameter.

Suggested-by: Bean Huo <beanhuo@micron.com>

Arthur Simchaev (4):
  ufs:core: Remove redundant wb check
  ufs:core: Remove redundant desc_size variable from hba
  ufs: core: Remove len parameter from ufshcd_set_active_icc_lvl
  ufs: core: Remove ufshcd_map_desc_id_to_length function

 drivers/ufs/core/ufs_bsg.c     |   7 +--
 drivers/ufs/core/ufshcd-priv.h |   3 --
 drivers/ufs/core/ufshcd.c      | 100 ++++++++++-------------------------------
 drivers/ufs/core/ufshpb.c      |   5 +--
 include/ufs/ufshcd.h           |   1 -
 5 files changed, 26 insertions(+), 90 deletions(-)

-- 
2.7.4


             reply	other threads:[~2022-12-11 13:05 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-12-11 13:05 Arthur Simchaev [this message]
2022-12-11 13:05 ` [PATCH v5 1/4] ufs: core: Remove redundant wb check Arthur Simchaev
2022-12-13  5:32   ` Stanley Chu
2022-12-11 13:05 ` [PATCH v5 2/4] ufs: core: Remove redundant desc_size variable from hba Arthur Simchaev
2022-12-12  0:11   ` Bart Van Assche
2022-12-11 13:05 ` [PATCH v5 3/4] ufs: core: Remove len parameter from ufshcd_set_active_icc_lvl Arthur Simchaev
2022-12-11 13:05 ` [PATCH v5 4/4] ufs: core: Remove ufshcd_map_desc_id_to_length function Arthur Simchaev
2022-12-12  0:18   ` Bart Van Assche
2022-12-12  9:10     ` Arthur Simchaev
2022-12-12 19:25       ` Bart Van Assche
2022-12-12 19:26   ` Bart Van Assche
2022-12-30 21:50 ` [PATCH v5 0/4] ufs: core: Always read the descriptors with max length Martin K. Petersen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1670763911-8695-1-git-send-email-Arthur.Simchaev@wdc.com \
    --to=arthur.simchaev@wdc.com \
    --cc=beanhuo@micron.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.