All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Amir Goldstein <amir73il@gmail.com>,
	linux-fsdevel@vger.kernel.org
Cc: linux-xfs@vger.kernel.org, linux-raid@vger.kernel.org,
	linux-nvdimm@lists.01.org, Shaohua Li <shli@kernel.org>,
	linux-kernel@vger.kernel.org, David Howells <dhowells@redhat.com>,
	linux-block@vger.kernel.org,
	Mimi Zohar <zohar@linux.vnet.ibm.com>,
	Steven Whitehouse <swhiteho@redhat.com>
Subject: [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it
Date: Sun, 28 May 2017 13:19:56 +0300	[thread overview]
Message-ID: <20170528102008.30276-11-hch@lst.de> (raw)
In-Reply-To: <20170528102008.30276-1-hch@lst.de>

And switch to use uuid_t instead of the old uuid_be type.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Amir Goldstein <amir73il@gmail.com>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 arch/s390/include/asm/sysinfo.h | 4 ++--
 arch/s390/kernel/sysinfo.c      | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/s390/include/asm/sysinfo.h b/arch/s390/include/asm/sysinfo.h
index e784bed6ed7f..2b498e58b914 100644
--- a/arch/s390/include/asm/sysinfo.h
+++ b/arch/s390/include/asm/sysinfo.h
@@ -109,7 +109,7 @@ struct sysinfo_2_2_2 {
 	unsigned short cpus_shared;
 	char reserved_4[3];
 	unsigned char vsne;
-	uuid_be uuid;
+	uuid_t uuid;
 	char reserved_5[160];
 	char ext_name[256];
 };
@@ -134,7 +134,7 @@ struct sysinfo_3_2_2 {
 		char reserved_1[3];
 		unsigned char evmne;
 		unsigned int reserved_2;
-		uuid_be uuid;
+		uuid_t uuid;
 	} vm[8];
 	char reserved_3[1504];
 	char ext_names[8][256];
diff --git a/arch/s390/kernel/sysinfo.c b/arch/s390/kernel/sysinfo.c
index eefcb54872a5..fb869b103825 100644
--- a/arch/s390/kernel/sysinfo.c
+++ b/arch/s390/kernel/sysinfo.c
@@ -242,7 +242,7 @@ static void print_ext_name(struct seq_file *m, int lvl,
 
 static void print_uuid(struct seq_file *m, int i, struct sysinfo_3_2_2 *info)
 {
-	if (!memcmp(&info->vm[i].uuid, &NULL_UUID_BE, sizeof(uuid_be)))
+	if (uuid_is_null(&info->vm[i].uuid))
 		return;
 	seq_printf(m, "VM%02d UUID:            %pUb\n", i, &info->vm[i].uuid);
 }
-- 
2.11.0

_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

WARNING: multiple messages have this Message-ID (diff)
From: Christoph Hellwig <hch-jcswGhMUV9g@public.gmane.org>
To: Andy Shevchenko
	<andriy.shevchenko-VuQAYsv1563Yd54FQh9/CA@public.gmane.org>,
	Amir Goldstein <amir73il-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>,
	linux-fsdevel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
Cc: linux-xfs-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	linux-raid-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	linux-nvdimm-hn68Rpc1hR1g9hUCZPvPmw@public.gmane.org,
	Shaohua Li <shli-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org>,
	linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	David Howells <dhowells-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org>,
	linux-block-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	Mimi Zohar
	<zohar-23VcF4HTsmIX0ybBhKVfKdBPR1lH4CV8@public.gmane.org>,
	Steven Whitehouse
	<swhiteho-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org>
Subject: [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it
Date: Sun, 28 May 2017 13:19:56 +0300	[thread overview]
Message-ID: <20170528102008.30276-11-hch@lst.de> (raw)
In-Reply-To: <20170528102008.30276-1-hch-jcswGhMUV9g@public.gmane.org>

And switch to use uuid_t instead of the old uuid_be type.

Signed-off-by: Christoph Hellwig <hch-jcswGhMUV9g@public.gmane.org>
Reviewed-by: Amir Goldstein <amir73il-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>
Reviewed-by: Andy Shevchenko <andriy.shevchenko-VuQAYsv1563Yd54FQh9/CA@public.gmane.org>
---
 arch/s390/include/asm/sysinfo.h | 4 ++--
 arch/s390/kernel/sysinfo.c      | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/s390/include/asm/sysinfo.h b/arch/s390/include/asm/sysinfo.h
index e784bed6ed7f..2b498e58b914 100644
--- a/arch/s390/include/asm/sysinfo.h
+++ b/arch/s390/include/asm/sysinfo.h
@@ -109,7 +109,7 @@ struct sysinfo_2_2_2 {
 	unsigned short cpus_shared;
 	char reserved_4[3];
 	unsigned char vsne;
-	uuid_be uuid;
+	uuid_t uuid;
 	char reserved_5[160];
 	char ext_name[256];
 };
@@ -134,7 +134,7 @@ struct sysinfo_3_2_2 {
 		char reserved_1[3];
 		unsigned char evmne;
 		unsigned int reserved_2;
-		uuid_be uuid;
+		uuid_t uuid;
 	} vm[8];
 	char reserved_3[1504];
 	char ext_names[8][256];
diff --git a/arch/s390/kernel/sysinfo.c b/arch/s390/kernel/sysinfo.c
index eefcb54872a5..fb869b103825 100644
--- a/arch/s390/kernel/sysinfo.c
+++ b/arch/s390/kernel/sysinfo.c
@@ -242,7 +242,7 @@ static void print_ext_name(struct seq_file *m, int lvl,
 
 static void print_uuid(struct seq_file *m, int i, struct sysinfo_3_2_2 *info)
 {
-	if (!memcmp(&info->vm[i].uuid, &NULL_UUID_BE, sizeof(uuid_be)))
+	if (uuid_is_null(&info->vm[i].uuid))
 		return;
 	seq_printf(m, "VM%02d UUID:            %pUb\n", i, &info->vm[i].uuid);
 }
-- 
2.11.0

WARNING: multiple messages have this Message-ID (diff)
From: Christoph Hellwig <hch@lst.de>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Amir Goldstein <amir73il@gmail.com>,
	linux-fsdevel@vger.kernel.org
Cc: Shaohua Li <shli@kernel.org>,
	Dan Williams <dan.j.williams@intel.com>,
	David Howells <dhowells@redhat.com>,
	Steven Whitehouse <swhiteho@redhat.com>,
	Mimi Zohar <zohar@linux.vnet.ibm.com>,
	linux-xfs@vger.kernel.org, linux-raid@vger.kernel.org,
	linux-nvdimm@lists.01.org, linux-kernel@vger.kernel.org,
	linux-block@vger.kernel.org
Subject: [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it
Date: Sun, 28 May 2017 13:19:56 +0300	[thread overview]
Message-ID: <20170528102008.30276-11-hch@lst.de> (raw)
In-Reply-To: <20170528102008.30276-1-hch@lst.de>

And switch to use uuid_t instead of the old uuid_be type.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Amir Goldstein <amir73il@gmail.com>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 arch/s390/include/asm/sysinfo.h | 4 ++--
 arch/s390/kernel/sysinfo.c      | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/s390/include/asm/sysinfo.h b/arch/s390/include/asm/sysinfo.h
index e784bed6ed7f..2b498e58b914 100644
--- a/arch/s390/include/asm/sysinfo.h
+++ b/arch/s390/include/asm/sysinfo.h
@@ -109,7 +109,7 @@ struct sysinfo_2_2_2 {
 	unsigned short cpus_shared;
 	char reserved_4[3];
 	unsigned char vsne;
-	uuid_be uuid;
+	uuid_t uuid;
 	char reserved_5[160];
 	char ext_name[256];
 };
@@ -134,7 +134,7 @@ struct sysinfo_3_2_2 {
 		char reserved_1[3];
 		unsigned char evmne;
 		unsigned int reserved_2;
-		uuid_be uuid;
+		uuid_t uuid;
 	} vm[8];
 	char reserved_3[1504];
 	char ext_names[8][256];
diff --git a/arch/s390/kernel/sysinfo.c b/arch/s390/kernel/sysinfo.c
index eefcb54872a5..fb869b103825 100644
--- a/arch/s390/kernel/sysinfo.c
+++ b/arch/s390/kernel/sysinfo.c
@@ -242,7 +242,7 @@ static void print_ext_name(struct seq_file *m, int lvl,
 
 static void print_uuid(struct seq_file *m, int i, struct sysinfo_3_2_2 *info)
 {
-	if (!memcmp(&info->vm[i].uuid, &NULL_UUID_BE, sizeof(uuid_be)))
+	if (uuid_is_null(&info->vm[i].uuid))
 		return;
 	seq_printf(m, "VM%02d UUID:            %pUb\n", i, &info->vm[i].uuid);
 }
-- 
2.11.0

WARNING: multiple messages have this Message-ID (diff)
From: Christoph Hellwig <hch@lst.de>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Amir Goldstein <amir73il@gmail.com>,
	linux-fsdevel@vger.kernel.org
Cc: Shaohua Li <shli@kernel.org>,
	Dan Williams <dan.j.williams@intel.com>,
	David Howells <dhowells@redhat.com>,
	Steven Whitehouse <swhiteho@redhat.com>,
	Mimi Zohar <zohar@linux.vnet.ibm.com>,
	linux-xfs@vger.kernel.org, linux-raid@vger.kernel.org,
	linux-nvdimm@ml01.01.org, linux-kernel@vger.kernel.org,
	linux-block@vger.kernel.org
Subject: [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it
Date: Sun, 28 May 2017 13:19:56 +0300	[thread overview]
Message-ID: <20170528102008.30276-11-hch@lst.de> (raw)
In-Reply-To: <20170528102008.30276-1-hch@lst.de>

And switch to use uuid_t instead of the old uuid_be type.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Amir Goldstein <amir73il@gmail.com>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 arch/s390/include/asm/sysinfo.h | 4 ++--
 arch/s390/kernel/sysinfo.c      | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/s390/include/asm/sysinfo.h b/arch/s390/include/asm/sysinfo.h
index e784bed6ed7f..2b498e58b914 100644
--- a/arch/s390/include/asm/sysinfo.h
+++ b/arch/s390/include/asm/sysinfo.h
@@ -109,7 +109,7 @@ struct sysinfo_2_2_2 {
 	unsigned short cpus_shared;
 	char reserved_4[3];
 	unsigned char vsne;
-	uuid_be uuid;
+	uuid_t uuid;
 	char reserved_5[160];
 	char ext_name[256];
 };
@@ -134,7 +134,7 @@ struct sysinfo_3_2_2 {
 		char reserved_1[3];
 		unsigned char evmne;
 		unsigned int reserved_2;
-		uuid_be uuid;
+		uuid_t uuid;
 	} vm[8];
 	char reserved_3[1504];
 	char ext_names[8][256];
diff --git a/arch/s390/kernel/sysinfo.c b/arch/s390/kernel/sysinfo.c
index eefcb54872a5..fb869b103825 100644
--- a/arch/s390/kernel/sysinfo.c
+++ b/arch/s390/kernel/sysinfo.c
@@ -242,7 +242,7 @@ static void print_ext_name(struct seq_file *m, int lvl,
 
 static void print_uuid(struct seq_file *m, int i, struct sysinfo_3_2_2 *info)
 {
-	if (!memcmp(&info->vm[i].uuid, &NULL_UUID_BE, sizeof(uuid_be)))
+	if (uuid_is_null(&info->vm[i].uuid))
 		return;
 	seq_printf(m, "VM%02d UUID:            %pUb\n", i, &info->vm[i].uuid);
 }
-- 
2.11.0

  parent reply	other threads:[~2017-05-28 10:20 UTC|newest]

Thread overview: 102+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-05-28 10:19 cleanup UUID types V5 Christoph Hellwig
2017-05-28 10:19 ` Christoph Hellwig
2017-05-28 10:19 ` Christoph Hellwig
2017-05-28 10:19 ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 01/22] Revert "afs: Move UUID struct to linux/uuid.h" Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 02/22] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 03/22] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 04/22] md: namespace private helper names Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 05/22] uuid: remove uuid_be defintions from the uapi header Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 06/22] uuid: rename uuid types Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 07/22] uuid: don't export guid_index and uuid_index Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 08/22] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 09/22] uuid: hoist uuid_is_null() helper from libnvdimm Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` Christoph Hellwig [this message]
2017-05-28 10:19   ` [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 11/22] xfs: remove uuid_getnodeuniq and xfs_uu_t Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 12/22] xfs: use the common helper uuid_is_null() Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19 ` [PATCH 13/22] block: remove blk_part_pack_uuid Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:19   ` Christoph Hellwig
2017-05-28 10:20 ` [PATCH 14/22] ima/policy: switch to use uuid_t Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20 ` [PATCH 15/22] fs: switch ->s_uuid to uuid_t Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20 ` [PATCH 16/22] overlayfs: use uuid_t instead of uuid_be Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20 ` [PATCH 17/22] partitions/ldm: switch to use uuid_t Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20 ` [PATCH 18/22] sysctl: " Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20 ` [PATCH 19/22] nvme: switch to uuid_t Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20 ` [PATCH 20/22] scsi_debug: " Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20 ` [PATCH 21/22] tmpfs: generate random sb->s_uuid Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20 ` [PATCH 22/22] MAINTAINERS: add uuid entry Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-28 10:20   ` Christoph Hellwig
2017-05-30 10:00 ` [PATCH 01/22] Revert "afs: Move UUID struct to linux/uuid.h" David Howells
2017-05-30 10:00   ` David Howells
2017-05-30 10:00   ` David Howells
2017-05-31  9:41   ` Christoph Hellwig
2017-05-31  9:41     ` Christoph Hellwig
2017-05-31  9:41     ` Christoph Hellwig
2017-05-31  9:41     ` Christoph Hellwig
2017-05-31 10:33   ` David Howells
2017-05-31 10:33     ` David Howells
2017-05-31 10:33     ` David Howells
2017-05-31 10:33     ` David Howells

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170528102008.30276-11-hch@lst.de \
    --to=hch@lst.de \
    --cc=amir73il@gmail.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=dhowells@redhat.com \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nvdimm@lists.01.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=shli@kernel.org \
    --cc=swhiteho@redhat.com \
    --cc=zohar@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.