All of lore.kernel.org
 help / color / mirror / Atom feed
From: John Stultz <john.stultz@linaro.org>
To: lkml <linux-kernel@vger.kernel.org>
Cc: Xu YiPing <xuyiping@hisilicon.com>,
	Rongrong Zou <zourongrong@gmail.com>,
	Xinliang Liu <z.liuxinliang@hisilicon.com>,
	David Airlie <airlied@linux.ie>, Daniel Vetter <daniel@ffwll.ch>,
	dri-devel <dri-devel@lists.freedesktop.org>,
	Sam Ravnborg <sam@ravnborg.org>,
	John Stultz <john.stultz@linaro.org>
Subject: [RESEND][PATCH v3 05/26] drm: kirin: Remove uncessary parameter indirection
Date: Wed, 14 Aug 2019 18:46:41 +0000	[thread overview]
Message-ID: <20190814184702.54275-6-john.stultz@linaro.org> (raw)
In-Reply-To: <20190814184702.54275-1-john.stultz@linaro.org>

From: Xu YiPing <xuyiping@hisilicon.com>

In a few functions, we pass in a struct ade_crtc, which we only
use to get to the underlying struct ade_hw_ctx.

Thus this patch refactors the functions to just take the
struct ade_hw_ctx directly.

Cc: Rongrong Zou <zourongrong@gmail.com>
Cc: Xinliang Liu <z.liuxinliang@hisilicon.com>
Cc: David Airlie <airlied@linux.ie>
Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: dri-devel <dri-devel@lists.freedesktop.org>
Cc: Sam Ravnborg <sam@ravnborg.org>
Reviewed-by: Sam Ravnborg <sam@ravnborg.org>
Signed-off-by: Xu YiPing <xuyiping@hisilicon.com>
[jstultz: reworded commit message]
Signed-off-by: John Stultz <john.stultz@linaro.org>
---
 drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)

diff --git a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
index 9a9e3b688ba3..756aefd5bcff 100644
--- a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
+++ b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
@@ -210,11 +210,10 @@ static void ade_set_pix_clk(struct ade_hw_ctx *ctx,
 	adj_mode->clock = clk_get_rate(ctx->ade_pix_clk) / 1000;
 }
 
-static void ade_ldi_set_mode(struct ade_crtc *acrtc,
+static void ade_ldi_set_mode(struct ade_hw_ctx *ctx,
 			     struct drm_display_mode *mode,
 			     struct drm_display_mode *adj_mode)
 {
-	struct ade_hw_ctx *ctx = acrtc->ctx;
 	void __iomem *base = ctx->base;
 	u32 width = mode->hdisplay;
 	u32 height = mode->vdisplay;
@@ -301,9 +300,8 @@ static void ade_power_down(struct ade_hw_ctx *ctx)
 	ctx->power_on = false;
 }
 
-static void ade_set_medianoc_qos(struct ade_crtc *acrtc)
+static void ade_set_medianoc_qos(struct ade_hw_ctx *ctx)
 {
-	struct ade_hw_ctx *ctx = acrtc->ctx;
 	struct regmap *map = ctx->noc_regmap;
 
 	regmap_update_bits(map, ADE0_QOSGENERATOR_MODE,
@@ -515,7 +513,7 @@ static void ade_crtc_atomic_enable(struct drm_crtc *crtc,
 			return;
 	}
 
-	ade_set_medianoc_qos(acrtc);
+	ade_set_medianoc_qos(ctx);
 	ade_display_enable(acrtc);
 	ade_dump_regs(ctx->base);
 	drm_crtc_vblank_on(crtc);
@@ -545,7 +543,7 @@ static void ade_crtc_mode_set_nofb(struct drm_crtc *crtc)
 
 	if (!ctx->power_on)
 		(void)ade_power_up(ctx);
-	ade_ldi_set_mode(acrtc, mode, adj_mode);
+	ade_ldi_set_mode(ctx, mode, adj_mode);
 }
 
 static void ade_crtc_atomic_begin(struct drm_crtc *crtc,
@@ -558,7 +556,7 @@ static void ade_crtc_atomic_begin(struct drm_crtc *crtc,
 
 	if (!ctx->power_on)
 		(void)ade_power_up(ctx);
-	ade_ldi_set_mode(acrtc, mode, adj_mode);
+	ade_ldi_set_mode(ctx, mode, adj_mode);
 }
 
 static void ade_crtc_atomic_flush(struct drm_crtc *crtc,
-- 
2.17.1


WARNING: multiple messages have this Message-ID (diff)
From: John Stultz <john.stultz@linaro.org>
To: lkml <linux-kernel@vger.kernel.org>
Cc: Xu YiPing <xuyiping@hisilicon.com>,
	David Airlie <airlied@linux.ie>,
	dri-devel <dri-devel@lists.freedesktop.org>,
	Xinliang Liu <z.liuxinliang@hisilicon.com>,
	Rongrong Zou <zourongrong@gmail.com>,
	Sam Ravnborg <sam@ravnborg.org>
Subject: [RESEND][PATCH v3 05/26] drm: kirin: Remove uncessary parameter indirection
Date: Wed, 14 Aug 2019 18:46:41 +0000	[thread overview]
Message-ID: <20190814184702.54275-6-john.stultz@linaro.org> (raw)
In-Reply-To: <20190814184702.54275-1-john.stultz@linaro.org>

From: Xu YiPing <xuyiping@hisilicon.com>

In a few functions, we pass in a struct ade_crtc, which we only
use to get to the underlying struct ade_hw_ctx.

Thus this patch refactors the functions to just take the
struct ade_hw_ctx directly.

Cc: Rongrong Zou <zourongrong@gmail.com>
Cc: Xinliang Liu <z.liuxinliang@hisilicon.com>
Cc: David Airlie <airlied@linux.ie>
Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: dri-devel <dri-devel@lists.freedesktop.org>
Cc: Sam Ravnborg <sam@ravnborg.org>
Reviewed-by: Sam Ravnborg <sam@ravnborg.org>
Signed-off-by: Xu YiPing <xuyiping@hisilicon.com>
[jstultz: reworded commit message]
Signed-off-by: John Stultz <john.stultz@linaro.org>
---
 drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)

diff --git a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
index 9a9e3b688ba3..756aefd5bcff 100644
--- a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
+++ b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
@@ -210,11 +210,10 @@ static void ade_set_pix_clk(struct ade_hw_ctx *ctx,
 	adj_mode->clock = clk_get_rate(ctx->ade_pix_clk) / 1000;
 }
 
-static void ade_ldi_set_mode(struct ade_crtc *acrtc,
+static void ade_ldi_set_mode(struct ade_hw_ctx *ctx,
 			     struct drm_display_mode *mode,
 			     struct drm_display_mode *adj_mode)
 {
-	struct ade_hw_ctx *ctx = acrtc->ctx;
 	void __iomem *base = ctx->base;
 	u32 width = mode->hdisplay;
 	u32 height = mode->vdisplay;
@@ -301,9 +300,8 @@ static void ade_power_down(struct ade_hw_ctx *ctx)
 	ctx->power_on = false;
 }
 
-static void ade_set_medianoc_qos(struct ade_crtc *acrtc)
+static void ade_set_medianoc_qos(struct ade_hw_ctx *ctx)
 {
-	struct ade_hw_ctx *ctx = acrtc->ctx;
 	struct regmap *map = ctx->noc_regmap;
 
 	regmap_update_bits(map, ADE0_QOSGENERATOR_MODE,
@@ -515,7 +513,7 @@ static void ade_crtc_atomic_enable(struct drm_crtc *crtc,
 			return;
 	}
 
-	ade_set_medianoc_qos(acrtc);
+	ade_set_medianoc_qos(ctx);
 	ade_display_enable(acrtc);
 	ade_dump_regs(ctx->base);
 	drm_crtc_vblank_on(crtc);
@@ -545,7 +543,7 @@ static void ade_crtc_mode_set_nofb(struct drm_crtc *crtc)
 
 	if (!ctx->power_on)
 		(void)ade_power_up(ctx);
-	ade_ldi_set_mode(acrtc, mode, adj_mode);
+	ade_ldi_set_mode(ctx, mode, adj_mode);
 }
 
 static void ade_crtc_atomic_begin(struct drm_crtc *crtc,
@@ -558,7 +556,7 @@ static void ade_crtc_atomic_begin(struct drm_crtc *crtc,
 
 	if (!ctx->power_on)
 		(void)ade_power_up(ctx);
-	ade_ldi_set_mode(acrtc, mode, adj_mode);
+	ade_ldi_set_mode(ctx, mode, adj_mode);
 }
 
 static void ade_crtc_atomic_flush(struct drm_crtc *crtc,
-- 
2.17.1

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  parent reply	other threads:[~2019-08-14 18:48 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-14 18:46 [RESEND][PATCH v3 00/26] drm: Kirin driver cleanups to prep for Kirin960 support John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 01/26] drm: kirin: Fix for hikey620 display offset problem John Stultz
2019-08-14 18:46   ` John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 02/26] drm: kirin: Get rid of drmP.h includes John Stultz
2019-08-14 18:46   ` John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 03/26] drm: kirin: Remove HISI_KIRIN_DW_DSI config option John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 04/26] drm: kirin: Remove unreachable return John Stultz
2019-08-14 18:46 ` John Stultz [this message]
2019-08-14 18:46   ` [RESEND][PATCH v3 05/26] drm: kirin: Remove uncessary parameter indirection John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 06/26] drm: kirin: Remove out_format from ade_crtc John Stultz
2019-08-14 18:46   ` John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 07/26] drm: kirin: Rename ade_plane to kirin_plane John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 08/26] drm: kirin: Rename ade_crtc to kirin_crtc John Stultz
2019-08-14 18:46   ` John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 09/26] drm: kirin: Dynamically allocate the hw_ctx John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 10/26] drm: kirin: Move request irq handle in ade hw ctx alloc John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 11/26] drm: kirin: Move workqueue to ade_hw_ctx structure John Stultz
2019-08-14 18:46   ` John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 12/26] drm: kirin: Move kirin_crtc, kirin_plane, kirin_format to kirin_drm_drv.h John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 13/26] drm: kirin: Reanme dc_ops to kirin_drm_data John Stultz
2019-08-14 18:46   ` John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 14/26] drm: kirin: Move ade crtc/plane help functions to driver_data John Stultz
2019-08-14 18:46   ` John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 15/26] drm: kirin: Move channel formats to driver data John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 16/26] drm: kirin: Move mode config function to driver_data John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 17/26] drm: kirin: Move plane number and primay plane in driver data John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 18/26] drm: kirin: Move config max_width and max_height to " John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 19/26] drm: kirin: Move drm driver " John Stultz
2019-08-14 18:46   ` John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 20/26] drm: kirin: Add register connect helper functions in drm init John Stultz
2019-08-14 18:46   ` John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 21/26] drm: kirin: Rename plane_init and crtc_init John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 22/26] drm: kirin: Fix dev->driver_data setting John Stultz
2019-08-14 18:46 ` [RESEND][PATCH v3 23/26] drm: kirin: Make driver_data variable non-global John Stultz
2019-08-14 18:47 ` [RESEND][PATCH v3 24/26] drm: kirin: Add alloc_hw_ctx/clean_hw_ctx ops in driver data John Stultz
2019-08-14 18:47 ` [RESEND][PATCH v3 25/26] drm: kirin: Pass driver data to crtc init and plane init John Stultz
2019-08-14 18:47 ` [RESEND][PATCH v3 26/26] drm: kirin: Move ade drm init to kirin drm drv John Stultz
2019-08-14 19:45 ` [RESEND][PATCH v3 00/26] drm: Kirin driver cleanups to prep for Kirin960 support Sam Ravnborg
2019-08-14 19:45   ` Sam Ravnborg
2019-08-19  2:07   ` xinliang
2019-08-19  2:07     ` xinliang
2019-08-19  4:40     ` Sam Ravnborg
2019-08-19  4:40       ` Sam Ravnborg
2019-08-19 23:25       ` John Stultz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190814184702.54275-6-john.stultz@linaro.org \
    --to=john.stultz@linaro.org \
    --cc=airlied@linux.ie \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sam@ravnborg.org \
    --cc=xuyiping@hisilicon.com \
    --cc=z.liuxinliang@hisilicon.com \
    --cc=zourongrong@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.