All of lore.kernel.org
 help / color / mirror / Atom feed
From: afzal mohammed <afzal.mohd.ma@gmail.com>
To: Arnd Bergmann <arnd@arndb.de>, SoC Team <soc@kernel.org>
Cc: "afzal mohammed" <afzal.mohd.ma@gmail.com>,
	"Thomas Gleixner" <tglx@linutronix.de>,
	"Tony Lindgren" <tony@atomide.com>,
	"Alexander Sverdlin" <alexander.sverdlin@gmail.com>,
	"Krzysztof Hałasa" <khalasa@piap.pl>,
	"Viresh Kumar" <viresh.kumar@linaro.org>,
	"Lubomir Rintel" <lkundrak@v3.sk>,
	"Gregory CLEMENT" <gregory.clement@bootlin.com>,
	"Hartley Sweeten" <hsweeten@visionengravers.com>,
	"Viresh Kumar" <vireshk@kernel.org>,
	"Shiraz Hashim" <shiraz.linux.kernel@gmail.com>,
	"Andrew Lunn" <andrew@lunn.ch>,
	"Jason Cooper" <jason@lakedaemon.net>,
	"Sebastian Hesselbarth" <sebastian.hesselbarth@gmail.com>,
	"Russell King" <linux@armlinux.org.uk>,
	"Linux ARM" <linux-arm-kernel@lists.infradead.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	arm-soc <arm@kernel.org>, "Olof Johansson" <olof@lixom.net>
Subject: [PATCH v4 4/5] ARM: mmp: replace setup_irq() by request_irq()
Date: Fri, 27 Mar 2020 18:14:37 +0530	[thread overview]
Message-ID: <20200327124437.4239-1-afzal.mohd.ma@gmail.com> (raw)
In-Reply-To: <CAK8P3a2sqika7=3D6Zgkz+v8HtGEc0q0+skWG8mSKuL+qSoYLw@mail.gmail.com>

request_irq() is preferred over setup_irq(). Invocations of setup_irq()
occur after memory allocators are ready.

Per tglx[1], setup_irq() existed in olden days when allocators were not
ready by the time early interrupts were initialized.

Hence replace setup_irq() by request_irq().

[1] https://lkml.kernel.org/r/alpine.DEB.2.20.1710191609480.1971@nanos

Signed-off-by: afzal mohammed <afzal.mohd.ma@gmail.com>
Acked-by: Lubomir Rintel <lkundrak@v3.sk>
Tested-by: Lubomir Rintel <lkundrak@v3.sk>
---

v4:
 * Add received tags

v3:
 * Split out from series, also split out from ARM patch to subarch level
	as Thomas suggested to take it thr' respective maintainers
 * Modify string displayed in case of error as suggested by Thomas
 * Re-arrange code as required to improve readability
 * Remove irrelevant parts from commit message & improve
 
v2:
 * Replace pr_err("request_irq() on %s failed" by
           pr_err("%s: request_irq() failed"
 * Commit message massage

 arch/arm/mach-mmp/time.c | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/arch/arm/mach-mmp/time.c b/arch/arm/mach-mmp/time.c
index c65cfc1ad99b..049a65f47b42 100644
--- a/arch/arm/mach-mmp/time.c
+++ b/arch/arm/mach-mmp/time.c
@@ -175,13 +175,6 @@ static void __init timer_config(void)
 	__raw_writel(0x2, mmp_timer_base + TMR_CER);
 }
 
-static struct irqaction timer_irq = {
-	.name		= "timer",
-	.flags		= IRQF_TIMER | IRQF_IRQPOLL,
-	.handler	= timer_interrupt,
-	.dev_id		= &ckevt,
-};
-
 void __init mmp_timer_init(int irq, unsigned long rate)
 {
 	timer_config();
@@ -190,7 +183,9 @@ void __init mmp_timer_init(int irq, unsigned long rate)
 
 	ckevt.cpumask = cpumask_of(0);
 
-	setup_irq(irq, &timer_irq);
+	if (request_irq(irq, timer_interrupt, IRQF_TIMER | IRQF_IRQPOLL,
+			"timer", &ckevt))
+		pr_err("Failed to request irq %d (timer)\n", irq);
 
 	clocksource_register_hz(&cksrc, rate);
 	clockevents_config_and_register(&ckevt, rate, MIN_DELTA, MAX_DELTA);
-- 
2.25.1


WARNING: multiple messages have this Message-ID (diff)
From: afzal mohammed <afzal.mohd.ma@gmail.com>
To: Arnd Bergmann <arnd@arndb.de>, SoC Team <soc@kernel.org>
Cc: "Andrew Lunn" <andrew@lunn.ch>,
	"Jason Cooper" <jason@lakedaemon.net>,
	"Hartley Sweeten" <hsweeten@visionengravers.com>,
	"Tony Lindgren" <tony@atomide.com>,
	"afzal mohammed" <afzal.mohd.ma@gmail.com>,
	"Gregory CLEMENT" <gregory.clement@bootlin.com>,
	"Russell King" <linux@armlinux.org.uk>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"Lubomir Rintel" <lkundrak@v3.sk>, arm-soc <arm@kernel.org>,
	"Krzysztof Hałasa" <khalasa@piap.pl>,
	"Viresh Kumar" <viresh.kumar@linaro.org>,
	"Olof Johansson" <olof@lixom.net>,
	"Thomas Gleixner" <tglx@linutronix.de>,
	"Sebastian Hesselbarth" <sebastian.hesselbarth@gmail.com>,
	"Alexander Sverdlin" <alexander.sverdlin@gmail.com>,
	"Shiraz Hashim" <shiraz.linux.kernel@gmail.com>,
	"Linux ARM" <linux-arm-kernel@lists.infradead.org>,
	"Viresh Kumar" <vireshk@kernel.org>
Subject: [PATCH v4 4/5] ARM: mmp: replace setup_irq() by request_irq()
Date: Fri, 27 Mar 2020 18:14:37 +0530	[thread overview]
Message-ID: <20200327124437.4239-1-afzal.mohd.ma@gmail.com> (raw)
In-Reply-To: <CAK8P3a2sqika7=3D6Zgkz+v8HtGEc0q0+skWG8mSKuL+qSoYLw@mail.gmail.com>

request_irq() is preferred over setup_irq(). Invocations of setup_irq()
occur after memory allocators are ready.

Per tglx[1], setup_irq() existed in olden days when allocators were not
ready by the time early interrupts were initialized.

Hence replace setup_irq() by request_irq().

[1] https://lkml.kernel.org/r/alpine.DEB.2.20.1710191609480.1971@nanos

Signed-off-by: afzal mohammed <afzal.mohd.ma@gmail.com>
Acked-by: Lubomir Rintel <lkundrak@v3.sk>
Tested-by: Lubomir Rintel <lkundrak@v3.sk>
---

v4:
 * Add received tags

v3:
 * Split out from series, also split out from ARM patch to subarch level
	as Thomas suggested to take it thr' respective maintainers
 * Modify string displayed in case of error as suggested by Thomas
 * Re-arrange code as required to improve readability
 * Remove irrelevant parts from commit message & improve
 
v2:
 * Replace pr_err("request_irq() on %s failed" by
           pr_err("%s: request_irq() failed"
 * Commit message massage

 arch/arm/mach-mmp/time.c | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/arch/arm/mach-mmp/time.c b/arch/arm/mach-mmp/time.c
index c65cfc1ad99b..049a65f47b42 100644
--- a/arch/arm/mach-mmp/time.c
+++ b/arch/arm/mach-mmp/time.c
@@ -175,13 +175,6 @@ static void __init timer_config(void)
 	__raw_writel(0x2, mmp_timer_base + TMR_CER);
 }
 
-static struct irqaction timer_irq = {
-	.name		= "timer",
-	.flags		= IRQF_TIMER | IRQF_IRQPOLL,
-	.handler	= timer_interrupt,
-	.dev_id		= &ckevt,
-};
-
 void __init mmp_timer_init(int irq, unsigned long rate)
 {
 	timer_config();
@@ -190,7 +183,9 @@ void __init mmp_timer_init(int irq, unsigned long rate)
 
 	ckevt.cpumask = cpumask_of(0);
 
-	setup_irq(irq, &timer_irq);
+	if (request_irq(irq, timer_interrupt, IRQF_TIMER | IRQF_IRQPOLL,
+			"timer", &ckevt))
+		pr_err("Failed to request irq %d (timer)\n", irq);
 
 	clocksource_register_hz(&cksrc, rate);
 	clockevents_config_and_register(&ckevt, rate, MIN_DELTA, MAX_DELTA);
-- 
2.25.1


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  parent reply	other threads:[~2020-03-27 12:44 UTC|newest]

Thread overview: 59+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-03-01 12:19 [PATCH v3] ARM: OMAP: replace setup_irq() by request_irq() afzal mohammed
2020-03-01 12:19 ` afzal mohammed
2020-03-04 16:34 ` Tony Lindgren
2020-03-04 16:34   ` Tony Lindgren
2020-03-13 15:45   ` [PATCH v3] ARM: " afzal mohammed
2020-03-13 15:45     ` afzal mohammed
2020-03-17  4:37     ` afzal mohammed
2020-03-17  4:37       ` afzal mohammed
2020-03-25 11:43       ` afzal mohammed
2020-03-25 11:43         ` afzal mohammed
2020-03-27 10:46         ` afzal mohammed
2020-03-27 10:46           ` afzal mohammed
2020-03-27 10:55           ` Arnd Bergmann
2020-03-27 10:55             ` Arnd Bergmann
2020-03-27 11:10             ` afzal mohammed
2020-03-27 11:10               ` afzal mohammed
2020-03-27 11:29               ` afzal mohammed
2020-03-27 11:29                 ` afzal mohammed
2020-03-27 11:58                 ` Arnd Bergmann
2020-03-27 11:58                   ` Arnd Bergmann
2020-03-27 12:41                   ` [PATCH v4 1/5] ARM: ep93xx: Replace " afzal mohammed
2020-03-27 12:41                     ` afzal mohammed
2020-03-27 12:44                   ` [PATCH v4 2/5] ARM: spear: replace " afzal mohammed
2020-03-27 12:44                     ` afzal mohammed
2020-03-27 12:44                   ` [PATCH v4 3/5] ARM: cns3xxx: " afzal mohammed
2020-03-27 12:44                     ` afzal mohammed
2020-03-27 12:44                   ` afzal mohammed [this message]
2020-03-27 12:44                     ` [PATCH v4 4/5] ARM: mmp: " afzal mohammed
2020-03-27 12:44                   ` [PATCH v4 5/5] ARM: iop32x: " afzal mohammed
2020-03-27 12:44                     ` afzal mohammed
2020-03-27 12:53                   ` [PATCH v3] ARM: " afzal mohammed
2020-03-27 12:53                     ` afzal mohammed
2020-03-01 12:21 [PATCH v3] ARM: ep93xx: Replace " afzal mohammed
2020-03-01 12:21 ` afzal mohammed
2020-03-01 16:21 ` Alexander Sverdlin
2020-03-01 16:21   ` Alexander Sverdlin
2020-03-01 12:22 [PATCH v3] ARM: mmp: replace " afzal mohammed
2020-03-01 12:22 ` afzal mohammed
2020-03-08 14:53 ` afzal mohammed
2020-03-08 14:53   ` afzal mohammed
2020-03-08 16:19   ` Lubomir Rintel
2020-03-01 12:22     ` [PATCH v3] ARM: iop32x: " afzal mohammed
2020-03-01 12:22       ` afzal mohammed
2020-03-09 12:19     ` [PATCH v3] ARM: mmp: " afzal mohammed
2020-03-09 12:19       ` afzal mohammed
2020-03-01 12:23 [PATCH v3] ARM: spear: " afzal mohammed
2020-03-01 12:23 ` afzal mohammed
2020-03-02  3:17 ` Viresh Kumar
2020-03-02  3:17   ` Viresh Kumar
2020-03-01 12:23 [PATCH v3] ARM: orion: " afzal mohammed
2020-03-01 12:23 ` afzal mohammed
2020-03-01 15:44 ` Andrew Lunn
2020-03-01 15:44   ` Andrew Lunn
2020-03-08 14:37   ` afzal mohammed
2020-03-08 14:37     ` afzal mohammed
2020-03-09 16:17     ` Gregory CLEMENT
2020-03-09 16:17       ` Gregory CLEMENT
2020-03-13 20:39 ` Gregory CLEMENT
2020-03-13 20:39   ` Gregory CLEMENT

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200327124437.4239-1-afzal.mohd.ma@gmail.com \
    --to=afzal.mohd.ma@gmail.com \
    --cc=alexander.sverdlin@gmail.com \
    --cc=andrew@lunn.ch \
    --cc=arm@kernel.org \
    --cc=arnd@arndb.de \
    --cc=gregory.clement@bootlin.com \
    --cc=hsweeten@visionengravers.com \
    --cc=jason@lakedaemon.net \
    --cc=khalasa@piap.pl \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=lkundrak@v3.sk \
    --cc=olof@lixom.net \
    --cc=sebastian.hesselbarth@gmail.com \
    --cc=shiraz.linux.kernel@gmail.com \
    --cc=soc@kernel.org \
    --cc=tglx@linutronix.de \
    --cc=tony@atomide.com \
    --cc=viresh.kumar@linaro.org \
    --cc=vireshk@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.