All of lore.kernel.org
 help / color / mirror / Atom feed
From: Allison Collins <allison.henderson@oracle.com>
To: linux-xfs@vger.kernel.org
Subject: [PATCH v8 00/39] xfsprogs: Delay Ready Attributes
Date: Fri,  3 Apr 2020 15:09:19 -0700	[thread overview]
Message-ID: <20200403220958.4944-1-allison.henderson@oracle.com> (raw)


Hi all,

This set applies the corresponding changes for delayed ready attributes to
xfsprogs. I will pick up the reviews from the kernel side series and mirror
them here.  This set also includes some patches from the kernel side that have
not yet been ported.  They are not part of the delayed ready attr set, but
they are required in order for the kernel side ports to seat correctly.

This series can also be viewed on github here:
https://github.com/allisonhenderson/xfs_work/tree/delay_ready_attrs_xfsprogs_v8

And also the extended delayed attribute and parent pointer series:
https://github.com/allisonhenderson/xfs_work/tree/delay_ready_attrs_xfsprogs_v8_extended

Thanks all!
Allison

Allison Collins (39):
  xfsprogs: remove the ATTR_INCOMPLETE flag
  xfsprogs: merge xfs_attr_remove into xfs_attr_set
  xfsprogs: remove the name == NULL check from xfs_attr_args_init
  xfsprogs: remove the MAXNAMELEN check from xfs_attr_args_init
  xfsprogs: turn xfs_da_args.value into a void pointer
  xfsprogs: pass an initialized xfs_da_args structure to xfs_attr_set
  xfsprogs: pass an initialized xfs_da_args to xfs_attr_get
  xfsprogs: remove the xfs_inode argument to xfs_attr_get_ilocked
  xfsprogs: remove ATTR_KERNOVAL
  xfsprogs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL
  xfsprogs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME
  xfsprogs: factor out a xfs_attr_match helper
  xfsprogs: cleanup struct xfs_attr_list_context
  xfsprogs: remove the unused ATTR_ENTRY macro
  xfsprogs: move the legacy xfs_attr_list to xfs_ioctl.c
  xfsprogs: rename xfs_attr_list_int to xfs_attr_list
  xfsprogs: clean up the ATTR_REPLACE checks
  xfsprogs: clean up the attr flag confusion
  xfsprogs: embedded the attrlist cursor into struct
    xfs_attr_list_context
  xfsprogs: Add xfs_has_attr and subroutines
  xfsprogs: Check for -ENOATTR or -EEXIST
  xfsprogs: Factor out new helper functions xfs_attr_rmtval_set
  xfsprogs: Pull up trans handling in xfs_attr3_leaf_flipflags
  xfsprogs: Split apart xfs_attr_leaf_addname
  xfsprogs: Refactor xfs_attr_try_sf_addname
  xfsprogs: Pull up trans roll from xfs_attr3_leaf_setflag
  xfsprogs: Factor out xfs_attr_rmtval_invalidate
  xfsprogs: Pull up trans roll in xfs_attr3_leaf_clearflag
  xfsprogs: Add helper function __xfs_attr_rmtval_remove
  xfsprogs: Add helper function xfs_attr_node_shrink
  xfsprogs: Removed unneeded xfs_trans_roll_inode calls
  xfsprogs: Add helpers xfs_attr_is_shortform and xfs_attr_set_shortform
  xfsprogs: Add helper function xfs_attr_leaf_mark_incomplete
  xfsprogs: Add remote block helper functions
  xfsprogs: Add helper function xfs_attr_node_removename_setup
  xfsprogs: Add helper function xfs_attr_node_removename_rmt
  xfsprogs: Add delay ready attr remove routines
  xfsprogs: Add delay ready attr set routines
  xfsprogs: Rename __xfs_attr_rmtval_remove

 db/attrset.c             |   61 +-
 include/libxfs.h         |    1 +
 libxfs/libxfs_api_defs.h |    9 +-
 libxfs/xfs_attr.c        | 1389 +++++++++++++++++++++++++++++-----------------
 libxfs/xfs_attr.h        |  169 +++---
 libxfs/xfs_attr_leaf.c   |  211 +++----
 libxfs/xfs_attr_leaf.h   |    4 +-
 libxfs/xfs_attr_remote.c |  259 ++++++---
 libxfs/xfs_attr_remote.h |    7 +-
 libxfs/xfs_da_btree.h    |    9 +-
 libxfs/xfs_da_format.h   |   12 -
 libxfs/xfs_fs.h          |   32 +-
 12 files changed, 1321 insertions(+), 842 deletions(-)

-- 
2.7.4


             reply	other threads:[~2020-04-03 22:10 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-03 22:09 Allison Collins [this message]
2020-04-03 22:09 ` [PATCH v8 01/39] xfsprogs: remove the ATTR_INCOMPLETE flag Allison Collins
2020-04-03 22:09 ` [PATCH v8 02/39] xfsprogs: merge xfs_attr_remove into xfs_attr_set Allison Collins
2020-04-03 22:09 ` [PATCH v8 03/39] xfsprogs: remove the name == NULL check from xfs_attr_args_init Allison Collins
2020-04-03 22:09 ` [PATCH v8 04/39] xfsprogs: remove the MAXNAMELEN " Allison Collins
2020-04-03 22:09 ` [PATCH v8 05/39] xfsprogs: turn xfs_da_args.value into a void pointer Allison Collins
2020-04-03 22:09 ` [PATCH v8 06/39] xfsprogs: pass an initialized xfs_da_args structure to xfs_attr_set Allison Collins
2020-04-03 22:09 ` [PATCH v8 07/39] xfsprogs: pass an initialized xfs_da_args to xfs_attr_get Allison Collins
2020-04-03 22:09 ` [PATCH v8 08/39] xfsprogs: remove the xfs_inode argument to xfs_attr_get_ilocked Allison Collins
2020-04-03 22:09 ` [PATCH v8 09/39] xfsprogs: remove ATTR_KERNOVAL Allison Collins
2020-04-03 22:09 ` [PATCH v8 10/39] xfsprogs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL Allison Collins
2020-04-03 22:09 ` [PATCH v8 11/39] xfsprogs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME Allison Collins
2020-04-03 22:09 ` [PATCH v8 12/39] xfsprogs: factor out a xfs_attr_match helper Allison Collins
2020-04-03 22:09 ` [PATCH v8 13/39] xfsprogs: cleanup struct xfs_attr_list_context Allison Collins
2020-04-03 22:09 ` [PATCH v8 14/39] xfsprogs: remove the unused ATTR_ENTRY macro Allison Collins
2020-04-03 22:09 ` [PATCH v8 15/39] xfsprogs: move the legacy xfs_attr_list to xfs_ioctl.c Allison Collins
2020-04-03 22:09 ` [PATCH v8 16/39] xfsprogs: rename xfs_attr_list_int to xfs_attr_list Allison Collins
2020-04-03 22:09 ` [PATCH v8 17/39] xfsprogs: clean up the ATTR_REPLACE checks Allison Collins
2020-04-03 22:09 ` [PATCH v8 18/39] xfsprogs: clean up the attr flag confusion Allison Collins
2020-04-03 22:09 ` [PATCH v8 19/39] xfsprogs: embedded the attrlist cursor into struct xfs_attr_list_context Allison Collins
2020-04-03 22:09 ` [PATCH v8 20/39] xfsprogs: Add xfs_has_attr and subroutines Allison Collins
2020-04-03 22:09 ` [PATCH v8 21/39] xfsprogs: Check for -ENOATTR or -EEXIST Allison Collins
2020-04-03 22:09 ` [PATCH v8 22/39] xfsprogs: Factor out new helper functions xfs_attr_rmtval_set Allison Collins
2020-04-03 22:09 ` [PATCH v8 23/39] xfsprogs: Pull up trans handling in xfs_attr3_leaf_flipflags Allison Collins
2020-04-03 22:09 ` [PATCH v8 24/39] xfsprogs: Split apart xfs_attr_leaf_addname Allison Collins
2020-04-03 22:09 ` [PATCH v8 25/39] xfsprogs: Refactor xfs_attr_try_sf_addname Allison Collins
2020-04-03 22:09 ` [PATCH v8 26/39] xfsprogs: Pull up trans roll from xfs_attr3_leaf_setflag Allison Collins
2020-04-03 22:09 ` [PATCH v8 27/39] xfsprogs: Factor out xfs_attr_rmtval_invalidate Allison Collins
2020-04-03 22:09 ` [PATCH v8 28/39] xfsprogs: Pull up trans roll in xfs_attr3_leaf_clearflag Allison Collins
2020-04-03 22:09 ` [PATCH v8 29/39] xfsprogs: Add helper function __xfs_attr_rmtval_remove Allison Collins
2020-04-03 22:09 ` [PATCH v8 30/39] xfsprogs: Add helper function xfs_attr_node_shrink Allison Collins
2020-04-03 22:09 ` [PATCH v8 31/39] xfsprogs: Removed unneeded xfs_trans_roll_inode calls Allison Collins
2020-04-03 22:09 ` [PATCH v8 32/39] xfsprogs: Add helpers xfs_attr_is_shortform and xfs_attr_set_shortform Allison Collins
2020-04-03 22:09 ` [PATCH v8 33/39] xfsprogs: Add helper function xfs_attr_leaf_mark_incomplete Allison Collins
2020-04-03 22:09 ` [PATCH v8 34/39] xfsprogs: Add remote block helper functions Allison Collins
2020-04-03 22:09 ` [PATCH v8 35/39] xfsprogs: Add helper function xfs_attr_node_removename_setup Allison Collins
2020-04-03 22:09 ` [PATCH v8 36/39] xfsprogs: Add helper function xfs_attr_node_removename_rmt Allison Collins
2020-04-03 22:09 ` [PATCH v8 37/39] xfsprogs: Add delay ready attr remove routines Allison Collins
2020-04-03 22:09 ` [PATCH v8 38/39] xfsprogs: Add delay ready attr set routines Allison Collins
2020-04-03 22:09 ` [PATCH v8 39/39] xfsprogs: Rename __xfs_attr_rmtval_remove Allison Collins

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200403220958.4944-1-allison.henderson@oracle.com \
    --to=allison.henderson@oracle.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.