All of lore.kernel.org
 help / color / mirror / Atom feed
From: Allison Collins <allison.henderson@oracle.com>
To: linux-xfs@vger.kernel.org
Subject: [PATCH v9 05/43] xfsprogs: turn xfs_da_args.value into a void pointer
Date: Thu, 30 Apr 2020 15:46:22 -0700	[thread overview]
Message-ID: <20200430224700.4183-6-allison.henderson@oracle.com> (raw)
In-Reply-To: <20200430224700.4183-1-allison.henderson@oracle.com>

The xattr values are blobs and should not be typed.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Dave Chinner <dchinner@redhat.com>
Reviewed-by: Darrick J. Wong <darrick.wong@oracle.com>
Signed-off-by: Darrick J. Wong <darrick.wong@oracle.com>
Signed-off-by: Allison Collins <allison.henderson@oracle.com>
---
 libxfs/xfs_da_btree.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/libxfs/xfs_da_btree.h b/libxfs/xfs_da_btree.h
index 0f4fbb0..0967d1b 100644
--- a/libxfs/xfs_da_btree.h
+++ b/libxfs/xfs_da_btree.h
@@ -57,7 +57,7 @@ typedef struct xfs_da_args {
 	const uint8_t		*name;		/* string (maybe not NULL terminated) */
 	int		namelen;	/* length of string (maybe no NULL) */
 	uint8_t		filetype;	/* filetype of inode for directories */
-	uint8_t		*value;		/* set of bytes (maybe contain NULLs) */
+	void		*value;		/* set of bytes (maybe contain NULLs) */
 	int		valuelen;	/* length of value */
 	int		flags;		/* argument flags (eg: ATTR_NOCREATE) */
 	xfs_dahash_t	hashval;	/* hash value of name */
-- 
2.7.4


  parent reply	other threads:[~2020-04-30 22:47 UTC|newest]

Thread overview: 46+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-30 22:46 [PATCH v9 00/43] xfsprogs: Delay Ready Attributes Allison Collins
2020-04-30 22:46 ` [PATCH v9 01/43] xfsprogs: remove the ATTR_INCOMPLETE flag Allison Collins
2020-04-30 22:46 ` [PATCH v9 02/43] xfsprogs: merge xfs_attr_remove into xfs_attr_set Allison Collins
2020-04-30 22:46 ` [PATCH v9 03/43] xfsprogs: remove the name == NULL check from xfs_attr_args_init Allison Collins
2020-04-30 22:46 ` [PATCH v9 04/43] xfsprogs: remove the MAXNAMELEN " Allison Collins
2020-04-30 22:46 ` Allison Collins [this message]
2020-04-30 22:46 ` [PATCH v9 06/43] xfsprogs: pass an initialized xfs_da_args structure to xfs_attr_set Allison Collins
2020-04-30 22:46 ` [PATCH v9 07/43] xfsprogs: pass an initialized xfs_da_args to xfs_attr_get Allison Collins
2020-04-30 22:46 ` [PATCH v9 08/43] xfsprogs: remove the xfs_inode argument to xfs_attr_get_ilocked Allison Collins
2020-04-30 22:46 ` [PATCH v9 09/43] xfsprogs: remove ATTR_KERNOVAL Allison Collins
2020-04-30 22:46 ` [PATCH v9 10/43] xfsprogs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL Allison Collins
2020-04-30 22:46 ` [PATCH v9 11/43] xfsprogs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME Allison Collins
2020-04-30 22:46 ` [PATCH v9 12/43] xfsprogs: factor out a xfs_attr_match helper Allison Collins
2020-04-30 22:46 ` [PATCH v9 13/43] xfsprogs: cleanup struct xfs_attr_list_context Allison Collins
2020-04-30 22:46 ` [PATCH v9 14/43] xfsprogs: remove the unused ATTR_ENTRY macro Allison Collins
2020-04-30 22:46 ` [PATCH v9 15/43] xfsprogs: move the legacy xfs_attr_list to xfs_ioctl.c Allison Collins
2020-04-30 22:46 ` [PATCH v9 16/43] xfsprogs: rename xfs_attr_list_int to xfs_attr_list Allison Collins
2020-04-30 22:46 ` [PATCH v9 17/43] xfsprogs: clean up the ATTR_REPLACE checks Allison Collins
2020-04-30 22:46 ` [PATCH v9 18/43] xfsprogs: clean up the attr flag confusion Allison Collins
2020-04-30 22:46 ` [PATCH v9 19/43] xfsprogs: embedded the attrlist cursor into struct xfs_attr_list_context Allison Collins
2020-04-30 22:46 ` [PATCH v9 20/43] xfsprogs: Add xfs_has_attr and subroutines Allison Collins
2020-04-30 22:46 ` [PATCH v9 21/43] xfsprogs: Check for -ENOATTR or -EEXIST Allison Collins
2020-04-30 22:46 ` [PATCH v9 22/43] xfsprogs: Factor out new helper functions xfs_attr_rmtval_set Allison Collins
2020-04-30 22:46 ` [PATCH v9 23/43] xfsprogs: Pull up trans handling in xfs_attr3_leaf_flipflags Allison Collins
2020-04-30 22:46 ` [PATCH v9 24/43] xfsprogs: Split apart xfs_attr_leaf_addname Allison Collins
2020-05-04 17:32   ` Darrick J. Wong
2020-05-04 22:33     ` Allison Collins
2020-04-30 22:46 ` [PATCH v9 25/43] xfsprogs: Refactor xfs_attr_try_sf_addname Allison Collins
2020-04-30 22:46 ` [PATCH v9 26/43] xfsprogs: Pull up trans roll from xfs_attr3_leaf_setflag Allison Collins
2020-04-30 22:46 ` [PATCH v9 27/43] xfsprogs: Factor out xfs_attr_rmtval_invalidate Allison Collins
2020-04-30 22:46 ` [PATCH v9 28/43] xfsprogs: Pull up trans roll in xfs_attr3_leaf_clearflag Allison Collins
2020-04-30 22:46 ` [PATCH v9 29/43] xfsprogs: Add helper function __xfs_attr_rmtval_remove Allison Collins
2020-04-30 22:46 ` [PATCH v9 30/43] xfsprogs: Pull up xfs_attr_rmtval_invalidate Allison Collins
2020-04-30 22:46 ` [PATCH v9 31/43] xfsprogs: Add helper function xfs_attr_node_shrink Allison Collins
2020-04-30 22:46 ` [PATCH v9 32/43] xfsprogs: Remove unneeded xfs_trans_roll_inode calls Allison Collins
2020-04-30 22:46 ` [PATCH v9 33/43] xfsprogs: Add helpers xfs_attr_is_shortform and xfs_attr_set_shortform Allison Collins
2020-04-30 22:46 ` [PATCH v9 34/43] xfsprogs: Add helper function xfs_attr_leaf_mark_incomplete Allison Collins
2020-04-30 22:46 ` [PATCH v9 35/43] xfsprogs: Add remote block helper functions Allison Collins
2020-04-30 22:46 ` [PATCH v9 36/43] xfsprogs: Add helper function xfs_attr_node_removename_setup Allison Collins
2020-04-30 22:46 ` [PATCH v9 37/43] xfsprogs: Add helper function xfs_attr_node_removename_rmt Allison Collins
2020-04-30 22:46 ` [PATCH v9 38/43] xfsprogs: Simplify xfs_attr_leaf_addname Allison Collins
2020-04-30 22:46 ` [PATCH v9 39/43] xfsprogs: Simplify xfs_attr_node_addname Allison Collins
2020-04-30 22:46 ` [PATCH v9 40/43] xfsprogs: Lift -ENOSPC handler from xfs_attr_leaf_addname Allison Collins
2020-04-30 22:46 ` [PATCH v9 41/43] xfsprogs: Add delay ready attr remove routines Allison Collins
2020-04-30 22:46 ` [PATCH v9 42/43] xfsprogs: Add delay ready attr set routines Allison Collins
2020-04-30 22:47 ` [PATCH v9 43/43] xfsprogs: Rename __xfs_attr_rmtval_remove Allison Collins

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200430224700.4183-6-allison.henderson@oracle.com \
    --to=allison.henderson@oracle.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.