All of lore.kernel.org
 help / color / mirror / Atom feed
From: Eric Biggers <ebiggers at kernel.org>
To: mptcp at lists.01.org
Subject: [MPTCP] [PATCH v2 0/5] crypto: add sha256() function
Date: Wed, 08 Jul 2020 09:39:38 -0700	[thread overview]
Message-ID: <20200708163943.52071-1-ebiggers@kernel.org> (raw)

[-- Attachment #1: Type: text/plain, Size: 1180 bytes --]

This series adds a function sha256() to the sha256 library so that users
who want to compute a hash in one step can just call sha256() instead of
sha256_init() + sha256_update() + sha256_final().

Patches 3-5 then convert some users to use it.

Changed v1 => v2:
  - Added sparc patch to fix a build breakage caused by a
    static variable already named "sha256".
  - Added Reviewed-by, Acked-by, and Tested-by tags.

Eric Biggers (5):
  crypto: sparc - rename sha256 to sha256_alg
  crypto: lib/sha256 - add sha256() function
  efi: use sha256() instead of open coding
  mptcp: use sha256() instead of open coding
  ASoC: cros_ec_codec: use sha256() instead of open coding

 arch/sparc/crypto/sha256_glue.c          | 14 ++++++------
 drivers/firmware/efi/embedded-firmware.c |  9 +++-----
 include/crypto/sha.h                     |  1 +
 lib/crypto/sha256.c                      | 10 +++++++++
 net/mptcp/crypto.c                       | 15 +++----------
 sound/soc/codecs/cros_ec_codec.c         | 27 ++----------------------
 6 files changed, 26 insertions(+), 50 deletions(-)


base-commit: 57c8aa43b9f272c382c253573c82be5cb68fe22d
-- 
2.27.0

WARNING: multiple messages have this Message-ID (diff)
From: Eric Biggers <ebiggers@kernel.org>
To: linux-crypto@vger.kernel.org, Herbert Xu <herbert@gondor.apana.org.au>
Cc: sparclinux@vger.kernel.org, linux-efi@vger.kernel.org,
	Ard Biesheuvel <ardb@kernel.org>,
	Hans de Goede <hdegoede@redhat.com>,
	mptcp@lists.01.org,
	Mat Martineau <mathew.j.martineau@linux.intel.com>,
	Matthieu Baerts <matthieu.baerts@tessares.net>,
	alsa-devel@alsa-project.org,
	Cheng-Yi Chiang <cychiang@chromium.org>,
	Enric Balletbo i Serra <enric.balletbo@collabora.com>,
	Guenter Roeck <groeck@chromium.org>,
	Tzung-Bi Shih <tzungbi@google.com>
Subject: [PATCH v2 0/5] crypto: add sha256() function
Date: Wed,  8 Jul 2020 09:39:38 -0700	[thread overview]
Message-ID: <20200708163943.52071-1-ebiggers@kernel.org> (raw)

This series adds a function sha256() to the sha256 library so that users
who want to compute a hash in one step can just call sha256() instead of
sha256_init() + sha256_update() + sha256_final().

Patches 3-5 then convert some users to use it.

Changed v1 => v2:
  - Added sparc patch to fix a build breakage caused by a
    static variable already named "sha256".
  - Added Reviewed-by, Acked-by, and Tested-by tags.

Eric Biggers (5):
  crypto: sparc - rename sha256 to sha256_alg
  crypto: lib/sha256 - add sha256() function
  efi: use sha256() instead of open coding
  mptcp: use sha256() instead of open coding
  ASoC: cros_ec_codec: use sha256() instead of open coding

 arch/sparc/crypto/sha256_glue.c          | 14 ++++++------
 drivers/firmware/efi/embedded-firmware.c |  9 +++-----
 include/crypto/sha.h                     |  1 +
 lib/crypto/sha256.c                      | 10 +++++++++
 net/mptcp/crypto.c                       | 15 +++----------
 sound/soc/codecs/cros_ec_codec.c         | 27 ++----------------------
 6 files changed, 26 insertions(+), 50 deletions(-)


base-commit: 57c8aa43b9f272c382c253573c82be5cb68fe22d
-- 
2.27.0


WARNING: multiple messages have this Message-ID (diff)
From: Eric Biggers <ebiggers@kernel.org>
To: linux-crypto@vger.kernel.org, Herbert Xu <herbert@gondor.apana.org.au>
Cc: Enric Balletbo i Serra <enric.balletbo@collabora.com>,
	alsa-devel@alsa-project.org, linux-efi@vger.kernel.org,
	Tzung-Bi Shih <tzungbi@google.com>,
	Mat Martineau <mathew.j.martineau@linux.intel.com>,
	Hans de Goede <hdegoede@redhat.com>,
	sparclinux@vger.kernel.org,
	Matthieu Baerts <matthieu.baerts@tessares.net>,
	Guenter Roeck <groeck@chromium.org>,
	mptcp@lists.01.org, Ard Biesheuvel <ardb@kernel.org>,
	Cheng-Yi Chiang <cychiang@chromium.org>
Subject: [PATCH v2 0/5] crypto: add sha256() function
Date: Wed, 08 Jul 2020 16:39:38 +0000	[thread overview]
Message-ID: <20200708163943.52071-1-ebiggers@kernel.org> (raw)

This series adds a function sha256() to the sha256 library so that users
who want to compute a hash in one step can just call sha256() instead of
sha256_init() + sha256_update() + sha256_final().

Patches 3-5 then convert some users to use it.

Changed v1 => v2:
  - Added sparc patch to fix a build breakage caused by a
    static variable already named "sha256".
  - Added Reviewed-by, Acked-by, and Tested-by tags.

Eric Biggers (5):
  crypto: sparc - rename sha256 to sha256_alg
  crypto: lib/sha256 - add sha256() function
  efi: use sha256() instead of open coding
  mptcp: use sha256() instead of open coding
  ASoC: cros_ec_codec: use sha256() instead of open coding

 arch/sparc/crypto/sha256_glue.c          | 14 ++++++------
 drivers/firmware/efi/embedded-firmware.c |  9 +++-----
 include/crypto/sha.h                     |  1 +
 lib/crypto/sha256.c                      | 10 +++++++++
 net/mptcp/crypto.c                       | 15 +++----------
 sound/soc/codecs/cros_ec_codec.c         | 27 ++----------------------
 6 files changed, 26 insertions(+), 50 deletions(-)


base-commit: 57c8aa43b9f272c382c253573c82be5cb68fe22d
-- 
2.27.0

WARNING: multiple messages have this Message-ID (diff)
From: Eric Biggers <ebiggers@kernel.org>
To: linux-crypto@vger.kernel.org, Herbert Xu <herbert@gondor.apana.org.au>
Cc: Enric Balletbo i Serra <enric.balletbo@collabora.com>,
	alsa-devel@alsa-project.org, linux-efi@vger.kernel.org,
	Tzung-Bi Shih <tzungbi@google.com>,
	Mat Martineau <mathew.j.martineau@linux.intel.com>,
	Hans de Goede <hdegoede@redhat.com>,
	sparclinux@vger.kernel.org,
	Matthieu Baerts <matthieu.baerts@tessares.net>,
	Guenter Roeck <groeck@chromium.org>,
	mptcp@lists.01.org, Ard Biesheuvel <ardb@kernel.org>,
	Cheng-Yi Chiang <cychiang@chromium.org>
Subject: [PATCH v2 0/5] crypto: add sha256() function
Date: Wed,  8 Jul 2020 09:39:38 -0700	[thread overview]
Message-ID: <20200708163943.52071-1-ebiggers@kernel.org> (raw)

This series adds a function sha256() to the sha256 library so that users
who want to compute a hash in one step can just call sha256() instead of
sha256_init() + sha256_update() + sha256_final().

Patches 3-5 then convert some users to use it.

Changed v1 => v2:
  - Added sparc patch to fix a build breakage caused by a
    static variable already named "sha256".
  - Added Reviewed-by, Acked-by, and Tested-by tags.

Eric Biggers (5):
  crypto: sparc - rename sha256 to sha256_alg
  crypto: lib/sha256 - add sha256() function
  efi: use sha256() instead of open coding
  mptcp: use sha256() instead of open coding
  ASoC: cros_ec_codec: use sha256() instead of open coding

 arch/sparc/crypto/sha256_glue.c          | 14 ++++++------
 drivers/firmware/efi/embedded-firmware.c |  9 +++-----
 include/crypto/sha.h                     |  1 +
 lib/crypto/sha256.c                      | 10 +++++++++
 net/mptcp/crypto.c                       | 15 +++----------
 sound/soc/codecs/cros_ec_codec.c         | 27 ++----------------------
 6 files changed, 26 insertions(+), 50 deletions(-)


base-commit: 57c8aa43b9f272c382c253573c82be5cb68fe22d
-- 
2.27.0


             reply	other threads:[~2020-07-08 16:39 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-08 16:39 Eric Biggers [this message]
2020-07-08 16:39 ` [PATCH v2 0/5] crypto: add sha256() function Eric Biggers
2020-07-08 16:39 ` Eric Biggers
2020-07-08 16:39 ` Eric Biggers
2020-07-08 16:39 ` [PATCH v2 1/5] crypto: sparc - rename sha256 to sha256_alg Eric Biggers
2020-07-08 16:39   ` Eric Biggers
2020-07-08 16:39 ` [PATCH v2 3/5] efi: use sha256() instead of open coding Eric Biggers
2020-07-08 16:39 ` [PATCH v2 5/5] ASoC: cros_ec_codec: " Eric Biggers
2020-07-08 16:39   ` Eric Biggers
2020-07-08 16:39 [MPTCP] [PATCH v2 2/5] crypto: lib/sha256 - add sha256() function Eric Biggers
2020-07-08 16:39 ` Eric Biggers
2020-07-08 16:39 ` Eric Biggers
2020-07-08 16:39 ` Eric Biggers
2020-07-08 16:39 [MPTCP] [PATCH v2 4/5] mptcp: use sha256() instead of open coding Eric Biggers
2020-07-08 16:39 ` Eric Biggers
2020-07-16 11:54 [MPTCP] Re: [PATCH v2 0/5] crypto: add sha256() function Herbert Xu
2020-07-16 11:54 ` Herbert Xu
2020-07-16 11:54 ` Herbert Xu
2020-07-16 11:54 ` Herbert Xu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200708163943.52071-1-ebiggers@kernel.org \
    --to=unknown@example.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.