All of lore.kernel.org
 help / color / mirror / Atom feed
From: Lee Jones <lee.jones@linaro.org>
To: kvalo@codeaurora.org, davem@davemloft.net, kuba@kernel.org
Cc: linux-kernel@vger.kernel.org, linux-wireless@vger.kernel.org,
	netdev@vger.kernel.org, Lee Jones <lee.jones@linaro.org>,
	Fox Chen <mhchen@golf.ccl.itri.org.tw>,
	de Melo <acme@conectiva.com.br>,
	Gustavo Niemeyer <niemeyer@conectiva.com>
Subject: [PATCH 20/30] wireless: wl3501_cs: Fix a bunch of formatting issues related to function docs
Date: Wed, 26 Aug 2020 10:33:51 +0100	[thread overview]
Message-ID: <20200826093401.1458456-21-lee.jones@linaro.org> (raw)
In-Reply-To: <20200826093401.1458456-1-lee.jones@linaro.org>

Fixes the following W=1 kernel build warning(s):

 In file included from drivers/net/wireless/wl3501_cs.c:57:
 drivers/net/wireless/wl3501_cs.c:143: warning: Function parameter or member 'reg_domain' not described in 'iw_valid_channel'
 drivers/net/wireless/wl3501_cs.c:143: warning: Function parameter or member 'channel' not described in 'iw_valid_channel'
 drivers/net/wireless/wl3501_cs.c:162: warning: Function parameter or member 'reg_domain' not described in 'iw_default_channel'
 drivers/net/wireless/wl3501_cs.c:248: warning: Function parameter or member 'this' not described in 'wl3501_set_to_wla'
 drivers/net/wireless/wl3501_cs.c:270: warning: Function parameter or member 'this' not described in 'wl3501_get_from_wla'
 drivers/net/wireless/wl3501_cs.c:467: warning: Function parameter or member 'this' not described in 'wl3501_send_pkt'
 drivers/net/wireless/wl3501_cs.c:467: warning: Function parameter or member 'data' not described in 'wl3501_send_pkt'
 drivers/net/wireless/wl3501_cs.c:467: warning: Function parameter or member 'len' not described in 'wl3501_send_pkt'
 drivers/net/wireless/wl3501_cs.c:729: warning: Function parameter or member 'this' not described in 'wl3501_block_interrupt'
 drivers/net/wireless/wl3501_cs.c:746: warning: Function parameter or member 'this' not described in 'wl3501_unblock_interrupt'
 drivers/net/wireless/wl3501_cs.c:1124: warning: Function parameter or member 'irq' not described in 'wl3501_interrupt'
 drivers/net/wireless/wl3501_cs.c:1124: warning: Function parameter or member 'dev_id' not described in 'wl3501_interrupt'
 drivers/net/wireless/wl3501_cs.c:1257: warning: Function parameter or member 'dev' not described in 'wl3501_reset'
 drivers/net/wireless/wl3501_cs.c:1420: warning: Function parameter or member 'link' not described in 'wl3501_detach'

Cc: Kalle Valo <kvalo@codeaurora.org>
Cc: "David S. Miller" <davem@davemloft.net>
Cc: Jakub Kicinski <kuba@kernel.org>
Cc: Fox Chen <mhchen@golf.ccl.itri.org.tw>
Cc: de Melo <acme@conectiva.com.br>
Cc: Gustavo Niemeyer <niemeyer@conectiva.com>
Cc: linux-wireless@vger.kernel.org
Cc: netdev@vger.kernel.org
Signed-off-by: Lee Jones <lee.jones@linaro.org>
---
 drivers/net/wireless/wl3501_cs.c | 22 ++++++++++++----------
 1 file changed, 12 insertions(+), 10 deletions(-)

diff --git a/drivers/net/wireless/wl3501_cs.c b/drivers/net/wireless/wl3501_cs.c
index 686161db8706c..4e7a2140649b4 100644
--- a/drivers/net/wireless/wl3501_cs.c
+++ b/drivers/net/wireless/wl3501_cs.c
@@ -134,8 +134,8 @@ static const struct {
 
 /**
  * iw_valid_channel - validate channel in regulatory domain
- * @reg_comain - regulatory domain
- * @channel - channel to validate
+ * @reg_comain: regulatory domain
+ * @channel: channel to validate
  *
  * Returns 0 if invalid in the specified regulatory domain, non-zero if valid.
  */
@@ -154,7 +154,7 @@ static int iw_valid_channel(int reg_domain, int channel)
 
 /**
  * iw_default_channel - get default channel for a regulatory domain
- * @reg_comain - regulatory domain
+ * @reg_domain: regulatory domain
  *
  * Returns the default channel for a regulatory domain
  */
@@ -237,6 +237,7 @@ static int wl3501_get_flash_mac_addr(struct wl3501_card *this)
 
 /**
  * wl3501_set_to_wla - Move 'size' bytes from PC to card
+ * @this: Card
  * @dest: Card addressing space
  * @src: PC addressing space
  * @size: Bytes to move
@@ -259,6 +260,7 @@ static void wl3501_set_to_wla(struct wl3501_card *this, u16 dest, void *src,
 
 /**
  * wl3501_get_from_wla - Move 'size' bytes from card to PC
+ * @this: Card
  * @src: Card addressing space
  * @dest: PC addressing space
  * @size: Bytes to move
@@ -455,7 +457,7 @@ static int wl3501_pwr_mgmt(struct wl3501_card *this, int suspend)
 
 /**
  * wl3501_send_pkt - Send a packet.
- * @this - card
+ * @this: Card
  *
  * Send a packet.
  *
@@ -720,7 +722,7 @@ static void wl3501_mgmt_scan_confirm(struct wl3501_card *this, u16 addr)
 
 /**
  * wl3501_block_interrupt - Mask interrupt from SUTRO
- * @this - card
+ * @this: Card
  *
  * Mask interrupt from SUTRO. (i.e. SUTRO cannot interrupt the HOST)
  * Return: 1 if interrupt is originally enabled
@@ -737,7 +739,7 @@ static int wl3501_block_interrupt(struct wl3501_card *this)
 
 /**
  * wl3501_unblock_interrupt - Enable interrupt from SUTRO
- * @this - card
+ * @this: Card
  *
  * Enable interrupt from SUTRO. (i.e. SUTRO can interrupt the HOST)
  * Return: 1 if interrupt is originally enabled
@@ -1110,8 +1112,8 @@ static inline void wl3501_ack_interrupt(struct wl3501_card *this)
 
 /**
  * wl3501_interrupt - Hardware interrupt from card.
- * @irq - Interrupt number
- * @dev_id - net_device
+ * @irq: Interrupt number
+ * @dev_id: net_device
  *
  * We must acknowledge the interrupt as soon as possible, and block the
  * interrupt from the same card immediately to prevent re-entry.
@@ -1247,7 +1249,7 @@ static int wl3501_close(struct net_device *dev)
 
 /**
  * wl3501_reset - Reset the SUTRO.
- * @dev - network device
+ * @dev: network device
  *
  * It is almost the same as wl3501_open(). In fact, we may just wl3501_close()
  * and wl3501_open() again, but I wouldn't like to free_irq() when the driver
@@ -1410,7 +1412,7 @@ static struct iw_statistics *wl3501_get_wireless_stats(struct net_device *dev)
 
 /**
  * wl3501_detach - deletes a driver "instance"
- * @link - FILL_IN
+ * @link: FILL_IN
  *
  * This deletes a driver "instance". The device is de-registered with Card
  * Services. If it has been released, all local data structures are freed.
-- 
2.25.1


  parent reply	other threads:[~2020-08-26  9:37 UTC|newest]

Thread overview: 45+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-08-26  9:33 [PATCH 00/30] Set 3: Rid W=1 warnings in Wireless Lee Jones
2020-08-26  9:33 ` [PATCH 01/30] wireless: marvell: mwifiex: pcie: Move tables to the only place they're used Lee Jones
2020-09-01 13:06   ` [01/30] " Kalle Valo
2020-08-26  9:33 ` [PATCH 02/30] wireless: broadcom: brcmsmac: ampdu: Remove a couple set but unused variables Lee Jones
2020-08-26  9:33 ` [PATCH 03/30] wireless: intel: iwlegacy: 3945-mac: Remove all non-conformant kernel-doc headers Lee Jones
2020-08-26  9:33 ` [PATCH 04/30] wireless: intel: iwlegacy: 3945-rs: " Lee Jones
2020-08-26  9:33 ` [PATCH 05/30] wireless: intel: iwlegacy: 3945: " Lee Jones
2020-08-26  9:33 ` [PATCH 06/30] wireless: broadcom: brcmfmac: p2p: Fix a couple of function headers Lee Jones
2020-08-26  9:33 ` [PATCH 07/30] wireless: intersil: orinoco_usb: Downgrade non-conforming kernel-doc headers Lee Jones
2020-08-26  9:33 ` [PATCH 08/30] wireless: broadcom: brcmsmac: phy_cmn: Remove a unused variables 'vbat' and 'temp' Lee Jones
2020-08-26  9:33 ` [PATCH 09/30] wireless: zydas: zd1211rw: zd_chip: Fix formatting Lee Jones
2020-08-26  9:33 ` [PATCH 10/30] wireless: zydas: zd1211rw: zd_mac: Add missing or incorrect function documentation Lee Jones
2020-08-26  9:33 ` [PATCH 11/30] wireless: zydas: zd1211rw: zd_chip: Correct misspelled function argument Lee Jones
2020-09-01 13:15   ` [11/30] " Kalle Valo
2020-08-26  9:33 ` [PATCH 12/30] wireless: ath: wil6210: wmi: Correct misnamed function parameter 'ptr_' Lee Jones
2020-08-26 15:56   ` Kalle Valo
2020-08-27  6:35     ` Lee Jones
2020-08-27  7:41       ` Lee Jones
2020-08-27 11:40         ` Kalle Valo
2020-08-27 12:16           ` Lee Jones
2020-08-26  9:33 ` [PATCH 13/30] wireless: broadcom: brcm80211: brcmfmac: fwsignal: Finish documenting 'brcmf_fws_mac_descriptor' Lee Jones
2020-08-26  9:33 ` [PATCH 14/30] wireless: ath: ath6kl: wmi: Remove unused variable 'rate' Lee Jones
2020-08-27 10:16   ` Kalle Valo
2020-08-26  9:33 ` [PATCH 15/30] wireless: ti: wlcore: debugfs: Remove unused variable 'res' Lee Jones
2020-08-26  9:33 ` [PATCH 16/30] wireless: rsi: rsi_91x_sdio: Fix a few kernel-doc related issues Lee Jones
2020-08-26  9:33 ` [PATCH 17/30] wireless: ath: ath9k: ar9002_initvals: Remove unused array 'ar9280PciePhy_clkreq_off_L1_9280' Lee Jones
2020-08-27 10:17   ` Kalle Valo
2020-08-26  9:33 ` [PATCH 18/30] wireless: ath: ath9k: ar9001_initvals: Remove unused array 'ar5416Bank6_9100' Lee Jones
2020-08-26  9:33 ` [PATCH 19/30] wireless: intersil: hostap: hostap_hw: Remove unused variable 'fc' Lee Jones
2020-08-26  9:33 ` Lee Jones [this message]
2020-08-26  9:33 ` [PATCH 21/30] wireless: realtek: rtw88: debug: Remove unused variables 'val' Lee Jones
2020-08-26  9:33 ` [PATCH 22/30] wireless: rsi: rsi_91x_sdio_ops: File headers are not good kernel-doc candidates Lee Jones
2020-08-26  9:33 ` [PATCH 23/30] wireless: intersil: prism54: isl_ioctl: Remove unused variable 'j' Lee Jones
2020-08-26  9:33 ` [PATCH 24/30] wireless: marvell: mwifiex: wmm: Mark 'mwifiex_1d_to_wmm_queue' as __maybe_unused Lee Jones
2020-09-01 13:16   ` [24/30] " Kalle Valo
     [not found]   ` <20200901131601.C3840C433C6@smtp.codeaurora.org>
2020-09-08  8:34     ` Lee Jones
2020-08-26  9:33 ` [PATCH 25/30] wireless: ath: ath9k: ar5008_initvals: Remove unused table entirely Lee Jones
2020-08-26  9:33 ` [PATCH 26/30] wireless: ath: ath9k: ar5008_initvals: Move ar5416Bank{0,1,2,3,7} to where they are used Lee Jones
2020-08-26  9:33 ` [PATCH 27/30] wireless: broadcom: brcm80211: phy_lcn: Remove a bunch of unused variables Lee Jones
2020-09-01 13:16   ` [27/30] brcmsmac: " Kalle Valo
2020-08-26  9:33 ` [PATCH 28/30] wireless: broadcom: brcm80211: phy_n: " Lee Jones
2020-08-26  9:34 ` [PATCH 29/30] wireless: broadcom: brcm80211: phytbl_lcn: Remove unused array 'dot11lcnphytbl_rx_gain_info_rev1' Lee Jones
2020-08-26  9:34 ` [PATCH 30/30] wireless: broadcom: brcm80211: phytbl_n: Remove a few unused arrays Lee Jones
2020-08-27 12:03 ` [PATCH 00/30] Set 3: Rid W=1 warnings in Wireless Kalle Valo
2020-08-27 12:14   ` Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200826093401.1458456-21-lee.jones@linaro.org \
    --to=lee.jones@linaro.org \
    --cc=acme@conectiva.com.br \
    --cc=davem@davemloft.net \
    --cc=kuba@kernel.org \
    --cc=kvalo@codeaurora.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=mhchen@golf.ccl.itri.org.tw \
    --cc=netdev@vger.kernel.org \
    --cc=niemeyer@conectiva.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.