All of lore.kernel.org
 help / color / mirror / Atom feed
From: Paul Durrant <paul@xen.org>
To: xen-devel@lists.xenproject.org
Cc: Paul Durrant <pdurrant@amazon.com>, Wei Liu <wl@xen.org>,
	Ian Jackson <iwj@xenproject.org>
Subject: [PATCH v6 24/25] docs/man: modify xl-pci-configuration(5) to add 'name' field to PCI_SPEC_STRING
Date: Tue,  8 Dec 2020 19:30:32 +0000	[thread overview]
Message-ID: <20201208193033.11306-25-paul@xen.org> (raw)
In-Reply-To: <20201208193033.11306-1-paul@xen.org>

From: Paul Durrant <pdurrant@amazon.com>

Since assignable devices can be named, a subsequent patch will support use
of a PCI_SPEC_STRING containing a 'name' parameter instead of a 'bdf'. In
this case the name will be used to look up the 'bdf' in the list of assignable
(or assigned) devices.

Signed-off-by: Paul Durrant <pdurrant@amazon.com>
Acked-by: Wei Liu <wl@xen.org>
---
Cc: Ian Jackson <iwj@xenproject.org>
---
 docs/man/xl-pci-configuration.5.pod | 25 +++++++++++++++++++++++--
 1 file changed, 23 insertions(+), 2 deletions(-)

diff --git a/docs/man/xl-pci-configuration.5.pod b/docs/man/xl-pci-configuration.5.pod
index 4dd73bc498d6..db3360307cbd 100644
--- a/docs/man/xl-pci-configuration.5.pod
+++ b/docs/man/xl-pci-configuration.5.pod
@@ -51,7 +51,7 @@ is not specified, or if it is specified with an empty value (whether
 positionally or explicitly).
 
 B<NOTE>: In context of B<xl pci-detach> (see L<xl(1)>), parameters other than
-B<bdf> will be ignored.
+B<bdf> or B<name> will be ignored.
 
 =head1 Positional Parameters
 
@@ -70,7 +70,11 @@ B<*> to indicate all functions of a multi-function device.
 
 =item Default Value
 
-None. This parameter is mandatory as it identifies the device.
+None. This parameter is mandatory in its positional form. As a non-positional
+parameter it is also mandatory unless a B<name> parameter is present, in
+which case B<bdf> must not be present since the B<name> will be used to find
+the B<bdf> in the list of assignable devices. See L<xl(1)> for more information
+on naming assignable devices.
 
 =back
 
@@ -194,4 +198,21 @@ B<NOTE>: This overrides the global B<rdm> option.
 
 =back
 
+=item B<name>=I<STRING>
+
+=over 4
+
+=item Description
+
+This is the name given when the B<BDF> was made assignable. See L<xl(1)> for
+more information on naming assignable devices.
+
+=item Default Value
+
+None. This parameter must not be present if a B<bdf> parameter is present.
+If a B<bdf> parameter is not present then B<name> is mandatory as it is
+required to look up the B<BDF> in the list of assignable devices.
+
+=back
+
 =back
-- 
2.20.1



  parent reply	other threads:[~2020-12-08 20:01 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-12-08 19:30 [PATCH v6 00/25] xl / libxl: named PCI pass-through devices Paul Durrant
2020-12-08 19:30 ` [PATCH v6 01/25] libxl: s/pcidev/pci and remove DEFINE_DEVICE_TYPE_STRUCT_X Paul Durrant
2020-12-15 15:59   ` Wei Liu
2020-12-08 19:30 ` [PATCH v6 02/25] xl: s/pcidev/pci where possible Paul Durrant
2020-12-15 16:00   ` Wei Liu
2020-12-08 19:30 ` [PATCH v6 03/25] libxl: make libxl__device_list() work correctly for LIBXL__DEVICE_KIND_PCI Paul Durrant
2020-12-08 19:30 ` [PATCH v6 04/25] libxl: Make sure devices added by pci-attach are reflected in the config Paul Durrant
2020-12-08 19:30 ` [PATCH v6 05/25] libxl: add/recover 'rdm_policy' to/from PCI backend in xenstore Paul Durrant
2020-12-08 19:30 ` [PATCH v6 06/25] libxl: s/detatched/detached in libxl_pci.c Paul Durrant
2020-12-08 19:30 ` [PATCH v6 07/25] libxl: remove extraneous arguments to do_pci_remove() " Paul Durrant
2020-12-08 19:30 ` [PATCH v6 08/25] libxl: stop using aodev->device_config in libxl__device_pci_add() Paul Durrant
2020-12-08 19:30 ` [PATCH v6 09/25] libxl: generalise 'driver_path' xenstore access functions in libxl_pci.c Paul Durrant
2020-12-08 19:30 ` [PATCH v6 10/25] libxl: remove unnecessary check from libxl__device_pci_add() Paul Durrant
2020-12-08 19:30 ` [PATCH v6 11/25] libxl: remove get_all_assigned_devices() from libxl_pci.c Paul Durrant
2020-12-08 19:30 ` [PATCH v6 12/25] libxl: make sure callers of libxl_device_pci_list() free the list after use Paul Durrant
2020-12-08 19:30 ` [PATCH v6 13/25] libxl: add libxl_device_pci_assignable_list_free() Paul Durrant
2020-12-08 19:30 ` [PATCH v6 14/25] libxl: use COMPARE_PCI() macro is_pci_in_array() Paul Durrant
2020-12-08 19:30 ` [PATCH v6 15/25] docs/man: extract documentation of PCI_SPEC_STRING from the xl.cfg manpage Paul Durrant
2020-12-08 19:30 ` [PATCH v6 16/25] docs/man: improve documentation of PCI_SPEC_STRING Paul Durrant
2020-12-08 19:30 ` [PATCH v6 17/25] docs/man: fix xl(1) documentation for 'pci' operations Paul Durrant
2020-12-08 19:30 ` [PATCH v6 18/25] libxl: introduce 'libxl_pci_bdf' in the idl Paul Durrant
2020-12-08 19:30 ` [PATCH v6 19/25] libxlu: introduce xlu_pci_parse_spec_string() Paul Durrant
2020-12-08 19:30 ` [PATCH v6 20/25] docs/man: modify xl(1) in preparation for naming of assignable devices Paul Durrant
2020-12-08 19:30 ` [PATCH v6 21/25] libxl: convert internal functions in libxl_pci.c Paul Durrant
2020-12-15 16:02   ` Wei Liu
2020-12-08 19:30 ` [PATCH v6 22/25] libxl: introduce libxl_pci_bdf_assignable_add/remove/list/list_free(), Paul Durrant
2020-12-15 16:03   ` Wei Liu
2020-12-08 19:30 ` [PATCH v6 23/25] xl: support naming of assignable devices Paul Durrant
2020-12-15 16:03   ` Wei Liu
2020-12-08 19:30 ` Paul Durrant [this message]
2020-12-08 19:30 ` [PATCH v6 25/25] libxl / libxlu: support 'xl pci-attach/detach' by name Paul Durrant

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201208193033.11306-25-paul@xen.org \
    --to=paul@xen.org \
    --cc=iwj@xenproject.org \
    --cc=pdurrant@amazon.com \
    --cc=wl@xen.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.