All of lore.kernel.org
 help / color / mirror / Atom feed
From: Lucas De Marchi <lucas.demarchi@intel.com>
To: intel-gfx@lists.freedesktop.org
Cc: Jani Nikula <jani.nikula@intel.com>
Subject: [Intel-gfx] [PATCH v2 02/12] drm/i915: rename display.version to display.ver
Date: Mon, 12 Apr 2021 22:09:52 -0700	[thread overview]
Message-ID: <20210413051002.92589-3-lucas.demarchi@intel.com> (raw)
In-Reply-To: <20210413051002.92589-1-lucas.demarchi@intel.com>

The macro we use to check is called DISPLAY_VER(). While using this
macro and the new ones being added in following changes I made the
mistake multiple times when mixing both "ver" and "version". Although
it's usually better to prefer the complete name, the shorhand
DISPLAY_VER() / GRAPHICS_VER / MEDIA_VER are clear and cause less
visual polution.

Another issue is when copying the variable to other places.
"display.version" would be copied to a "display_version" variable which
is long and would make people abbreviate as "version", or "display_ver".
In the first case it's not always clear what version refers to, and in
the second case it just hints it should be the name in the first place.

So, in the same way use used "gen" rather than "generation", use "ver"
instead of "version".

Signed-off-by: Lucas De Marchi <lucas.demarchi@intel.com>
Reviewed-by: José Roberto de Souza <jose.souza@intel.com>
Acked-by: Jani Nikula <jani.nikula@intel.com>
---
 drivers/gpu/drm/i915/i915_drv.h          | 2 +-
 drivers/gpu/drm/i915/i915_pci.c          | 4 ++--
 drivers/gpu/drm/i915/intel_device_info.h | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h
index 69e43bf91a15..8c62bb2abd31 100644
--- a/drivers/gpu/drm/i915/i915_drv.h
+++ b/drivers/gpu/drm/i915/i915_drv.h
@@ -1237,7 +1237,7 @@ static inline struct drm_i915_private *pdev_to_i915(struct pci_dev *pdev)
 #define INTEL_GEN(dev_priv)	(INTEL_INFO(dev_priv)->gen)
 #define INTEL_DEVID(dev_priv)	(RUNTIME_INFO(dev_priv)->device_id)
 
-#define DISPLAY_VER(i915)	(INTEL_INFO(i915)->display.version)
+#define DISPLAY_VER(i915)	(INTEL_INFO(i915)->display.ver)
 #define IS_DISPLAY_RANGE(i915, from, until) \
 	(DISPLAY_VER(i915) >= (from) && DISPLAY_VER(i915) <= (until))
 #define IS_DISPLAY_VER(i915, v) (DISPLAY_VER(i915) == (v))
diff --git a/drivers/gpu/drm/i915/i915_pci.c b/drivers/gpu/drm/i915/i915_pci.c
index 480553746794..ce5cbeaf036d 100644
--- a/drivers/gpu/drm/i915/i915_pci.c
+++ b/drivers/gpu/drm/i915/i915_pci.c
@@ -36,7 +36,7 @@
 #include "i915_selftest.h"
 
 #define PLATFORM(x) .platform = (x)
-#define GEN(x) .gen = (x), .gen_mask = BIT((x) - 1), .display.version = (x)
+#define GEN(x) .gen = (x), .gen_mask = BIT((x) - 1), .display.ver = (x)
 
 #define I845_PIPE_OFFSETS \
 	.pipe_offsets = { \
@@ -723,7 +723,7 @@ static const struct intel_device_info bxt_info = {
 static const struct intel_device_info glk_info = {
 	GEN9_LP_FEATURES,
 	PLATFORM(INTEL_GEMINILAKE),
-	.display.version = 10,
+	.display.ver = 10,
 	.ddb_size = 1024,
 	GLK_COLORS,
 };
diff --git a/drivers/gpu/drm/i915/intel_device_info.h b/drivers/gpu/drm/i915/intel_device_info.h
index 2f442d418a15..b16c75927a12 100644
--- a/drivers/gpu/drm/i915/intel_device_info.h
+++ b/drivers/gpu/drm/i915/intel_device_info.h
@@ -189,7 +189,7 @@ struct intel_device_info {
 #undef DEFINE_FLAG
 
 	struct {
-		u8 version;
+		u8 ver;
 
 #define DEFINE_FLAG(name) u8 name:1
 		DEV_INFO_DISPLAY_FOR_EACH_FLAG(DEFINE_FLAG);
-- 
2.31.1

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  parent reply	other threads:[~2021-04-13  5:11 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-04-13  5:09 [Intel-gfx] [PATCH v2 00/12] drm/i915: Extend GEN renames to the rest of the driver Lucas De Marchi
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 01/12] drm/i915/display: use DISPLAY_VER() on remaining users Lucas De Marchi
2021-04-13  9:24   ` Jani Nikula
2021-04-13  5:09 ` Lucas De Marchi [this message]
2021-04-13  9:25   ` [Intel-gfx] [PATCH v2 02/12] drm/i915: rename display.version to display.ver Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 03/12] drm/i915/display: rename display version macros Lucas De Marchi
2021-04-13  9:35   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 04/12] drm/i915: add macros for graphics and media versions Lucas De Marchi
2021-04-13  9:33   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 05/12] drm/i915/gt: replace gen use in intel_engine_cs Lucas De Marchi
2021-04-13  9:36   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 06/12] drm/i915/selftests: replace unused mask with simple version Lucas De Marchi
2021-04-13  9:36   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 07/12] drm/i915/selftests: eliminate use of gen_mask Lucas De Marchi
2021-04-13  9:38   ` Jani Nikula
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 08/12] drm/i915: finish removal " Lucas De Marchi
2021-04-13  9:40   ` Jani Nikula
2021-04-14 11:38   ` Tvrtko Ursulin
2021-04-14 13:13     ` Jani Nikula
2021-04-14 13:46       ` Tvrtko Ursulin
2021-04-15 10:22         ` Jani Nikula
2021-04-14 17:41     ` Lucas De Marchi
2021-04-13  5:09 ` [Intel-gfx] [PATCH v2 09/12] drm/i915: eliminate remaining uses of intel_device_info->gen Lucas De Marchi
2021-04-13  9:43   ` Jani Nikula
2021-04-13  5:10 ` [Intel-gfx] [PATCH v2 10/12] drm/i915: finish removal of gen from intel_device_info Lucas De Marchi
2021-04-13  9:45   ` Jani Nikula
2021-04-13  5:10 ` [Intel-gfx] [PATCH v2 11/12] drm/i915: add media and display versions to device_info print Lucas De Marchi
2021-04-13  9:46   ` Jani Nikula
2021-04-13  5:10 ` [Intel-gfx] [PATCH v2 12/12] drm/i915: split dgfx features from gen 12 Lucas De Marchi
2021-04-13  9:47   ` Jani Nikula
2021-04-13  5:43 ` [Intel-gfx] ✗ Fi.CI.CHECKPATCH: warning for drm/i915: Extend GEN renames to the rest of the driver (rev3) Patchwork
2021-04-13  5:45 ` [Intel-gfx] ✗ Fi.CI.SPARSE: " Patchwork
2021-04-13  5:48 ` [Intel-gfx] ✗ Fi.CI.DOCS: " Patchwork
2021-04-13  6:10 ` [Intel-gfx] ✓ Fi.CI.BAT: success " Patchwork
2021-04-13  7:29 ` [Intel-gfx] ✓ Fi.CI.IGT: " Patchwork
2021-04-13 10:03 ` [Intel-gfx] [PATCH v2 00/12] drm/i915: Extend GEN renames to the rest of the driver Jani Nikula
2021-04-14  8:08   ` Jani Nikula
2021-04-14 10:06     ` Jani Nikula
2021-04-14 11:17       ` Joonas Lahtinen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210413051002.92589-3-lucas.demarchi@intel.com \
    --to=lucas.demarchi@intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=jani.nikula@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.