All of lore.kernel.org
 help / color / mirror / Atom feed
From: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com>
To: qemu-block@nongnu.org
Cc: qemu-devel@nongnu.org, armbru@redhat.com, eblake@redhat.com,
	crosa@redhat.com, ehabkost@redhat.com, berrange@redhat.com,
	pbonzini@redhat.com, vsementsov@virtuozzo.com, jsnow@redhat.com,
	mreitz@redhat.com, kwolf@redhat.com
Subject: [PATCH v6 24/33] python/qemu/machine: QEMUMachine: improve qmp() method
Date: Wed, 21 Jul 2021 13:05:46 +0300	[thread overview]
Message-ID: <20210721100555.45594-25-vsementsov@virtuozzo.com> (raw)
In-Reply-To: <20210721100555.45594-1-vsementsov@virtuozzo.com>

We often call qmp() with unpacking dict, like qmp('foo', **{...}).
mypy don't really like it, it thinks that passed unpacked dict is a
positional argument and complains that it type should be bool (because
second argument of qmp() is conv_keys: bool).

Allow passing dict directly, simplifying interface, and giving a way to
satisfy mypy.

Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com>
Reviewed-by: Max Reitz <mreitz@redhat.com>
Reviewed-by: John Snow <jsnow@redhat.com>
---
 python/qemu/machine/machine.py | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)

diff --git a/python/qemu/machine/machine.py b/python/qemu/machine/machine.py
index 5eab31aeec..ce1e130c13 100644
--- a/python/qemu/machine/machine.py
+++ b/python/qemu/machine/machine.py
@@ -572,11 +572,21 @@ def _qmp_args(cls, conv_keys: bool,
         return args
 
     def qmp(self, cmd: str,
-            conv_keys: bool = True,
+            args_dict: Optional[Dict[str, object]] = None,
+            conv_keys: Optional[bool] = None,
             **args: Any) -> QMPMessage:
         """
         Invoke a QMP command and return the response dict
         """
+        if args_dict is not None:
+            assert not args
+            assert conv_keys is None
+            args = args_dict
+            conv_keys = False
+
+        if conv_keys is None:
+            conv_keys = True
+
         qmp_args = self._qmp_args(conv_keys, args)
         return self._qmp.cmd(cmd, args=qmp_args)
 
-- 
2.29.2



  parent reply	other threads:[~2021-07-21 10:37 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-21 10:05 [PATCH v6 00/33] block: publish backup-top filter Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 01/33] block: introduce bdrv_replace_child_bs() Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 02/33] block: introduce blk_replace_bs Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 03/33] qdev-properties: PropertyInfo: add realized_set_allowed field Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 04/33] qdev: allow setting drive property for realized device Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 05/33] block: rename backup-top to copy-before-write Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 06/33] block-copy: always set BDRV_REQ_SERIALISING flag Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 07/33] block/block-copy: introduce block_copy_set_copy_opts() Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 08/33] block/backup: set copy_range and compress after filter insertion Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 09/33] block/backup: move cluster size calculation to block-copy Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 10/33] block/copy-before-write: relax permission requirements when no parents Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 11/33] block/copy-before-write: drop extra bdrv_unref on failure path Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 12/33] block/copy-before-write: use file child instead of backing Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 13/33] block/copy-before-write: bdrv_cbw_append(): replace child at last Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 14/33] block/copy-before-write: introduce cbw_init() Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 15/33] block/copy-before-write: cbw_init(): rename variables Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 16/33] block/copy-before-write: cbw_init(): use file child after attaching Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 17/33] block/copy-before-write: bdrv_cbw_append(): drop unused compress arg Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 18/33] block/copy-before-write: cbw_init(): use options Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 19/33] block/copy-before-write: initialize block-copy bitmap Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 20/33] block/block-copy: make setting progress optional Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 21/33] block/copy-before-write: make public block driver Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 22/33] qapi: publish copy-before-write filter Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 23/33] python/qemu/machine.py: refactor _qemu_args() Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` Vladimir Sementsov-Ogievskiy [this message]
2021-07-21 10:05 ` [PATCH v6 25/33] iotests.py: VM: add own __enter__ method Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 26/33] iotests/222: fix pylint and mypy complains Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 27/33] iotests/222: constantly use single quotes for strings Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 28/33] iotests: move 222 to tests/image-fleecing Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 29/33] iotests.py: hmp_qemu_io: support qdev Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 30/33] iotests/image-fleecing: proper source device Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 31/33] iotests/image-fleecing: rename tgt_node Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 32/33] iotests/image-fleecing: prepare for adding new test-case Vladimir Sementsov-Ogievskiy
2021-07-21 10:05 ` [PATCH v6 33/33] iotests/image-fleecing: add test-case for copy-before-write filter Vladimir Sementsov-Ogievskiy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210721100555.45594-25-vsementsov@virtuozzo.com \
    --to=vsementsov@virtuozzo.com \
    --cc=armbru@redhat.com \
    --cc=berrange@redhat.com \
    --cc=crosa@redhat.com \
    --cc=eblake@redhat.com \
    --cc=ehabkost@redhat.com \
    --cc=jsnow@redhat.com \
    --cc=kwolf@redhat.com \
    --cc=mreitz@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.