All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Carlos Maiolino <cem@kernel.org>
Cc: linux-xfs@vger.kernel.org
Subject: [PATCH 01/23] libxfs: remove the unused icache_flags member from struct libxfs_xinit
Date: Mon, 11 Dec 2023 17:37:20 +0100	[thread overview]
Message-ID: <20231211163742.837427-2-hch@lst.de> (raw)
In-Reply-To: <20231211163742.837427-1-hch@lst.de>

Signed-off-by: Christoph Hellwig <hch@lst.de>
---
 include/libxfs.h | 1 -
 1 file changed, 1 deletion(-)

diff --git a/include/libxfs.h b/include/libxfs.h
index b28781d19..9b0294cb8 100644
--- a/include/libxfs.h
+++ b/include/libxfs.h
@@ -124,7 +124,6 @@ typedef struct libxfs_xinit {
 	int             dfd;            /* data subvolume file descriptor */
 	int             logfd;          /* log subvolume file descriptor */
 	int             rtfd;           /* realtime subvolume file descriptor */
-	int		icache_flags;	/* cache init flags */
 	int		bcache_flags;	/* cache init flags */
 } libxfs_init_t;
 
-- 
2.39.2


  reply	other threads:[~2023-12-11 16:37 UTC|newest]

Thread overview: 49+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-12-11 16:37 improve libxfs device handling Christoph Hellwig
2023-12-11 16:37 ` Christoph Hellwig [this message]
2023-12-18  8:37   ` [PATCH 01/23] libxfs: remove the unused icache_flags member from struct libxfs_xinit Carlos Maiolino
2023-12-11 16:37 ` [PATCH 02/23] libxfs: remove the dead {d,log,rt}path variables in libxfs_init Christoph Hellwig
2023-12-18  8:38   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 03/23] libxfs/frog: remove latform_find{raw,block}path Christoph Hellwig
2023-12-18  8:41   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 04/23] libxfs: remove the volname concept Christoph Hellwig
2023-12-18  8:47   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 05/23] xfs_logprint: move all code to set up the fake xlog into logstat() Christoph Hellwig
2023-12-18  8:51   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 06/23] libxlog: remove the verbose argument to xlog_is_dirty Christoph Hellwig
2023-12-18  8:56   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 07/23] libxlog: add a helper to initialize a xlog without clobbering the x structure Christoph Hellwig
2023-12-18  9:00   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 08/23] libxlog: don't require a libxfs_xinit structure for xlog_init Christoph Hellwig
2023-12-18  9:06   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 09/23] libxlog: remove the global libxfs_xinit x structure Christoph Hellwig
2023-12-18  9:18   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 10/23] libxfs: rename struct libxfs_xinit to libxfs_init Christoph Hellwig
2023-12-18  9:20   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 11/23] libxfs: pass a struct libxfs_init to libxfs_mount Christoph Hellwig
2023-12-18  9:21   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 12/23] libxfs: pass a struct libxfs_init to libxfs_alloc_buftarg Christoph Hellwig
2023-12-18  9:21   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 13/23] libxfs: merge the file vs device cases in libxfs_init Christoph Hellwig
2023-12-18  9:23   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 14/23] libxfs: making passing flags to libxfs_init less confusing Christoph Hellwig
2023-12-18 12:30   ` Carlos Maiolino
2023-12-18 14:36     ` Christoph Hellwig
2023-12-11 16:37 ` [PATCH 15/23] libxfs: remove the setblksize == 1 case in libxfs_device_open Christoph Hellwig
2023-12-18 12:44   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 16/23] libfrog: make platform_set_blocksize exit on fatal failure Christoph Hellwig
2023-12-18 12:48   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 17/23] libxfs: remove dead size < 0 checks in libxfs_init Christoph Hellwig
2023-12-18 12:51   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 18/23] libxfs: mark libxfs_device_{open,close} static Christoph Hellwig
2023-12-18 12:52   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 19/23] libxfs: return the opened fd from libxfs_device_open Christoph Hellwig
2023-12-18 12:53   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 20/23] libxfs: pass the device fd to discard_blocks Christoph Hellwig
2023-12-18 12:53   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 21/23] xfs_repair: remove various libxfs_device_to_fd calls Christoph Hellwig
2023-12-18 12:55   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 22/23] libxfs: stash away the device fd in struct xfs_buftarg Christoph Hellwig
2023-12-18 12:58   ` Carlos Maiolino
2023-12-11 16:37 ` [PATCH 23/23] libxfs: split out a libxfs_dev structure from struct libxfs_init Christoph Hellwig
2023-12-18 13:01   ` Carlos Maiolino
2023-12-12  1:52 ` improve libxfs device handling Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20231211163742.837427-2-hch@lst.de \
    --to=hch@lst.de \
    --cc=cem@kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.