All of lore.kernel.org
 help / color / mirror / Atom feed
From: Shawn Sung <shawn.sung@mediatek.com>
To: Chun-Kuang Hu <chunkuang.hu@kernel.org>,
	AngeloGioacchino Del Regno
	<angelogioacchino.delregno@collabora.com>
Cc: "Philipp Zabel" <p.zabel@pengutronix.de>,
	"David Airlie" <airlied@gmail.com>,
	"Daniel Vetter" <daniel@ffwll.ch>,
	"Matthias Brugger" <matthias.bgg@gmail.com>,
	"Sumit Semwal" <sumit.semwal@linaro.org>,
	"Christian König" <christian.koenig@amd.com>,
	dri-devel@lists.freedesktop.org,
	linux-mediatek@lists.infradead.org, linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	linux-media@vger.kernel.org, linaro-mm-sig@lists.linaro.org,
	"Hsiao Chien Sung" <shawn.sung@mediatek.corp-partner.google.com>
Subject: [PATCH v2 03/14] drm/mediatek: Rename "mtk_drm_plane" to "mtk_plane"
Date: Tue, 19 Mar 2024 15:02:46 +0800	[thread overview]
Message-ID: <20240319070257.6443-4-shawn.sung@mediatek.com> (raw)
In-Reply-To: <20240319070257.6443-1-shawn.sung@mediatek.com>

From: Hsiao Chien Sung <shawn.sung@mediatek.corp-partner.google.com>

Rename all "mtk_drm_plane" to "mtk_plane":
- To align the naming rule
- To reduce the code size

Reviewed-by: AngeloGiaocchino Del Regno <angelogioacchino.delregno@collabora.com>
Reviewed-by: CK Hu <ck.hu@mediatek.com>
Signed-off-by: Hsiao Chien Sung <shawn.sung@mediatek.corp-partner.google.com>
---
 drivers/gpu/drm/mediatek/mtk_drm_plane.c | 6 +++---
 drivers/gpu/drm/mediatek/mtk_drm_plane.h | 4 ++--
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/gpu/drm/mediatek/mtk_drm_plane.c b/drivers/gpu/drm/mediatek/mtk_drm_plane.c
index cbdb70677d305..43137c46fc148 100644
--- a/drivers/gpu/drm/mediatek/mtk_drm_plane.c
+++ b/drivers/gpu/drm/mediatek/mtk_drm_plane.c
@@ -93,8 +93,8 @@ static bool mtk_plane_format_mod_supported(struct drm_plane *plane,
 	return true;
 }
 
-static void mtk_drm_plane_destroy_state(struct drm_plane *plane,
-					struct drm_plane_state *state)
+static void mtk_plane_destroy_state(struct drm_plane *plane,
+				    struct drm_plane_state *state)
 {
 	__drm_atomic_helper_plane_destroy_state(state);
 	kfree(to_mtk_plane_state(state));
@@ -241,7 +241,7 @@ static const struct drm_plane_funcs mtk_plane_funcs = {
 	.destroy = drm_plane_cleanup,
 	.reset = mtk_plane_reset,
 	.atomic_duplicate_state = mtk_plane_duplicate_state,
-	.atomic_destroy_state = mtk_drm_plane_destroy_state,
+	.atomic_destroy_state = mtk_plane_destroy_state,
 	.format_mod_supported = mtk_plane_format_mod_supported,
 };
 
diff --git a/drivers/gpu/drm/mediatek/mtk_drm_plane.h b/drivers/gpu/drm/mediatek/mtk_drm_plane.h
index 99aff7da0831d..231bb7aac9473 100644
--- a/drivers/gpu/drm/mediatek/mtk_drm_plane.h
+++ b/drivers/gpu/drm/mediatek/mtk_drm_plane.h
@@ -4,8 +4,8 @@
  * Author: CK Hu <ck.hu@mediatek.com>
  */
 
-#ifndef _MTK_DRM_PLANE_H_
-#define _MTK_DRM_PLANE_H_
+#ifndef _MTK_PLANE_H_
+#define _MTK_PLANE_H_
 
 #include <drm/drm_crtc.h>
 #include <linux/types.h>
-- 
2.18.0


WARNING: multiple messages have this Message-ID (diff)
From: Shawn Sung <shawn.sung@mediatek.com>
To: Chun-Kuang Hu <chunkuang.hu@kernel.org>,
	AngeloGioacchino Del Regno
	<angelogioacchino.delregno@collabora.com>
Cc: "Philipp Zabel" <p.zabel@pengutronix.de>,
	"David Airlie" <airlied@gmail.com>,
	"Daniel Vetter" <daniel@ffwll.ch>,
	"Matthias Brugger" <matthias.bgg@gmail.com>,
	"Sumit Semwal" <sumit.semwal@linaro.org>,
	"Christian König" <christian.koenig@amd.com>,
	dri-devel@lists.freedesktop.org,
	linux-mediatek@lists.infradead.org, linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	linux-media@vger.kernel.org, linaro-mm-sig@lists.linaro.org,
	"Hsiao Chien Sung" <shawn.sung@mediatek.corp-partner.google.com>
Subject: [PATCH v2 03/14] drm/mediatek: Rename "mtk_drm_plane" to "mtk_plane"
Date: Tue, 19 Mar 2024 15:02:46 +0800	[thread overview]
Message-ID: <20240319070257.6443-4-shawn.sung@mediatek.com> (raw)
In-Reply-To: <20240319070257.6443-1-shawn.sung@mediatek.com>

From: Hsiao Chien Sung <shawn.sung@mediatek.corp-partner.google.com>

Rename all "mtk_drm_plane" to "mtk_plane":
- To align the naming rule
- To reduce the code size

Reviewed-by: AngeloGiaocchino Del Regno <angelogioacchino.delregno@collabora.com>
Reviewed-by: CK Hu <ck.hu@mediatek.com>
Signed-off-by: Hsiao Chien Sung <shawn.sung@mediatek.corp-partner.google.com>
---
 drivers/gpu/drm/mediatek/mtk_drm_plane.c | 6 +++---
 drivers/gpu/drm/mediatek/mtk_drm_plane.h | 4 ++--
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/gpu/drm/mediatek/mtk_drm_plane.c b/drivers/gpu/drm/mediatek/mtk_drm_plane.c
index cbdb70677d305..43137c46fc148 100644
--- a/drivers/gpu/drm/mediatek/mtk_drm_plane.c
+++ b/drivers/gpu/drm/mediatek/mtk_drm_plane.c
@@ -93,8 +93,8 @@ static bool mtk_plane_format_mod_supported(struct drm_plane *plane,
 	return true;
 }
 
-static void mtk_drm_plane_destroy_state(struct drm_plane *plane,
-					struct drm_plane_state *state)
+static void mtk_plane_destroy_state(struct drm_plane *plane,
+				    struct drm_plane_state *state)
 {
 	__drm_atomic_helper_plane_destroy_state(state);
 	kfree(to_mtk_plane_state(state));
@@ -241,7 +241,7 @@ static const struct drm_plane_funcs mtk_plane_funcs = {
 	.destroy = drm_plane_cleanup,
 	.reset = mtk_plane_reset,
 	.atomic_duplicate_state = mtk_plane_duplicate_state,
-	.atomic_destroy_state = mtk_drm_plane_destroy_state,
+	.atomic_destroy_state = mtk_plane_destroy_state,
 	.format_mod_supported = mtk_plane_format_mod_supported,
 };
 
diff --git a/drivers/gpu/drm/mediatek/mtk_drm_plane.h b/drivers/gpu/drm/mediatek/mtk_drm_plane.h
index 99aff7da0831d..231bb7aac9473 100644
--- a/drivers/gpu/drm/mediatek/mtk_drm_plane.h
+++ b/drivers/gpu/drm/mediatek/mtk_drm_plane.h
@@ -4,8 +4,8 @@
  * Author: CK Hu <ck.hu@mediatek.com>
  */
 
-#ifndef _MTK_DRM_PLANE_H_
-#define _MTK_DRM_PLANE_H_
+#ifndef _MTK_PLANE_H_
+#define _MTK_PLANE_H_
 
 #include <drm/drm_crtc.h>
 #include <linux/types.h>
-- 
2.18.0


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  parent reply	other threads:[~2024-03-19  7:03 UTC|newest]

Thread overview: 64+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-03-19  7:02 [PATCH v2 00/14] Rename mtk_drm_* to mtk_* Shawn Sung
2024-03-19  7:02 ` Shawn Sung
2024-03-19  7:02 ` [PATCH v2 01/14] drm/mediatek: Rename "mtk_drm_crtc" to "mtk_crtc" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-19  7:02 ` [PATCH v2 02/14] drm/mediatek: Rename "mtk_drm_ddp_comp" to "mtk_ddp_comp" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-19 11:11   ` AngeloGioacchino Del Regno
2024-03-19 11:11     ` AngeloGioacchino Del Regno
2024-03-20  1:18     ` Shawn Sung (宋孝謙)
2024-03-20  1:18       ` Shawn Sung (宋孝謙)
2024-03-20  1:18       ` Shawn Sung (宋孝謙)
2024-03-19  7:02 ` Shawn Sung [this message]
2024-03-19  7:02   ` [PATCH v2 03/14] drm/mediatek: Rename "mtk_drm_plane" to "mtk_plane" Shawn Sung
2024-03-19  7:02 ` [PATCH v2 04/14] drm/mediatek: Rename "mtk_drm_gem" to "mtk_gem" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-19  7:02 ` [PATCH v2 05/14] drm/mediatek: Rename "mtk_drm_hdmi" to "mtk_hdmi" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-19  7:02 ` [PATCH v2 06/14] drm/mediatek: Rename files "mtk_drm_crtc.h" to "mtk_crtc.h" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-20  1:34   ` CK Hu (胡俊光)
2024-03-20  1:34     ` CK Hu (胡俊光)
2024-03-20  1:34     ` CK Hu (胡俊光)
2024-03-19  7:02 ` [PATCH v2 07/14] drm/mediatek: Rename files "mtk_drm_crtc.c" to "mtk_crtc.c" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-20  1:38   ` CK Hu (胡俊光)
2024-03-20  1:38     ` CK Hu (胡俊光)
2024-03-20  1:38     ` CK Hu (胡俊光)
2024-03-19  7:02 ` [PATCH v2 08/14] drm/mediatek: Rename files "mtk_drm_ddp_comp.h" to "mtk_ddp_comp.h" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-20  1:42   ` CK Hu (胡俊光)
2024-03-20  1:42     ` CK Hu (胡俊光)
2024-03-20  1:42     ` CK Hu (胡俊光)
2024-03-19  7:02 ` [PATCH v2 09/14] drm/mediatek: Rename files "mtk_drm_ddp_comp.c" to "mtk_ddp_comp.c" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-20  1:55   ` CK Hu (胡俊光)
2024-03-20  1:55     ` CK Hu (胡俊光)
2024-03-20  1:55     ` CK Hu (胡俊光)
2024-03-19  7:02 ` [PATCH v2 10/14] drm/mediatek: Rename files "mtk_drm_plane.h" to "mtk_plane.h" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-20  1:59   ` CK Hu (胡俊光)
2024-03-20  1:59     ` CK Hu (胡俊光)
2024-03-20  1:59     ` CK Hu (胡俊光)
2024-03-19  7:02 ` [PATCH v2 11/14] drm/mediatek: Rename files "mtk_drm_plane.c" to "mtk_plane.c" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-19 11:09   ` AngeloGioacchino Del Regno
2024-03-19 11:09     ` AngeloGioacchino Del Regno
2024-03-20  2:04   ` CK Hu (胡俊光)
2024-03-20  2:04     ` CK Hu (胡俊光)
2024-03-20  2:04     ` CK Hu (胡俊光)
2024-03-20  2:48     ` Shawn Sung (宋孝謙)
2024-03-20  2:48       ` Shawn Sung (宋孝謙)
2024-03-20  2:48       ` Shawn Sung (宋孝謙)
2024-03-19  7:02 ` [PATCH v2 12/14] drm/mediatek: Rename files "mtk_drm_gem.h" to "mtk_gem.h" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-20  2:14   ` CK Hu (胡俊光)
2024-03-20  2:14     ` CK Hu (胡俊光)
2024-03-20  2:14     ` CK Hu (胡俊光)
2024-03-19  7:02 ` [PATCH v2 13/14] drm/mediatek: Rename files "mtk_drm_gem.c" to "mtk_gem.c" Shawn Sung
2024-03-19  7:02   ` Shawn Sung
2024-03-20  2:28   ` CK Hu (胡俊光)
2024-03-20  2:28     ` CK Hu (胡俊光)
2024-03-20  2:28     ` CK Hu (胡俊光)
2024-03-19  7:02 ` [PATCH v2 14/14] drm/mediatek: Rename mtk_ddp_comp functions Shawn Sung
2024-03-19  7:02   ` Shawn Sung

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20240319070257.6443-4-shawn.sung@mediatek.com \
    --to=shawn.sung@mediatek.com \
    --cc=airlied@gmail.com \
    --cc=angelogioacchino.delregno@collabora.com \
    --cc=christian.koenig@amd.com \
    --cc=chunkuang.hu@kernel.org \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linaro-mm-sig@lists.linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=matthias.bgg@gmail.com \
    --cc=p.zabel@pengutronix.de \
    --cc=shawn.sung@mediatek.corp-partner.google.com \
    --cc=sumit.semwal@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.