All of lore.kernel.org
 help / color / mirror / Atom feed
From: Ryder Lee <ryder.lee@mediatek.com>
To: Felix Fietkau <nbd@nbd.name>,
	Lorenzo Bianconi <lorenzo.bianconi@redhat.com>
Cc: Shayne Chen <shayne.chen@mediatek.com>,
	Roy Luo <royluo@google.com>, Sean Wang <sean.wang@mediatek.com>,
	Josh Boyer <jwboyer@kernel.org>, <linux-wireless@vger.kernel.org>,
	<linux-mediatek@lists.infradead.org>,
	Ryder Lee <ryder.lee@mediatek.com>
Subject: [PATCH v2 0/7] switch mt7615 MCU command format from v1 to v2
Date: Sat, 1 Feb 2020 23:33:45 +0800	[thread overview]
Message-ID: <cover.1580565624.git.ryder.lee@mediatek.com> (raw)

Hi,

This updates command flow to adapt newer firmware version.

Changes since v2:
- check the return value from __mt76_mcu_send_msg.
- rename dev->fw_ver to '2.0'.
- simplify is_v1 expression.
- revise commit messages.

Ryder Lee (7):
  mt76: mt7615: simplify mcu_set_bmc flow
  mt76: mt7615: simplify mcu_set_sta flow
  mt76: mt7615: add a helper to encapsulate sta_rec operation
  mt76: mt7615: add starec operating flow for firmware v2
  mt76: mt7615: use new tag sta_rec_wtbl
  mt76: mt7615: switch mt7615_mcu_set_tx_ba to v2 format
  mt76: mt7615: switch mt7615_mcu_set_rx_ba to v2 format

 .../net/wireless/mediatek/mt76/mt7615/main.c  |  12 +-
 .../net/wireless/mediatek/mt76/mt7615/mcu.c   | 577 +++++++++---------
 .../net/wireless/mediatek/mt76/mt7615/mcu.h   |   8 +-
 .../wireless/mediatek/mt76/mt7615/mt7615.h    |  20 +-
 4 files changed, 310 insertions(+), 307 deletions(-)

-- 
2.18.0

WARNING: multiple messages have this Message-ID (diff)
From: Ryder Lee <ryder.lee@mediatek.com>
To: Felix Fietkau <nbd@nbd.name>,
	Lorenzo Bianconi <lorenzo.bianconi@redhat.com>
Cc: Ryder Lee <ryder.lee@mediatek.com>,
	Josh Boyer <jwboyer@kernel.org>,
	Sean Wang <sean.wang@mediatek.com>,
	linux-wireless@vger.kernel.org,
	linux-mediatek@lists.infradead.org, Roy Luo <royluo@google.com>,
	Shayne Chen <shayne.chen@mediatek.com>
Subject: [PATCH v2 0/7] switch mt7615 MCU command format from v1 to v2
Date: Sat, 1 Feb 2020 23:33:45 +0800	[thread overview]
Message-ID: <cover.1580565624.git.ryder.lee@mediatek.com> (raw)

Hi,

This updates command flow to adapt newer firmware version.

Changes since v2:
- check the return value from __mt76_mcu_send_msg.
- rename dev->fw_ver to '2.0'.
- simplify is_v1 expression.
- revise commit messages.

Ryder Lee (7):
  mt76: mt7615: simplify mcu_set_bmc flow
  mt76: mt7615: simplify mcu_set_sta flow
  mt76: mt7615: add a helper to encapsulate sta_rec operation
  mt76: mt7615: add starec operating flow for firmware v2
  mt76: mt7615: use new tag sta_rec_wtbl
  mt76: mt7615: switch mt7615_mcu_set_tx_ba to v2 format
  mt76: mt7615: switch mt7615_mcu_set_rx_ba to v2 format

 .../net/wireless/mediatek/mt76/mt7615/main.c  |  12 +-
 .../net/wireless/mediatek/mt76/mt7615/mcu.c   | 577 +++++++++---------
 .../net/wireless/mediatek/mt76/mt7615/mcu.h   |   8 +-
 .../wireless/mediatek/mt76/mt7615/mt7615.h    |  20 +-
 4 files changed, 310 insertions(+), 307 deletions(-)

-- 
2.18.0
_______________________________________________
Linux-mediatek mailing list
Linux-mediatek@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-mediatek

             reply	other threads:[~2020-02-01 15:34 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-01 15:33 Ryder Lee [this message]
2020-02-01 15:33 ` [PATCH v2 0/7] switch mt7615 MCU command format from v1 to v2 Ryder Lee
2020-02-01 15:33 ` [PATCH v2 1/7] mt76: mt7615: simplify mcu_set_bmc flow Ryder Lee
2020-02-01 15:33   ` Ryder Lee
2020-02-01 15:33 ` [PATCH v2 2/7] mt76: mt7615: simplify mcu_set_sta flow Ryder Lee
2020-02-01 15:33   ` Ryder Lee
2020-02-01 15:33 ` [PATCH v2 3/7] mt76: mt7615: add a helper to encapsulate sta_rec operation Ryder Lee
2020-02-01 15:33   ` Ryder Lee
2020-02-01 15:33 ` [PATCH v2 4/7] mt76: mt7615: add starec operating flow for firmware v2 Ryder Lee
2020-02-01 15:33   ` Ryder Lee
2020-02-01 15:33 ` [PATCH v2 5/7] mt76: mt7615: use new tag sta_rec_wtbl Ryder Lee
2020-02-01 15:33   ` Ryder Lee
2020-02-01 15:33 ` [PATCH v2 6/7] mt76: mt7615: switch mt7615_mcu_set_tx_ba to v2 format Ryder Lee
2020-02-01 15:33   ` Ryder Lee
2020-02-01 15:33 ` [PATCH v2 7/7] mt76: mt7615: switch mt7615_mcu_set_rx_ba " Ryder Lee
2020-02-01 15:33   ` Ryder Lee

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cover.1580565624.git.ryder.lee@mediatek.com \
    --to=ryder.lee@mediatek.com \
    --cc=jwboyer@kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=lorenzo.bianconi@redhat.com \
    --cc=nbd@nbd.name \
    --cc=royluo@google.com \
    --cc=sean.wang@mediatek.com \
    --cc=shayne.chen@mediatek.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.