rcu.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2019-07-13 08:47:44 to 2019-08-01 23:09:29 UTC [more...]

[PATCH tip/core/rcu 0/18] No-CBs cblist updates for v5.3-rc2
 2019-08-01 23:08 UTC  (17+ messages)
` [PATCH tip/core/rcu 01/18] rcu/nocb: Use separate flag to indicate disabled ->cblist
` [PATCH tip/core/rcu 02/18] rcu/nocb: Use separate flag to indicate offloaded ->cblist
` [PATCH tip/core/rcu 03/18] rcu/nocb: Add checks for offloaded callback processing
` [PATCH tip/core/rcu 04/18] rcu/nocb: Make rcutree_migrate_callbacks() start at leaf rcu_node structure
` [PATCH tip/core/rcu 05/18] rcu/nocb: Check for deferred nocb wakeups before nohz_full early exit
` [PATCH tip/core/rcu 06/18] rcu/nocb: Remove deferred wakeup checks for extended quiescent states
` [PATCH tip/core/rcu 07/18] rcu/nocb: Allow lockless use of rcu_segcblist_restempty()
` [PATCH tip/core/rcu 08/18] rcu/nocb: Allow lockless use of rcu_segcblist_empty()
` [PATCH tip/core/rcu 09/18] rcu/nocb: Leave ->cblist enabled for no-CBs CPUs
` [PATCH tip/core/rcu 10/18] rcu/nocb: Use rcu_segcblist "
` [PATCH tip/core/rcu 11/18] rcu/nocb: Remove obsolete nocb_head and nocb_tail fields
` [PATCH tip/core/rcu 12/18] rcu/nocb: Remove obsolete nocb_q_count and nocb_q_count_lazy fields
` [PATCH tip/core/rcu 13/18] rcu/nocb: Remove obsolete nocb_cb_tail and nocb_cb_head fields
` [PATCH tip/core/rcu 14/18] rcu/nocb: Remove obsolete nocb_gp_head and nocb_gp_tail fields
` [PATCH tip/core/rcu 16/18] rcu/nocb: Use build-time no-CBs check in rcu_core()
` [PATCH tip/core/rcu 18/18] rcu/nocb: Suppress uninitialized false-positive in nocb_gp_wait()

[PATCH tip/core/rcu 0/11] No-CBs grace-period kthread updates for v5.3-rc2
 2019-08-01 22:50 UTC  (12+ messages)
` [PATCH tip/core/rcu 01/11] rcu/nocb: Rename rcu_data fields to prepare for forward-progress work
` [PATCH tip/core/rcu 02/11] rcu/nocb: Update comments "
` [PATCH tip/core/rcu 03/11] rcu/nocb: Provide separate no-CBs grace-period kthreads
` [PATCH tip/core/rcu 04/11] rcu/nocb: Rename nocb_follower_wait() to nocb_cb_wait()
` [PATCH tip/core/rcu 05/11] rcu/nocb: Rename wake_nocb_leader() to wake_nocb_gp()
` [PATCH tip/core/rcu 06/11] rcu/nocb: Rename __wake_nocb_leader() to __wake_nocb_gp()
` [PATCH tip/core/rcu 07/11] rcu/nocb: Rename wake_nocb_leader_defer() to wake_nocb_gp_defer()
` [PATCH tip/core/rcu 08/11] rcu/nocb: Rename rcu_organize_nocb_kthreads() local variable
` [PATCH tip/core/rcu 09/11] rcu/nocb: Rename and document no-CB CB kthread sleep trace event
` [PATCH tip/core/rcu 10/11] rcu/nocb: Rename rcu_nocb_leader_stride kernel boot parameter
` [PATCH tip/core/rcu 11/11] rcu/nocb: Print gp/cb kthread hierarchy if dump_tree

[PATCH tip/core/rcu 0/8] RCU list-traversal lockdep updates for v5.4
 2019-08-01 22:42 UTC  (9+ messages)
` [PATCH tip/core/rcu 1/8] treewide: Rename rcu_dereference_raw_notrace() to _check()
` [PATCH tip/core/rcu 2/8] rcu: Remove redundant debug_locks check in rcu_read_lock_sched_held()
` [PATCH tip/core/rcu 3/8] rcu: Add support for consolidated-RCU reader checking
` [PATCH tip/core/rcu 4/8] rcu/sync: Remove custom check for RCU readers
` [PATCH tip/core/rcu 5/8] ipv4: Add lockdep condition to fix for_each_entry()
` [PATCH tip/core/rcu 6/8] driver/core: Convert to use built-in RCU list checking
` [PATCH tip/core/rcu 7/8] x86/pci: Pass lockdep condition to pcm_mmcfg_list iterator
` [PATCH tip/core/rcu 8/8] acpi: Use built-in RCU list checking for acpi_ioremaps list

[PATCH tip/core/rcu 0/12] Miscellaneous fixes for v5.4
 2019-08-01 22:37 UTC  (13+ messages)
` [PATCH tip/core/rcu 01/12] lockdep: Make print_lock() address visible
` [PATCH tip/core/rcu 02/12] time/tick-broadcast: Fix tick_broadcast_offline() lockdep complaint
` [PATCH tip/core/rcu 03/12] rcu: Restore barrier() to rcu_read_lock() and rcu_read_unlock()
` [PATCH tip/core/rcu 04/12] rcu: Add kernel parameter to dump trace after RCU CPU stall warning
` [PATCH tip/core/rcu 05/12] rcu: Add destroy_work_on_stack() to match INIT_WORK_ONSTACK()
` [PATCH tip/core/rcu 06/12] srcu: Avoid srcutorture security-based pointer obfuscation
` [PATCH tip/core/rcu 07/12] rcu: Change return type of rcu_spawn_one_boost_kthread()
` [PATCH tip/core/rcu 08/12] doc: Add rcutree.kthread_prio pointer to stallwarn.txt
` [PATCH tip/core/rcu 09/12] idle: Prevent late-arriving interrupts from disrupting offline
` [PATCH tip/core/rcu 10/12] rcu: Remove redundant "if" condition from rcu_gp_is_expedited()
` [PATCH tip/core/rcu 11/12] arm: Use common outgoing-CPU-notification code
` [PATCH tip/core/rcu 12/12] rcu: Fix spelling mistake "greate"->"great"

[PATCH tip/core/rcu 0/3] Straggling consolidation cleanups for v5.4
 2019-08-01 22:31 UTC  (4+ messages)
` [PATCH tip/core/rcu 1/3] rcu: Simplify rcu_read_unlock_special() deferred wakeups
` [PATCH tip/core/rcu 2/3] rcu: Make rcu_read_unlock_special() checks match raise_softirq_irqoff()
` [PATCH tip/core/rcu 3/3] rcu: Simplify rcu_note_context_switch exit from critical section

[PATCH v2 0/7] Doc updates to /dev branch
 2019-08-01 21:41 UTC  (8+ messages)
` ['PATCH v2' 1/7] Revert docs from "rcu: Restore barrier() to rcu_read_lock() and rcu_read_unlock()"
` ['PATCH v2' 2/7] Revert docs from "treewide: Rename rcu_dereference_raw_notrace() to _check()"
` ['PATCH v2' 4/7] docs: rcu: Correct links referring to titles
` ['PATCH v2' 5/7] docs: rcu: Increase toctree to 3
` ['PATCH v2' 6/7] Restore docs "treewide: Rename rcu_dereference_raw_notrace() to _check()"
` ['PATCH v2' 7/7] Restore docs "rcu: Restore barrier() to rcu_read_lock() and rcu_read_unlock()"

[PATCH tip/core/rcu 1/1] rcu: Remove unused function rcutorture_record_progress
 2019-08-01 21:00 UTC 

[PATCH 0/9] Apply new rest conversion patches to /dev branch
 2019-08-01 20:14 UTC  (13+ messages)
` [PATCH 1/9] Revert "rcu: Restore barrier() to rcu_read_lock() and rcu_read_unlock()"
` [PATCH 2/9] Revert "rcu: Add support for consolidated-RCU reader checking"
` [PATCH 3/9] Revert "treewide: Rename rcu_dereference_raw_notrace() to _check()"
` [PATCH 5/9] docs: rcu: Correct links referring to titles
` [PATCH 6/9] docs: rcu: Increase toctree to 3
` [PATCH 7/9] Revert "Revert "treewide: Rename rcu_dereference_raw_notrace() to _check()""
` [PATCH 8/9] Revert "Revert "rcu: Add support for consolidated-RCU reader checking""
` [PATCH 9/9] Revert "Revert "rcu: Restore barrier() to rcu_read_lock() and rcu_read_unlock()""

[PATCH v2 00/26] ReST conversion of text files without .txt extension
 2019-07-31  1:33 UTC  (19+ messages)
      ` [PATCH v2 25/26] docs: rcu: convert some articles from html to ReST

[PATCH v3 0/3] Convert some RCU articles to ReST
 2019-07-30 23:57 UTC  (5+ messages)
` [PATCH v3 2/3] docs: rcu: Correct links referring to titles
` [PATCH v3 3/3] docs: rcu: Increase toctree to 3

How to turn scheduler tick on for current nohz_full CPU?
 2019-07-30 17:36 UTC  (8+ messages)

[PATCH] rcu: Fix spelling mistake "greate"->"great"
 2019-07-30 16:02 UTC  (2+ messages)

[PATCH 1/7] docs: fix broken doc references due to renames
 2019-07-29 23:17 UTC  (4+ messages)

[PATCH] rcu: Make jiffies_till_sched_qs writable
 2019-07-24  7:59 UTC  (41+ messages)

[PATCH 00/14] pending doc patches for 5.3-rc
 2019-07-22 11:38 UTC  (3+ messages)
` [PATCH 03/14] docs: fix broken doc references due to renames

[PATCH 00/22] ReST conversion of text files without .txt extension
 2019-07-22 11:07 UTC 

This percpu_rwsem that always enters its reader slow path
 2019-07-21 13:28 UTC  (4+ messages)

[PATCH 0/9] Harden list_for_each_entry_rcu() and family
 2019-07-17  0:07 UTC  (26+ messages)
` [PATCH 1/9] rcu/update: Remove useless check for debug_locks (v1)
` [PATCH 2/9] rcu: Add support for consolidated-RCU reader checking (v3)
` [PATCH 3/9] rcu/sync: Remove custom check for reader-section (v2)
` [PATCH 4/9] ipv4: add lockdep condition to fix for_each_entry (v1)
` [PATCH 5/9] driver/core: Convert to use built-in RCU list checking (v1)
` [PATCH 6/9] workqueue: Convert for_each_wq to use built-in list check (v2)
` [PATCH 7/9] x86/pci: Pass lockdep condition to pcm_mmcfg_list iterator (v1)
` [PATCH 8/9] acpi: Use built-in RCU list checking for acpi_ioremaps list (v1)
` [PATCH 9/9] doc: Update documentation about list_for_each_entry_rcu (v1)

[PATCH v2 0/9] Harden list_for_each_entry_rcu() and family
 2019-07-16 18:50 UTC  (23+ messages)
` [PATCH v2 2/9] rcu: Add support for consolidated-RCU reader checking
` [PATCH v2 3/9] rcu/sync: Remove custom check for reader-section

[PATCH] rculist: Add build check for single optional list argument
 2019-07-16  4:07 UTC 

[PATCH AUTOSEL 5.2 101/249] rcu: Force inlining of rcu_read_lock()
 2019-07-15 13:44 UTC 

[PATCH AUTOSEL 4.14 048/105] rcu: Force inlining of rcu_read_lock()
 2019-07-15 14:27 UTC 

[PATCH AUTOSEL 4.4 30/53] rcu: Force inlining of rcu_read_lock()
 2019-07-15 14:45 UTC 

[PATCH AUTOSEL 4.9 37/73] rcu: Force inlining of rcu_read_lock()
 2019-07-15 14:35 UTC 

[PATCH AUTOSEL 4.19 067/158] rcu: Force inlining of rcu_read_lock()
 2019-07-15 14:16 UTC 

[PATCH AUTOSEL 5.1 089/219] rcu: Force inlining of rcu_read_lock()
 2019-07-15 14:01 UTC 

[PATCH] docs: fix broken doc links due to renames
 2019-07-15  9:12 UTC 

[PATCH] rcuperf: Make rcuperf kernel test more robust for !expedited mode
 2019-07-13 14:18 UTC  (7+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).