rcu.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-02-27 18:07:07 to 2020-03-23 11:36:56 UTC [more...]

[PATCH 0/7] Headless support in the kvfree_rcu()
 2020-03-23 11:36 UTC  (7+ messages)
` [PATCH 1/7] rcu/tree: simplify KFREE_BULK_MAX_ENTR macro
` [PATCH 3/7] rcu/tree: introduce expedited_drain flag
` [PATCH 4/7] rcu/tree: support reclaim for head-less object
` [PATCH 5/7] rcu/tiny: move kvfree_call_rcu() out of header
` [PATCH 6/7] rcu/tiny: support reclaim for head-less object
` [PATCH 7/7] rcu: support headless variant in the kvfree_rcu()

[GIT PULL rcu/next] RCU commits for v5.7
 2020-03-22 14:53 UTC  (2+ messages)
` [GIT PULL v2 "

[PATCH RFC tip/core/rcu 0/16] Prototype RCU usable from idle, exception, offline
 2020-03-20 19:14 UTC  (78+ messages)
` [PATCH RFC tip/core/rcu 01/16] sched/core: Add function to sample state of non-running function
` [PATCH RFC tip/core/rcu 02/16] rcu: Add per-task state to RCU CPU stall warnings
` [PATCH RFC tip/core/rcu 03/16] rcutorture: Add flag to produce non-busy-wait task stalls
` [PATCH RFC tip/core/rcu 04/16] rcu-tasks: Move Tasks RCU to its own file
` [PATCH RFC tip/core/rcu 05/16] rcu-tasks: Create struct to hold state information
` [PATCH RFC tip/core/rcu 06/16] rcu: Reinstate synchronize_rcu_mult()
` [PATCH RFC tip/core/rcu 07/16] rcutorture: Add a test for synchronize_rcu_mult()
` [PATCH RFC tip/core/rcu 08/16] rcu-tasks: Refactor RCU-tasks to allow variants to be added
` [PATCH RFC tip/core/rcu 09/16] rcu-tasks: Add an RCU-tasks rude variant
` [PATCH RFC tip/core/rcu 10/16] rcutorture: Add torture tests for RCU Tasks Rude
` [PATCH RFC tip/core/rcu 11/16] rcu-tasks: Use unique names for RCU-Tasks kthreads and messages
` [PATCH RFC tip/core/rcu 12/16] rcu-tasks: Further refactor RCU-tasks to allow adding more variants
` [PATCH RFC tip/core/rcu 13/16] rcu-tasks: Code movement to allow more Tasks RCU variants
` [PATCH RFC tip/core/rcu 14/16] rcu: Add an RCU Tasks Trace to simplify protection of tracing hooks
` [PATCH RFC tip/core/rcu 15/16] rcutorture: Add torture tests for RCU Tasks Trace
` [PATCH RFC tip/core/rcu 16/16] rcu-tasks: Add stall warnings "
` [PATCH RFC v2 tip/core/rcu 0/22] Prototype RCU usable from idle, exception, offline
  ` [PATCH RFC v2 tip/core/rcu 01/22] sched/core: Add function to sample state of locked-down task
  ` [PATCH RFC v2 tip/core/rcu 02/22] rcu: Add per-task state to RCU CPU stall warnings
  ` [PATCH RFC v2 tip/core/rcu 03/22] rcutorture: Add flag to produce non-busy-wait task stalls
  ` [PATCH RFC v2 tip/core/rcu 04/22] rcu-tasks: Move Tasks RCU to its own file
  ` [PATCH RFC v2 tip/core/rcu 05/22] rcu-tasks: Create struct to hold state information
  ` [PATCH RFC v2 tip/core/rcu 06/22] rcu: Reinstate synchronize_rcu_mult()
  ` [PATCH RFC v2 tip/core/rcu 07/22] rcutorture: Add a test for synchronize_rcu_mult()
  ` [PATCH RFC v2 tip/core/rcu 08/22] rcu-tasks: Refactor RCU-tasks to allow variants to be added
  ` [PATCH RFC v2 tip/core/rcu 09/22] rcu-tasks: Add an RCU-tasks rude variant
  ` [PATCH RFC v2 tip/core/rcu 10/22] rcutorture: Add torture tests for RCU Tasks Rude
  ` [PATCH RFC v2 tip/core/rcu 11/22] rcu-tasks: Use unique names for RCU-Tasks kthreads and messages
  ` [PATCH RFC v2 tip/core/rcu 12/22] rcu-tasks: Further refactor RCU-tasks to allow adding more variants
  ` [PATCH RFC v2 tip/core/rcu 13/22] rcu-tasks: Code movement to allow more Tasks RCU variants
  ` [PATCH RFC v2 tip/core/rcu 14/22] rcu-tasks: Add an RCU Tasks Trace to simplify protection of tracing hooks
  ` [PATCH RFC v2 tip/core/rcu 15/22] rcutorture: Add torture tests for RCU Tasks Trace
  ` [PATCH RFC v2 tip/core/rcu 16/22] rcu-tasks: Add stall warnings "
  ` [PATCH RFC v2 tip/core/rcu 17/22] rcu-tasks: Move #ifdef into tasks.h
  ` [PATCH RFC v2 tip/core/rcu 18/22] rcu-tasks: Add RCU tasks to rcutorture writer stall output
  ` [PATCH RFC v2 tip/core/rcu 19/22] rcu-tasks: Make rcutorture writer stall output include GP state
  ` [PATCH RFC v2 tip/core/rcu 20/22] rcu-tasks: Make RCU Tasks Trace make use of RCU scheduler hooks
  ` [PATCH RFC v2 tip/core/rcu 21/22] rcu-tasks: Add a grace-period start time for throttling and debug
  ` [PATCH RFC v2 tip/core/rcu 22/22] rcu-tasks: Provide boot parameter to delay IPIs until late in grace period

linux-next build error (8)
 2020-03-20 17:04 UTC  (10+ messages)

PROVE_RCU_LIST + /proc/lockdep warning
 2020-03-20 11:50 UTC  (13+ messages)
` Hard lockups due to "tick/common: Make tick_periodic() check for missing ticks"

RCU use of swait
 2020-03-19  9:25 UTC  (4+ messages)

kernel/rcu/tasks.h:1070:37: error: ‘rcu_tasks_rude’ undeclared
 2020-03-18 16:05 UTC  (2+ messages)

[PATCH v2 rcu-dev 1/3] rcuperf: Add ability to increase object allocation size
 2020-03-18  1:09 UTC  (9+ messages)
` [PATCH v2 rcu-dev 2/3] rcu/tree: Add a shrinker to prevent OOM due to kfree_rcu() batching
` [PATCH v2 rcu-dev 3/3] rcu/tree: Count number of batched kfree_rcu() locklessly

[PATCH 09/17] rcu: update.c: get rid of some doc warnings
 2020-03-17 16:45 UTC  (2+ messages)

Power outage
 2020-03-17  1:44 UTC  (4+ messages)

[PATCH v1 0/6] Introduce kvfree_rcu() logic
 2020-03-16 19:48 UTC  (18+ messages)
` [PATCH v1 1/6] mm/list_lru.c: rename kvfree_rcu() to local variant
` [PATCH v1 2/6] rcu: introduce kvfree_rcu() interface
` [PATCH v1 3/6] rcu: rename rcu_invoke_kfree_callback/rcu_kfree_callback
` [PATCH v1 4/6] rcu: rename __is_kfree_rcu_offset() macro
` [PATCH v1 5/6] rcu: rename kfree_call_rcu()/__kfree_rcu()
` [PATCH v1 6/6] mm/list_lru.c: remove kvfree_rcu_local() function

[RFC] Simplify debug_objects handling in kfree_rcu
 2020-03-16 17:42 UTC 

[PATCH] locking/lockdep: Avoid recursion in lockdep_count_{for,back}ward_deps()
 2020-03-16 15:01 UTC  (6+ messages)

[PATCH RFC tip/core/rcu 0/2] Fix RCU idle-exit problem and comment
 2020-03-13 21:47 UTC  (5+ messages)
` [PATCH RFC tip/core/rcu 1/2] rcu: Don't acquire lock in NMI handler in rcu_nmi_enter_common()
` [PATCH RFC tip/core/rcu 2/2] rcu: Add comments marking transitions between RCU watching and not

Is there a reason we don't have kvfree_rcu()?
 2020-03-13 19:58 UTC  (14+ messages)

[PATCH -next] rcu-tasks: fix a modpost warning for rcu_tasks_rude_wait_gp
 2020-03-13 13:49 UTC  (2+ messages)

Clang warning in kernel/rcu/tasks.h
 2020-03-10 21:56 UTC  (2+ messages)

[PATCH rcu-dev 1/2] rcuperf: Add ability to increase object allocation size
 2020-03-09  3:26 UTC  (4+ messages)
` [PATCH rcu-dev 2/2] rcu/tree: Add a shrinker to prevent OOM due to kfree_rcu() batching

[PATCH] rcu: Fix the (t=0 jiffies) false positive
 2020-03-06  5:06 UTC  (3+ messages)

[PATCH linus/master 1/2] rcuperf: Add ability to increase object allocation size
 2020-03-06  2:17 UTC  (5+ messages)
` [PATCH linus/master 2/2] rcu/tree: Add a shrinker to prevent OOM due to kfree_rcu() batching

[PATCH] Revert "rculist: Describe variadic macro argument in a Sphinx-compatible way"
 2020-03-05 23:07 UTC  (2+ messages)

rcu_sched stalls on 4.14
 2020-03-03 22:41 UTC  (4+ messages)

[PATCH v3] ipc: use a work queue to free_ipc
 2020-02-29 23:55 UTC  (2+ messages)

[Linux-kernel-mentees] [PATCH v3] doc: Convert rculist_nulls.txt to rculist_nulls.rst
 2020-02-29 16:36 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).