rcu.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-04-17 18:26:44 to 2020-05-07 17:34:55 UTC [more...]

[PATCH 00/24] Introduce kvfree_rcu(1 or 2 arguments)
 2020-05-07 17:34 UTC  (78+ messages)
` [PATCH 01/24] rcu/tree: Keep kfree_rcu() awake during lock contention
` [PATCH 02/24] rcu/tree: Skip entry into the page allocator for PREEMPT_RT
` [PATCH 03/24] rcu/tree: Use consistent style for comments
` [PATCH 04/24] rcu/tree: Repeat the monitor if any free channel is busy
` [PATCH 05/24] rcu/tree: Simplify debug_objects handling
` [PATCH 06/24] rcu/tree: Simplify KFREE_BULK_MAX_ENTR macro
` [PATCH 07/24] rcu/tree: move locking/unlocking to separate functions
` [PATCH 08/24] rcu/tree: Use static initializer for krc.lock
` [PATCH 09/24] rcu/tree: cache specified number of objects
` [PATCH 10/24] rcu/tree: add rcutree.rcu_min_cached_objs description
` [PATCH 11/24] rcu/tree: Maintain separate array for vmalloc ptrs
` [PATCH 12/24] rcu/tiny: support vmalloc in tiny-RCU
` [PATCH 13/24] rcu: Rename rcu_invoke_kfree_callback/rcu_kfree_callback
` [PATCH 14/24] rcu: Rename __is_kfree_rcu_offset() macro
` [PATCH 15/24] rcu: Rename kfree_call_rcu() to the kvfree_call_rcu()
` [PATCH 16/24] mm/list_lru.c: Rename kvfree_rcu() to local variant
` [PATCH 17/24] rcu: Introduce 2 arg kvfree_rcu() interface
` [PATCH 18/24] mm/list_lru.c: Remove kvfree_rcu_local() function
` [PATCH 19/24] rcu/tree: Support reclaim for head-less object
` [PATCH 20/24] rcu/tree: Make kvfree_rcu() tolerate any alignment
` [PATCH 21/24] rcu/tiny: move kvfree_call_rcu() out of header
` [PATCH 22/24] rcu/tiny: support reclaim for head-less object
` [PATCH 23/24] rcu: Introduce 1 arg kvfree_rcu() interface
` [PATCH 24/24] lib/test_vmalloc.c: Add test cases for kvfree_rcu()

[PATCH RFC tip/core/rcu] Add shrinker to shift to fast/inefficient GP mode
 2020-05-07 17:29 UTC  (7+ messages)

[PATCH RFC] rcu/tree: Refactor object allocation and try harder for array allocation
 2020-05-05 18:33 UTC  (16+ messages)

[PATCH v3 0/5] RCU dyntick nesting counter cleanups for rcu -dev
 2020-05-04 18:18 UTC  (10+ messages)
` [PATCH v3 1/5] Revert b8c17e6664c4 ("rcu: Maintain special bits at bottom of ->dynticks counter")
` [PATCH v3 2/5] rcu/tree: Add better tracing for dyntick-idle
` [PATCH v3 3/5] rcu/tree: Clean up dynticks counter usage
` [PATCH v3 4/5] rcu/tree: Remove dynticks_nmi_nesting counter
` [PATCH v3 5/5] trace: events: rcu: Change description of rcu_dyntick trace event

[PATCH] rcu: fix some kernel-doc warnings
 2020-05-04 12:35 UTC 

Discussion about rcu_barrier() in ext4
 2020-04-30  5:39 UTC  (2+ messages)

[bug report] rcutorture: Add races with task-exit processing
 2020-04-29 17:47 UTC  (4+ messages)

[PATCH] rcutorture: Fix error codes in rcu_torture_read_exit_init()
 2020-04-29 15:53 UTC  (2+ messages)

[PATCH 15/24] mm/list_lru.c: Rename kvfree_rcu() to local variant
 2020-04-27 11:11 UTC  (2+ messages)
` [PATCH 18/24] mm/list_lru.c: Remove kvfree_rcu_local() function

[PATCH v1 0/6] Introduce kvfree_rcu() logic
 2020-04-22 23:16 UTC  (8+ messages)
` [PATCH v1 5/6] rcu: rename kfree_call_rcu()/__kfree_rcu()

[PATCH 1/3] rcu: Use static initializer for krc.lock
 2020-04-22 16:35 UTC  (51+ messages)

[PATCH rcu/dev -fixes 0/4]
 2020-04-22 13:28 UTC  (13+ messages)
` [PATCH rcu/dev -fixes 1/4] rcu/tree: Keep kfree_rcu() awake during lock contention
` [PATCH rcu/dev -fixes 2/4] rcu/tree: Skip entry into the page allocator for PREEMPT_RT
` [PATCH rcu/dev -fixes 3/4] rcu/tree: Avoid using xchg() in kfree_call_rcu_add_ptr_to_bulk()
` [PATCH rcu/dev -fixes 4/4] rcu/tree: Use consistent style for comments

[PATCH 00/10] Manually convert RCU text files to ReST format
 2020-04-22  0:42 UTC  (16+ messages)
` [PATCH 01/10] docs: RCU: convert checklist.txt to ReST
` [PATCH 02/10] docs: RCU: convert lockdep-splat.txt "
` [PATCH 03/10] docs: RCU: convert lockdep.txt "
` [PATCH 04/10] docs: RCU: convert rculist_nulls.txt "
` [PATCH 05/10] docs: RCU: convert torture.txt "
` [PATCH 06/10] docs: RCU: convert rcuref.txt "
` [PATCH 07/10] docs: RCU: RTFP: fix bibtex entries
` [PATCH 08/10] docs: RCU: convert RTFP.txt to ReST
` [PATCH 09/10] docs: RCU: stallwarn.txt: convert it "
` [PATCH 10/10] docs: RCU: rculist_nulls.rst: don't duplicate chapter names

[Patch v2] rcu: simplify the calculation of rcu_state.ncpus
 2020-04-20 21:28 UTC  (3+ messages)

[PATCH 0/3] rcu: Static initializer + misc
 2020-04-20 15:23 UTC  (3+ messages)
` [PATCH 3/3] rcu: Avoid using xchg() in kfree_call_rcu_add_ptr_to_bulk()

[PATCH] rcu: simplify the calculation of rcu_state.ncpus
 2020-04-19 21:48 UTC  (5+ messages)

[PATCH] srcu: Fix a typo in comment "amoritized"->"amortized"
 2020-04-19 15:15 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).