Linux kernel regressions
 help / color / Atom feed
* regressions in iommu system with 5.10.37
@ 2021-05-19  8:01 Anatoli N.Chechelnickiy
  2021-05-19  8:23 ` Greg KH
  0 siblings, 1 reply; 2+ messages in thread
From: Anatoli N.Chechelnickiy @ 2021-05-19  8:01 UTC (permalink / raw)
  To: stable; +Cc: regressions, baolu.lu, sashal


[-- Attachment #1: Type: text/plain, Size: 882 bytes --]

Hi

I'm sorry to report about regression in 5.10.37

with

CONFIG_IOMMU_IOVA=y
CONFIG_IOMMU_API=y
CONFIG_IOMMU_SUPPORT=y
CONFIG_OF_IOMMU=y
CONFIG_INTEL_IOMMU=y
CONFIG_INTEL_IOMMU_SVM=y
CONFIG_INTEL_IOMMU_DEFAULT_ON=y
CONFIG_INTEL_IOMMU_FLOPPY_WA=y

and iommu=on in grub.cfg


All my dell r340 and all lenovo servers won't boot any more. Just black 
screen at once.


with intel_iommu=on iommu=pt DELL R240 and Lenovo SR350 cat boot

Older Lenovo cannot boot even with "intel_iommu=on iommu=pt" only with 
iommu=off in grub

With iommu=off in grub all servers are booting well

With 5.4.36 do not have this problem


tested last 4 days with 10+ different servers(


-- 
Best regards,
Anatoli N. Chechel'nickiy
Senior expert of IT security department


Phone: +380 562 7474 200


Anatoli.Chechelnickiy@interpipe.biz
www.interpipe.biz



[-- Attachment #2: S/MIME Cryptographic Signature --]
[-- Type: application/pkcs7-signature, Size: 4550 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: regressions in iommu system with 5.10.37
  2021-05-19  8:01 regressions in iommu system with 5.10.37 Anatoli N.Chechelnickiy
@ 2021-05-19  8:23 ` Greg KH
  0 siblings, 0 replies; 2+ messages in thread
From: Greg KH @ 2021-05-19  8:23 UTC (permalink / raw)
  To: Anatoli N.Chechelnickiy; +Cc: stable, regressions, baolu.lu, sashal

On Wed, May 19, 2021 at 08:01:29AM +0000, Anatoli N.Chechelnickiy wrote:
> Hi
> 
> I'm sorry to report about regression in 5.10.37
> 
> with
> 
> CONFIG_IOMMU_IOVA=y
> CONFIG_IOMMU_API=y
> CONFIG_IOMMU_SUPPORT=y
> CONFIG_OF_IOMMU=y
> CONFIG_INTEL_IOMMU=y
> CONFIG_INTEL_IOMMU_SVM=y
> CONFIG_INTEL_IOMMU_DEFAULT_ON=y
> CONFIG_INTEL_IOMMU_FLOPPY_WA=y
> 
> and iommu=on in grub.cfg
> 
> 
> All my dell r340 and all lenovo servers won't boot any more. Just black
> screen at once.
> 
> 
> with intel_iommu=on iommu=pt DELL R240 and Lenovo SR350 cat boot
> 
> Older Lenovo cannot boot even with "intel_iommu=on iommu=pt" only with
> iommu=off in grub
> 
> With iommu=off in grub all servers are booting well
> 
> With 5.4.36 do not have this problem
> 
> 
> tested last 4 days with 10+ different servers(

Should be fixed with 5.10.38.  If not, please let us know.

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-19  8:01 regressions in iommu system with 5.10.37 Anatoli N.Chechelnickiy
2021-05-19  8:23 ` Greg KH

Linux kernel regressions

Archives are clonable:
	git clone --mirror https://lore.kernel.org/regressions/0 regressions/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 regressions regressions/ https://lore.kernel.org/regressions \
		regressions@lists.linux.dev
	public-inbox-index regressions

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/dev.linux.lists.regressions


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git