SELinux-Refpolicy Archive on
 help / color / Atom feed
From: Russell Coker <>
Subject: systemd_generator_t vs systemd_generator_type
Date: Sat, 11 Apr 2020 13:02:10 +1000
Message-ID: <1717302.MpC4nazLU5@liv> (raw)

This combination of names is confusing.  As a general rule I think we 
shouldn't have a type name be a substring of an attribute name.  Having an 
attribute name as a substring of a type name is less of an issue but still 
best avoided.


Above are the generators on my system that run as systemd_generator_t.  Would 
systemd_generator_generic_t/systemd_generator_generic_exec_t be an OK name?

My Main Blog
My Documents Blog

             reply index

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-11  3:02 Russell Coker [this message]
2020-04-14 15:06 ` Chris PeBenito

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1717302.MpC4nazLU5@liv \ \ \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

SELinux-Refpolicy Archive on

Archives are clonable:
	git clone --mirror selinux-refpolicy/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 selinux-refpolicy selinux-refpolicy/ \
	public-inbox-index selinux-refpolicy

Example config snippet for mirrors

Newsgroup available over NNTP:

AGPL code for this site: git clone