selinux-refpolicy.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Chris PeBenito <pebenito@ieee.org>
To: Dave Sugar <dsugar@tresys.com>, selinux-refpolicy@vger.kernel.org
Subject: Re: [PATCH 1/1] Add interface udev_domtrans_to
Date: Sat, 27 Oct 2018 15:13:22 -0400	[thread overview]
Message-ID: <a63fac38-8c33-13f3-e386-a15bb4bd57b4@ieee.org> (raw)
In-Reply-To: <20181017141949.17119-1-dsugar@tresys.com>

On 10/17/2018 10:19 AM, Dave Sugar wrote:
> This interface is useful when using the 'RUN' option in UDEV rules where udev will be executing a user function to perform some action.  This interface allows a domain transition to occur for the run action.
> 
> Signed-off-by: Dave Sugar <dsugar@tresys.com>
> ---
>   policy/modules/system/udev.if | 35 +++++++++++++++++++++++++++++++++++
>   1 file changed, 35 insertions(+)
> 
> diff --git a/policy/modules/system/udev.if b/policy/modules/system/udev.if
> index a2067895..45ab498c 100644
> --- a/policy/modules/system/udev.if
> +++ b/policy/modules/system/udev.if
> @@ -36,6 +36,41 @@ interface(`udev_domtrans',`
>   	domtrans_pattern($1, udev_exec_t, udev_t)
>   ')
>   
> +########################################
> +## <summary>
> +##	Allow udev to execute the specified program in
> +##	the specified domain.
> +## </summary>
> +## <desc>
> +##	<p>
> +##	Allow udev to execute the specified program in
> +##	the specified domain.
> +##	</p>
> +##	<p>
> +##	This is an interface to support the UDEV 'RUN'
> +##	command.  This will allow the command run by
> +##	udev to be run in a domain other than udev_t.
> +##	</p>
> +## </desc>
> +## <param name="domain">
> +##	<summary>
> +##	Domain to execute in.
> +##	</summary>
> +## </param>
> +## <param name="entry_file">
> +##	<summary>
> +##	Domain entry point file.
> +##	</summary>
> +## </param>
> +#
> +interface(`udev_domtrans_to',`

This should be called something like udev_run_command_domain or 
udev_run_domain.  If you have other suggestions, I could take that too, 
since this being for "run commands" doesn't make interface naming easy.



> +	gen_require(`
> +		type udev_t;
> +	')
> +
> +	domtrans_pattern(udev_t,$2,$1)
> +')
> +
>   ########################################
>   ## <summary>
>   ##	Execute udev in the caller domain.
> 


-- 
Chris PeBenito

      reply	other threads:[~2018-10-27 19:13 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-17 14:19 [PATCH 1/1] Add interface udev_domtrans_to Dave Sugar
2018-10-27 19:13 ` Chris PeBenito [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a63fac38-8c33-13f3-e386-a15bb4bd57b4@ieee.org \
    --to=pebenito@ieee.org \
    --cc=dsugar@tresys.com \
    --cc=selinux-refpolicy@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).