Linux maintainer tooling and workflows
 help / color / Atom feed
* [PATCH b4] Loosen compatible release identifiers for install_requires
@ 2021-02-26  4:25 Kyle Meyer
  2021-03-01 19:45 ` Konstantin Ryabitsev
  0 siblings, 1 reply; 2+ messages in thread
From: Kyle Meyer @ 2021-02-26  4:25 UTC (permalink / raw)
  To: tools

The install_requires entries use a compatible release operator.  As an
example, "requests~=2.24.0" maps to a requirement of ">= 2.24.0 and ==
2.24.*".  With the current version of requests (2.25.1), this leads to
a ContextualVersionConflict failure at runtime.

Allowing only Z to tick in version X.Y.Z seems unnecessarily strict
unless there are known problems with a particular release, and it
makes it more difficult for distributions to package b4.  Drop the
trailing digit from all of the version identifiers, allowing both Y
and Z to increase.

Signed-off-by: Kyle Meyer <kyle@kyleam.com>
---
 setup.py | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/setup.py b/setup.py
index 358e6a7..a21ec76 100644
--- a/setup.py
+++ b/setup.py
@@ -41,9 +41,9 @@ def find_version(source):
     data_files = [('share/man/man5', ['man/b4.5'])],
     keywords=['git', 'lore.kernel.org', 'patches'],
     install_requires=[
-        'requests~=2.24.0',
-        'dkimpy~=1.0.5',
-        'dnspython~=2.0.0',
+        'requests~=2.24',
+        'dkimpy~=1.0',
+        'dnspython~=2.0',
     ],
     python_requires='>=3.6',
     entry_points={

base-commit: f93bbd3e50b1fb4507aa537f4004da545af9d890
-- 
2.30.1


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH b4] Loosen compatible release identifiers for install_requires
  2021-02-26  4:25 [PATCH b4] Loosen compatible release identifiers for install_requires Kyle Meyer
@ 2021-03-01 19:45 ` Konstantin Ryabitsev
  0 siblings, 0 replies; 2+ messages in thread
From: Konstantin Ryabitsev @ 2021-03-01 19:45 UTC (permalink / raw)
  To: Kyle Meyer, tools

On Thu, 25 Feb 2021 23:25:57 -0500, Kyle Meyer wrote:
> The install_requires entries use a compatible release operator.  As an
> example, "requests~=2.24.0" maps to a requirement of ">= 2.24.0 and ==
> 2.24.*".  With the current version of requests (2.25.1), this leads to
> a ContextualVersionConflict failure at runtime.
> 
> Allowing only Z to tick in version X.Y.Z seems unnecessarily strict
> unless there are known problems with a particular release, and it
> makes it more difficult for distributions to package b4.  Drop the
> trailing digit from all of the version identifiers, allowing both Y
> and Z to increase.

Applied, thanks!

[1/1] Loosen compatible release identifiers for install_requires
      commit: 31348a14afdb1d39e7faf9576eaddea1ced76e19

Best regards,
-K

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-26  4:25 [PATCH b4] Loosen compatible release identifiers for install_requires Kyle Meyer
2021-03-01 19:45 ` Konstantin Ryabitsev

Linux maintainer tooling and workflows

Archives are clonable:
	git clone --mirror https://lore.kernel.org/tools/0 tools/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 tools tools/ https://lore.kernel.org/tools \
		tools@linux.kernel.org
	public-inbox-index tools

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.linux.tools


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git