u-boot.lists.denx.de archive mirror
 help / color / mirror / Atom feed
From: Michal Simek <michal.simek@amd.com>
To: Tom Rini <trini@konsulko.com>, <u-boot@lists.denx.de>
Subject: Re: [PATCH 10/19] fpga: Migrate CONFIG_MAX_FPGA_DEVICES to Kconfig
Date: Wed, 11 Jan 2023 09:17:25 +0100	[thread overview]
Message-ID: <09faffe9-3e1d-0831-4130-2f49ea8b4111@amd.com> (raw)
In-Reply-To: <20230110161946.3816866-10-trini@konsulko.com>



On 1/10/23 17:19, Tom Rini wrote:
> This is always defined to 5, so use that as the default.
> 
> Cc: Michal Simek <michal.simek@amd.com>
> Signed-off-by: Tom Rini <trini@konsulko.com>
> ---
>   drivers/fpga/Kconfig | 5 +++++
>   drivers/fpga/fpga.c  | 5 -----
>   include/fpga.h       | 4 ----
>   3 files changed, 5 insertions(+), 9 deletions(-)
> 
> diff --git a/drivers/fpga/Kconfig b/drivers/fpga/Kconfig
> index 11b742eeebfe..4113de230cd9 100644
> --- a/drivers/fpga/Kconfig
> +++ b/drivers/fpga/Kconfig
> @@ -153,4 +153,9 @@ config SANDBOX_FPGA
>   	  This is a driver model based FPGA driver for sandbox.
>   	  Currently it is a stub only, as there are no usable uclass methods yet.
>   
> +config MAX_FPGA_DEVICES
> +	int "Maximum number of FPGA devices"
> +	depends on FPGA
> +	default 5
> +
>   endmenu
> diff --git a/drivers/fpga/fpga.c b/drivers/fpga/fpga.c
> index 4db5c0a91e98..7f6b6bc73a1f 100644
> --- a/drivers/fpga/fpga.c
> +++ b/drivers/fpga/fpga.c
> @@ -13,11 +13,6 @@
>   #include <lattice.h>
>   #include <dm/device_compat.h>
>   
> -/* Local definitions */
> -#ifndef CONFIG_MAX_FPGA_DEVICES
> -#define CONFIG_MAX_FPGA_DEVICES		5
> -#endif
> -
>   /* Local static data */
>   static int next_desc = FPGA_INVALID_DEVICE;
>   static fpga_desc desc_table[CONFIG_MAX_FPGA_DEVICES];
> diff --git a/include/fpga.h b/include/fpga.h
> index a4e16401da72..ed688cc0fa3b 100644
> --- a/include/fpga.h
> +++ b/include/fpga.h
> @@ -9,10 +9,6 @@
>   #ifndef _FPGA_H_
>   #define _FPGA_H_
>   
> -#ifndef CONFIG_MAX_FPGA_DEVICES
> -#define CONFIG_MAX_FPGA_DEVICES		5
> -#endif
> -
>   /* fpga_xxxx function return value definitions */
>   #define FPGA_SUCCESS		0
>   #define FPGA_FAIL		1

Reviewed-by: Michal Simek <michal.simek@amd.com>

Thanks,
Michal

  reply	other threads:[~2023-01-11  8:17 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-01-10 16:19 [PATCH 01/19] global: Remove unused CONFIG defines Tom Rini
2023-01-10 16:19 ` [PATCH 02/19] arc: Migrate ARC_MMU_VER to Kconfig Tom Rini
2023-01-10 16:19 ` [PATCH 03/19] i2c: fsl_i2c: Rework usage of CONFIG_SYS_IMMR Tom Rini
2023-01-10 16:19 ` [PATCH 04/19] arm: Rework usage of CONFIG_ARMV[78]_SECURE_BASE in linker scripts Tom Rini
2023-01-10 16:19 ` [PATCH 05/19] dm: ns16550: Change how we get UART_REG to be defined Tom Rini
2023-01-11  0:15   ` Simon Glass
2023-01-17 22:10   ` [PATCHv2 05/19] dm: ns16550: Restore how we define UART_REG Tom Rini
2023-01-17 23:34     ` Andre Przywara
2023-01-18 14:15     ` Quentin Schulz
2023-01-10 16:19 ` [PATCH 06/19] arm: lib1funcs.S: Update compatibility with Linux comment slightly Tom Rini
2023-01-10 16:19 ` [PATCH 07/19] autoboot: Rework CONFIG_AUTOBOOT_STOP_STR_* usage Tom Rini
2023-01-10 16:19 ` [PATCH 08/19] spl: sata: Rework the loading case it not use IS_ENABLED(...) Tom Rini
2023-01-10 16:19 ` [PATCH 09/19] common/update: Finish Kconfig migration Tom Rini
2023-01-10 16:19 ` [PATCH 10/19] fpga: Migrate CONFIG_MAX_FPGA_DEVICES to Kconfig Tom Rini
2023-01-11  8:17   ` Michal Simek [this message]
2023-01-10 16:19 ` [PATCH 11/19] usb: musb: Rename CONFIG_USB_MUSB_TIMEOUT to MUSB_TIMEOUT Tom Rini
2023-01-10 17:20   ` Marek Vasut
2023-01-10 16:19 ` [PATCH 12/19] fsl-layerscape: Rework usage of CONFIG_CLUSTER_CLK_FREQ Tom Rini
2023-01-10 16:19 ` [PATCH 13/19] net: phy: mv88e61xx: Finish migration of MV88E61XX_FIXED_PORTS Tom Rini
2023-01-10 17:11   ` Ramon Fried
2023-01-10 16:19 ` [PATCH 14/19] nxp: Finish migration of SYS_FSL_IFC_BANK_COUNT to Kconfig Tom Rini
2023-01-10 16:19 ` [PATCH 15/19] nxp: Finish migration of SYS_FSL_SRDS_[12] " Tom Rini
2023-01-10 16:19 ` [PATCH 16/19] usbtty: Remove default CONFIG_USBD_* values Tom Rini
2023-01-10 16:19 ` [PATCH 17/19] watchdog: Clean up defaults for imx_watchdog / ulp_wdog Tom Rini
2023-01-10 16:54   ` Stefan Roese
2023-01-10 16:19 ` [PATCH 18/19] global: Finish CONFIG -> CFG migration Tom Rini
2023-01-11  0:15   ` Simon Glass
2023-01-10 16:19 ` [PATCH 19/19] CI: Make check for new defined CONFIG symbols even more robust Tom Rini
2023-01-11  0:15   ` Simon Glass
2023-01-20 23:21 ` [PATCH 01/19] global: Remove unused CONFIG defines Tom Rini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=09faffe9-3e1d-0831-4130-2f49ea8b4111@amd.com \
    --to=michal.simek@amd.com \
    --cc=trini@konsulko.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).