u-boot.lists.denx.de archive mirror
 help / color / mirror / Atom feed
From: Heiko Schocher <hs@denx.de>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH V4 0/4] Improve I2C for orion5x, kirkwood and ED Mini V2
Date: Mon, 30 Aug 2010 15:34:11 +0200	[thread overview]
Message-ID: <4C7BB353.6000307@denx.de> (raw)
In-Reply-To: <1282926366-1542-1-git-send-email-albert.aribaud@free.fr>

Hello Albert,

Albert Aribaud wrote:
> SUMMARY:
> 
> This patchset improves the driver for the Marvell TWSI interface found
> on orion5x and kirkwood SoCs and adds I2C support to the orion5x-based
> ED Mini V2 board. The mvtwsi driver is a complete rewrite, 50% shorter
> in source code lines, 25% smaller in object size, much simpler and way
> faster than the kirkwood_i2c driver it replaces.
> 
> PATCH SET:
> 
> Patch 1 removes dependencies on kirwkood_i2c from suen3, the only
> board that mentioned it. Patch 2 renames the driver from kirkwood_i2c
> to mvtwsi. Patch 3 replaces the old code with the new one. Patch 4
> adds support for I2C in orion5x-based ED Mini V2.
> 
> TESTS:
> 
> This driver has been tested on an ED Mini V2 with basic u-boot i2c
> commands, on an 5C372a RTC and an HT24LC08 1 KB eeprom (read+write).
> 
> HISTORY:
> 
> V1:	Initial submission as an addition rather than a replacement.
> 
> V2:	Fixed copyright line.
> 	Made mvtwsi a replacement for kirkwood_i2c.
> 	Made patches checkpatch-clean: 0 errors, 0 warnings.
> 	Various cosmetic changes.
> 	Removed useless i2c_end() function.
> 
> V3:	Reduced line lengths below 78 characters.
> 	Removed blank line after function description block comment.
> 
> V4:	Changed CONFIG_I2C_DRIVER_MVTWSI into CONFIG_I2C_MVTWSI.
> 	Really fixed copyright line.
> 	Added and documented kirkwood support.
> 	Shortened extended_slave_address into xtnd_slave_addr.
> 	Added explanation on default/init baudrate value.
> 	Moved I2C config settings under #ifdef CONFIG_CMD_I2C.
> 
> Albert Aribaud (4):
>   suen3: remove CONFIG_HARD_I2C and related defines
>   i2c: rename kirkwood_i2c to mvtwsi
>   i2c: rewrite mvtwsi, support orion5x and kirkwood
>   edminiv2: add I2C support using mvtwsi driver
> 
>  drivers/i2c/Makefile       |    2 +-
>  drivers/i2c/kirkwood_i2c.c |  496 --------------------------------------------
>  drivers/i2c/mvtwsi.c       |  428 ++++++++++++++++++++++++++++++++++++++
>  include/configs/edminiv2.h |   11 +
>  include/configs/km_arm.h   |    8 -
>  5 files changed, 440 insertions(+), 505 deletions(-)
>  delete mode 100644 drivers/i2c/kirkwood_i2c.c
>  create mode 100644 drivers/i2c/mvtwsi.c

applied to u-boot-i2c.git

Thanks!

bye,
Heiko
-- 
DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany

      parent reply	other threads:[~2010-08-30 13:34 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-08-27 16:26 [U-Boot] [PATCH V4 0/4] Improve I2C for orion5x, kirkwood and ED Mini V2 Albert Aribaud
2010-08-27 16:26 ` [U-Boot] [PATCH V4 1/4] suen3: remove CONFIG_HARD_I2C and related defines Albert Aribaud
2010-08-30  9:29   ` Prafulla Wadaskar
2010-08-30  9:38     ` Heiko Schocher
2010-08-30  9:44       ` Prafulla Wadaskar
2010-08-30 10:50         ` Albert ARIBAUD
2010-08-27 16:26 ` [U-Boot] [PATCH V4 2/4] i2c: rename kirkwood_i2c to mvtwsi Albert Aribaud
2010-08-30  9:45   ` Prafulla Wadaskar
2010-08-27 16:26 ` [U-Boot] [PATCH V4 3/4] i2c: rewrite mvtwsi, support orion5x and kirkwood Albert Aribaud
2010-08-30  9:45   ` Prafulla Wadaskar
2010-08-27 16:26 ` [U-Boot] [PATCH V4 4/4] edminiv2: add I2C support using mvtwsi driver Albert Aribaud
2010-08-30  9:46   ` Prafulla Wadaskar
2010-08-30 13:34 ` Heiko Schocher [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4C7BB353.6000307@denx.de \
    --to=hs@denx.de \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).