u-boot.lists.denx.de archive mirror
 help / color / mirror / Atom feed
* error -22 whilst initialising SD Card - New Raspberry Pi 4b 4GB (C0 stepping)
@ 2021-09-28 17:38 Craig Setera
  0 siblings, 0 replies; only message in thread
From: Craig Setera @ 2021-09-28 17:38 UTC (permalink / raw)
  To: u-boot


I wasn't quite sure where to report this, so I figured I would start 
with the mailing list.  If there is another place I should go, please 
feel free to redirect me.

I'm a user if IPFire which uses u-boot.  I recently bought a new 
Raspberry Pi 4b 4gb device, but it fails to boot with a loop that says:

|invalid bus width error -22 whilst initialising SD Card |I originally opened up a bug report with the IPFire team (https://bugzilla.ipfire.org/show_bug.cgi?id=12690), but it now appears that this is a|but somewhere in u-boot. I downloaded an Ubuntu 20.04 image that 
behaves the same way. As I stated in the IPFire issue, I'm seeing this 
behavior on a Raspberry Pi, but not on an older device. I ran a number 
of tests:|

To validate that this is an issue with newer hardware, I was able to take advantage of another Pi 4 that is probably a year or so old in my Retropie setup.  I used that Pi and a Samsung 32G EVO SD card.  I tried the following combinations, all with a monitor and keyboard attached (and SERIAL set to off in uEnv.txt):

* RaspiOS - "old" Pi 4 - Works
* RaspiOS - "new" Pi 4 - Works
* IPFire - "old" Pi 4 - Works
* IPFire - "new" Pi 4 - Boot loops

As discussed in the forum thread, this looks suspiciously like an issue with U-Boot on newer Pi 4 hardware as discussed here:

*https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=255080  <https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=255080>
*https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=255080#c47  <https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=255080#c47>



^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2021-09-28 17:43 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-28 17:38 error -22 whilst initialising SD Card - New Raspberry Pi 4b 4GB (C0 stepping) Craig Setera

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).