WireGuard Archive on lore.kernel.org
 help / color / Atom feed
* Windows client "Unable to create Wintun device"
       [not found] <2078146812.1909563.1573533502212.ref@mail.yahoo.com>
@ 2019-11-12  4:38 ` Richard Reiner
  0 siblings, 0 replies; only message in thread
From: Richard Reiner @ 2019-11-12  4:38 UTC (permalink / raw)
  To: wireguard

[-- Attachment #1.1: Type: text/plain, Size: 644 bytes --]

On one of my machines, the Wireguard Windows client 0.0.35 was previously working well, but as of today whenever attempting to activate any tunnel it generates errors with log messages like:
  2019-11-11 17:32:48.033: [TUN] [tun22] Unable to create Wintun device: Unable to create Wintun interface: GetStringValueWait(NetCfgInstanceId) failed: Timeout waiting for registry value
An uninstall - reboot - reinstall has not corrected this/

The affected machine has received some Windows 10 updates recently as well as a VMware Player update.But another machine with the same software installed works fine.
Any thoughts or suggestions?


[-- Attachment #1.2: Type: text/html, Size: 2864 bytes --]

<html><head></head><body><div class="ydp6836c165yahoo-style-wrap" style="font-family:Helvetica Neue, Helvetica, Arial, sans-serif;font-size:16px;"><div dir="ltr" data-setdir="false"><div><div class="ydpd9bbaf35adn ydpd9bbaf35ads" data-message-id="#msg-a:r-1579899094284406921" data-legacy-message-id="16e5dc0f2704ef04" style="border-left: none; padding: 0px; color: rgb(34, 34, 34); font-family: Roboto, RobotoDraft, Helvetica, Arial, sans-serif; font-size: medium;"><div class="ydpd9bbaf35gs" style="margin: 0px; padding: 0px 0px 20px; width: 1084.57px;"><div><div class="ydpd9bbaf35ii ydpd9bbaf35gt" style="direction: ltr; margin: 8px 0px 0px; padding: 0px; position: relative;"><div class="ydpd9bbaf35a3s ydpd9bbaf35aXjCH" style="font-stretch: normal; font-size: small; line-height: 1.5; font-family: Arial, Helvetica, sans-serif;"><div dir="ltr"><div>On one of my machines, the Wireguard Windows client 0.0.35 was previously&nbsp;working well, but as of today whenever attempting to activate any tunnel it generates errors with log messages like:</div><div dir="ltr"><br></div><div dir="ltr"><div>&nbsp; 2019-11-11 17:32:48.033: [TUN] [tun22] Unable to create Wintun device: Unable to create Wintun interface: GetStringValueWait(NetCfgInstanceId) failed: Timeout waiting for registry value</div><div><br style="color: rgb(0, 0, 0); font-family: Helvetica Neue, Helvetica, Arial, sans-serif; font-size: 16px;"></div><div></div><div>An uninstall - reboot - reinstall has not corrected this/<br></div><div><br></div><div>The affected machine has received some Windows 10 updates recently as well as a VMware Player update.</div><div>But another machine with the same software installed works fine.</div><div><br></div><div>Any thoughts&nbsp;or suggestions?</div><div class="ydpd9bbaf35yj6qo"></div><div class="ydpd9bbaf35adL"><br></div></div></div><div class="ydpd9bbaf35adL"></div></div></div><div class="ydpd9bbaf35hi" style="border-bottom-left-radius: 1px; border-bottom-right-radius: 1px; padding: 0px; width: auto; background: rgb(242, 242, 242); margin: 0px;"></div></div></div><div class="ydpd9bbaf35ajx" style="clear: both;"></div></div><div class="ydpd9bbaf35gA ydpd9bbaf35gt ydpd9bbaf35acV" style="padding: 0px; width: auto; border-bottom-left-radius: 0px; border-bottom-right-radius: 0px; border-top: none; margin: 0px; background-image: initial; background-position: initial; background-size: initial; background-repeat: initial; background-attachment: initial; background-origin: initial; background-clip: initial; color: rgb(34, 34, 34); font-family: Roboto, RobotoDraft, Helvetica, Arial, sans-serif;"><div class="ydpd9bbaf35gB ydpd9bbaf35xu" style="border-top: 0px; padding: 0px;"><div class="ydpd9bbaf35ip ydpd9bbaf35iq" style="clear: both; margin: 0px; padding: 16px 0px; border-top: none;"></div></div></div></div><br></div></div></body></html>

[-- Attachment #2: Type: text/plain, Size: 148 bytes --]

_______________________________________________
WireGuard mailing list
WireGuard@lists.zx2c4.com
https://lists.zx2c4.com/mailman/listinfo/wireguard

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <2078146812.1909563.1573533502212.ref@mail.yahoo.com>
2019-11-12  4:38 ` Windows client "Unable to create Wintun device" Richard Reiner

WireGuard Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/wireguard/0 wireguard/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 wireguard wireguard/ https://lore.kernel.org/wireguard \
		wireguard@lists.zx2c4.com
	public-inbox-index wireguard

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/com.zx2c4.lists.wireguard


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git