WireGuard Archive on lore.kernel.org
 help / color / Atom feed
* Connection loss on Apple devices when switching between Access points with same network name
@ 2019-10-15  7:04 Mario Melzer
  0 siblings, 0 replies; only message in thread
From: Mario Melzer @ 2019-10-15  7:04 UTC (permalink / raw)
  To: wireguard

[-- Attachment #1.1: Type: text/plain, Size: 1445 bytes --]

I still ran into trouble when switching between Access points with the same network name.

Occurs on macOS and iOS independent of the software Version (still on the latest releases 13.1.2 and 10.15 and the recently published updates for Wireguard 0.0.20191012-14 and 0.0.20191012 on Lentos 7 & 8)


When I connect to device 1 I have an internet connection, now if my device seamlessly connects to to device 2 (so meanwhile didn’t connect to mobile Network) I loose my internet connection and I get the following message in the logs:

Handshake did not complete after 5 seconds, retrying

Switching back to device 1 brings back the internet connection.

To get an internet connection on device 2 is only possible by disabling and reenabling the VPN connection, or being connected to mobile network between both connections.

It even occurs if all access points are the same hardware like in a mesh network of Speed Home WiFi from Deutsche Telekom.

 There already should have been a fix with https://git.zx2c4.com/wireguard-apple/commit/?id=996af4b97de85c17b7157dd5610830536c4e3e29 <https://git.zx2c4.com/wireguard-apple/commit/?id=996af4b97de85c17b7157dd5610830536c4e3e29>

But it didn’t solve my problem, and I didn’t hear back after this.

There is no difference in the logs to those I already send to team@wireguard.com <mailto:team@wireguard.com>

If there is anything specific I could provide, please let me know.

[-- Attachment #1.2: Type: text/html, Size: 2327 bytes --]

<html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">I still ran into trouble when switching between Access points with the same network name.<div class=""><br class=""></div><div class="">Occurs on macOS and iOS independent of the software Version (still on the latest releases 13.1.2 and 10.15 and the recently published updates for Wireguard 0.0.20191012-14 and 0.0.20191012 on Lentos 7 &amp; 8)<div class=""><br class=""></div><div class=""><br class=""></div><div class="">When I connect to device 1 I have an internet connection, now if my device seamlessly connects to to device 2 (so meanwhile didn’t connect to mobile Network) I loose my internet connection and I get the following message in the logs:</div><div class=""><br class=""></div><div class="">Handshake did not complete after 5 seconds, retrying</div><div class=""><br class=""></div><div class="">Switching back to device 1 brings back the internet connection.</div><div class=""><br class=""></div><div class="">To get an internet connection on device 2 is only possible by disabling and reenabling the VPN connection, or being connected to mobile network between both connections.</div><div class=""><br class=""></div><div class="">It even occurs if all access points are the same hardware like in a mesh network of&nbsp;<b class="">Speed Home WiFi from Deutsche Telekom.</b></div><div class=""><b class=""><br class=""></b></div><div class=""><b class="">&nbsp;There already should have been a fix with&nbsp;<a href="https://git.zx2c4.com/wireguard-apple/commit/?id=996af4b97de85c17b7157dd5610830536c4e3e29" class="">https://git.zx2c4.com/wireguard-apple/commit/?id=996af4b97de85c17b7157dd5610830536c4e3e29</a></b></div><div class=""><b class=""><br class=""></b></div><div class=""><b class="">But it&nbsp;didn’t solve my problem, and&nbsp;I&nbsp;didn’t hear back after this.</b></div><div class=""><b class=""><br class=""></b></div><div class=""><b class="">There is no difference in the logs to those&nbsp;I already send to <a href="mailto:team@wireguard.com" class="">team@wireguard.com</a></b></div><div class=""><b class=""><br class=""></b></div><div class=""><b class="">If there is anything specific&nbsp;I could provide, please let me know.</b></div></div></body></html>

[-- Attachment #2: Type: text/plain, Size: 148 bytes --]

_______________________________________________
WireGuard mailing list
WireGuard@lists.zx2c4.com
https://lists.zx2c4.com/mailman/listinfo/wireguard

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-10-15  7:04 Connection loss on Apple devices when switching between Access points with same network name Mario Melzer

WireGuard Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/wireguard/0 wireguard/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 wireguard wireguard/ https://lore.kernel.org/wireguard \
		wireguard@lists.zx2c4.com
	public-inbox-index wireguard

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/com.zx2c4.lists.wireguard


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git