wireguard.lists.zx2c4.com archive mirror
 help / color / mirror / Atom feed
* Cannot use localhost as endpoint for wireguard-windows
@ 2021-06-07 16:02 zhengmian hu
  0 siblings, 0 replies; only message in thread
From: zhengmian hu @ 2021-06-07 16:02 UTC (permalink / raw)
  To: wireguard

I might encounter the same problem as
https://lists.zx2c4.com/pipermail/wireguard/2020-August/005801.html
When endpoint is set as 127.0.0.1:51820, the log shows like follows:

[TUN] [xxx] peer(xxx) Received handshake response
[TUN] [xxx] peer(xxx) - Retrying handshake because we stopped hearing
back after 15 seconds.
[TUN] [xxx] peer(xxx) - Sending handshake initiation
[TUN] [xxx] peer(xxx) - Handshake did not complete after 5 seconds,
retrying (try 2)
[TUN] [xxx] peer(xxx) - Sending handshake initiation
[TUN] [xxx] peer(xxx) - Handshake did not complete after 5 seconds,
retrying (try 4)
...

In Wireshark, I can see that only the first handshake initiation
package is sent. There are no following packages even if the log shows
"Sending handshake initiation".

However, when I use another ip of the local computer for the endpoint,
e.g. 192.168.1.2, everything works fine.

Is it a known bug of wireguard-windows? Is there any existing formal
description on the scope of this bug? Is there any way to bypass this
problem?

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2021-06-08 10:59 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-07 16:02 Cannot use localhost as endpoint for wireguard-windows zhengmian hu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).