WireGuard Archive on lore.kernel.org
 help / color / Atom feed
* breakage in policy routing on 5.3 and 5.3.1
@ 2019-09-24  8:47 Jason A. Donenfeld
  2019-09-24 11:50 ` Michael Williams
  0 siblings, 1 reply; 2+ messages in thread
From: Jason A. Donenfeld @ 2019-09-24  8:47 UTC (permalink / raw)
  To: WireGuard mailing list

Hi folks,

FYI, upstream Linux broke aspects policy routing in 5.3. This isn't
specific to WireGuard, but rather the policy routing engine in
general, but users of the wg-quick(8) bash script for configuring
networks might run into this if they're routing a default route and
have IPv6, because the bash script makes use of policy routing.

I sent two patches upstream to fix bugs introduced with 5.3:
https://lore.kernel.org/netdev/20190923144612.29668-1-Jason@zx2c4.com/
https://lore.kernel.org/netdev/20190924073615.31704-1-Jason@zx2c4.com/

The latter one appears to mitigate the problem, as confirmed by Arch
Linux users: https://bugs.archlinux.org/task/63870

I'll update this thread when we know more from the netdev mailing list.

Thanks,
Jason
_______________________________________________
WireGuard mailing list
WireGuard@lists.zx2c4.com
https://lists.zx2c4.com/mailman/listinfo/wireguard

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: breakage in policy routing on 5.3 and 5.3.1
  2019-09-24  8:47 breakage in policy routing on 5.3 and 5.3.1 Jason A. Donenfeld
@ 2019-09-24 11:50 ` Michael Williams
  0 siblings, 0 replies; 2+ messages in thread
From: Michael Williams @ 2019-09-24 11:50 UTC (permalink / raw)
  To: Jason A. Donenfeld; +Cc: WireGuard mailing list

Thank you Jason! This makes more sense as the issue did not appear
until the system reboot which would be consistent with the kernel not
WireGuard upgrade. Much appreciate your response.

Sent from my iPhone

> On Sep 24, 2019, at 04:47, Jason A. Donenfeld <Jason@zx2c4.com> wrote:
>
> Hi folks,
>
> FYI, upstream Linux broke aspects policy routing in 5.3. This isn't
> specific to WireGuard, but rather the policy routing engine in
> general, but users of the wg-quick(8) bash script for configuring
> networks might run into this if they're routing a default route and
> have IPv6, because the bash script makes use of policy routing.
>
> I sent two patches upstream to fix bugs introduced with 5.3:
> https://lore.kernel.org/netdev/20190923144612.29668-1-Jason@zx2c4.com/
> https://lore.kernel.org/netdev/20190924073615.31704-1-Jason@zx2c4.com/
>
> The latter one appears to mitigate the problem, as confirmed by Arch
> Linux users: https://bugs.archlinux.org/task/63870
>
> I'll update this thread when we know more from the netdev mailing list.
>
> Thanks,
> Jason
> _______________________________________________
> WireGuard mailing list
> WireGuard@lists.zx2c4.com
> https://lists.zx2c4.com/mailman/listinfo/wireguard
_______________________________________________
WireGuard mailing list
WireGuard@lists.zx2c4.com
https://lists.zx2c4.com/mailman/listinfo/wireguard

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-09-24  8:47 breakage in policy routing on 5.3 and 5.3.1 Jason A. Donenfeld
2019-09-24 11:50 ` Michael Williams

WireGuard Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/wireguard/0 wireguard/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 wireguard wireguard/ https://lore.kernel.org/wireguard \
		wireguard@lists.zx2c4.com
	public-inbox-index wireguard

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/com.zx2c4.lists.wireguard


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git