WireGuard Archive on lore.kernel.org
 help / color / Atom feed
* Wireguard iOS: no route to host [Error]
@ 2019-10-26 17:59 Renym
  0 siblings, 0 replies; only message in thread
From: Renym @ 2019-10-26 17:59 UTC (permalink / raw)
  To: wireguard

[-- Attachment #1.1: Type: text/plain, Size: 1957 bytes --]

To WireGuard Developer,

    Hello, When I use WireGuard For iOS (https://apps.apple.com/us/app/wireguard/id1441195209) I found that it could not connect to the server side properly. When I checked the logs I found this error, which is consistent with the feedback in the following link:
https://www.reddit.com/r/WireGuard/comments/ax3h0c/failed_to_send_handshake_initiation_on_ios/

    When I further checked the problem, I found that there is no Wireless Setting option in the WireGuard settings page in the iOS settings. I understand that this setting will only appear in iOS devices with Cellular sold in China. Under normal circumstances, China region devices will pop up the user permission to use data when an app first runs (You can select: off / WLAN Only / WLAN & Cellular Data), but WireGuard does not pop up the alert when it first runs, so the Wireless setting option does not appear in the iOS settings, it results in It is WireGuard that can never use any network (WLAN and Cellular Data).

    Further inquiry and learning related materials, I learned that it is possible that WireGuard only uses the underlying socks to connect, there is no operation to actively connect to the network, causing iOS to not pop up an alert. This should be a system bug that has not been well resolved since iOS10. However, due to the experience of some developers, there is an easy way to solve this problem. When the app first runs or there is a related error, open a URL session to force internet access attempt, then the system will pop up the network permission, and all problems will be solved. Here is a code to solve the same problem for reference:
https://stackoverflow.com/a/43670783

    I hope the above information can help you solve this problem. I really like the design of WireGuard and iOS App, It is very convenient to use. I am looking forward to updating it to a version that can be used normally.

    Sincerely, I wish you all the best!

[-- Attachment #1.2: Type: text/html, Size: 2848 bytes --]

<div>To WireGuard Developer,<br></div><div><br></div><div>&nbsp; &nbsp; Hello, When I use WireGuard For iOS (<a href="https://apps.apple.com/us/app/wireguard/id1441195209">https://apps.apple.com/us/app/wireguard/id1441195209</a>) I found that it could not connect to the server side properly. When I checked the logs I found this error, which is consistent with the feedback in the following link:<br></div><div><a href="https://www.reddit.com/r/WireGuard/comments/ax3h0c/failed_to_send_handshake_initiation_on_ios/">https://www.reddit.com/r/WireGuard/comments/ax3h0c/failed_to_send_handshake_initiation_on_ios/</a><br></div><div><br></div><div>&nbsp; &nbsp; When I further checked the problem, I found that there is no Wireless Setting option in the WireGuard settings page in the iOS settings. I understand that this setting will only appear in iOS devices with&nbsp;Cellular sold in China. Under normal circumstances, China region devices will pop up the user permission to use data when an app first runs (You can select: off / WLAN Only / WLAN &amp; Cellular Data), but WireGuard does not pop up the <span style="background-color:rgb(255, 255, 255)"><span style="color:rgb(36, 39, 41)"><span style="font-family:Arial, &quot;Helvetica Neue&quot;, Helvetica, sans-serif"><span style="font-size:15px">alert</span></span></span></span> when it first runs, so the Wireless setting option <span style="background-color:rgb(255, 255, 255)"><span style="color:rgb(51, 51, 51)"><span style="font-family:arial"><span style="font-size:13px">does not</span></span></span></span>&nbsp;appear in the iOS settings, it results in It is WireGuard that can never use any network (WLAN and Cellular Data).<br></div><div><br></div><div>&nbsp; &nbsp; Further inquiry and learning related materials, I learned that it is possible that WireGuard only uses the underlying socks to connect, there is no operation to actively connect to the network, causing iOS to not pop up an alert. This should be a system bug that has not been well resolved since iOS10. However, due to the experience of some developers, there is an easy way to solve this problem. When the app first runs or there is a related error, open a URL session to force internet access attempt, then the system will pop up the network permission, and all problems will be solved.&nbsp;Here is a code to solve the same problem for reference:&nbsp;<br></div><div><a href="https://stackoverflow.com/a/43670783">https://stackoverflow.com/a/43670783</a><br></div><div><br></div><div>&nbsp; &nbsp;&nbsp;I hope the above information can help you solve this problem. I really like the design of WireGuard and iOS App, It is very convenient to use. I am looking forward to updating it to a version that can be used normally.<br></div><div><br></div><div>&nbsp; &nbsp; Sincerely, I wish you all the best!<br></div>

[-- Attachment #2: Type: text/plain, Size: 148 bytes --]

_______________________________________________
WireGuard mailing list
WireGuard@lists.zx2c4.com
https://lists.zx2c4.com/mailman/listinfo/wireguard

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-10-26 17:59 Wireguard iOS: no route to host [Error] Renym

WireGuard Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/wireguard/0 wireguard/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 wireguard wireguard/ https://lore.kernel.org/wireguard \
		wireguard@lists.zx2c4.com
	public-inbox-index wireguard

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/com.zx2c4.lists.wireguard


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git