xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 1/2] xsm: only define XSM_MAGIC in xsm.h
@ 2016-03-16 19:18 Doug Goldstein
  2016-03-16 19:18 ` [PATCH v2 2/2] xsm: move FLASK_AVC_STATS to Kconfig Doug Goldstein
                   ` (2 more replies)
  0 siblings, 3 replies; 5+ messages in thread
From: Doug Goldstein @ 2016-03-16 19:18 UTC (permalink / raw)
  To: xen-devel; +Cc: Daniel De Graaf, Doug Goldstein

Rather than have XSM_MAGIC set in the global xen/config.h and set in
xsm.h if it's unset, just set it once in xsm.h since its only used in
files that already include xsm.h

Signed-off-by: Doug Goldstein <cardoe@cardoe.com>
---
CC: Daniel De Graaf <dgdegra@tycho.nsa.gov>
---
 xen/include/xen/config.h | 1 -
 xen/include/xsm/xsm.h    | 7 +++++--
 2 files changed, 5 insertions(+), 3 deletions(-)

diff --git a/xen/include/xen/config.h b/xen/include/xen/config.h
index 96f5539..3f8c53d 100644
--- a/xen/include/xen/config.h
+++ b/xen/include/xen/config.h
@@ -79,7 +79,6 @@
 #define STR(...) __STR(__VA_ARGS__)
 
 #ifdef CONFIG_FLASK
-#define XSM_MAGIC 0xf97cff8c
 /* Maintain statistics on the access vector cache */
 #define FLASK_AVC_STATS 1
 #endif
diff --git a/xen/include/xsm/xsm.h b/xen/include/xsm/xsm.h
index 3afed70..37a102a 100644
--- a/xen/include/xsm/xsm.h
+++ b/xen/include/xsm/xsm.h
@@ -23,8 +23,11 @@ DEFINE_XEN_GUEST_HANDLE(xsm_op_t);
 
 /* policy magic number (defined by XSM_MAGIC) */
 typedef u32 xsm_magic_t;
-#ifndef XSM_MAGIC
-#define XSM_MAGIC 0x00000000
+
+#ifdef CONFIG_FLASK
+#define XSM_MAGIC 0xf97cff8c
+#else
+#define XSM_MAGIC 0x0
 #endif
 
 /* These annotations are used by callers and in dummy.h to document the
-- 
2.7.3


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

^ permalink raw reply related	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2016-03-25 15:30 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-03-16 19:18 [PATCH v2 1/2] xsm: only define XSM_MAGIC in xsm.h Doug Goldstein
2016-03-16 19:18 ` [PATCH v2 2/2] xsm: move FLASK_AVC_STATS to Kconfig Doug Goldstein
2016-03-22 18:31 ` [PATCH v2 1/2] xsm: only define XSM_MAGIC in xsm.h Doug Goldstein
2016-03-25 15:07 ` Daniel De Graaf
2016-03-25 15:30   ` Konrad Rzeszutek Wilk

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).