On Thu, 2016-03-31 at 23:59 -0500, Chong Li wrote: > Add libxl_vcpu_sched_params_get/set and sched_rtds_vcpu_get/set > functions to support per-VCPU settings. > > Signed-off-by: Chong Li > Signed-off-by: Meng Xu > Signed-off-by: Sisu Xi > > Acked-by: Wei Liu > Reviewed-by: Dario Faggioli > You added a new function, so you probably should have dropped the tags. Anyway, I'll re-issue mine: Reviewed-by: Dario Faggioli There are still things I'd like being done better. There's a certain amount of code duplication, and there still are two instances of this pattern (the 'else' is superfluous): > +    if (scinfo->num_vcpus > 0) { > +        rc = ERROR_INVAL; > +        goto out; > +    } else { > +        num_vcpus = info.max_vcpu_id + 1; > +        GCNEW_ARRAY(vcpus, num_vcpus); > +        for (i = 0; i < num_vcpus; i++) > +            vcpus[i].vcpuid = i; > +    } > + But Wei said (a few series versions ago) he is kinda fine with this, and I also don't think the series should be blocked because of it. We can improve and refactor things at a later point (adding this to my TODO list). Thanks and Regards, Dario -- <> (Raistlin Majere) ----------------------------------------------------------------- Dario Faggioli, Ph.D, http://about.me/dario.faggioli Senior Software Engineer, Citrix Systems R&D Ltd., Cambridge (UK)