xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-08-14 17:22:43 to 2020-08-18 07:29:01 UTC [more...]

[PATCH v1 0/6] tools/ocaml/xenstored: simplify code
 2020-08-18  7:28 UTC  (4+ messages)

[RFC PATCH] xen/gntdev.c: Convert get_user_pages*() to pin_user_pages*()
 2020-08-18  4:32 UTC 

[PATCH] xen/arm: Missing N1/A76/A75 FP registers in vCPU context switch
 2020-08-18  3:11 UTC 

[RFC PATCH V1 00/12] IOREQ feature (+ virtio-mmio) on Arm
 2020-08-17 22:56 UTC  (29+ messages)
` [RFC PATCH V1 01/12] hvm/ioreq: Make x86's IOREQ feature common
` [RFC PATCH V1 04/12] xen/arm: Introduce arch specific bits for IOREQ/DM features
` [RFC PATCH V1 05/12] hvm/dm: Introduce xendevicemodel_set_irq_level DM op
` [RFC PATCH V1 07/12] A collection of tweaks to be able to run emulator in driver domain

[PATCH 00/14] kernel-doc: public/arch-arm.h
 2020-08-17 22:56 UTC  (11+ messages)
` [PATCH 05/14] kernel-doc: public/features.h
` [PATCH 08/14] kernel-doc: public/memory.h

[PATCH] xen: Introduce cmpxchg64() and guest_cmpxchg64()
 2020-08-17 22:56 UTC  (10+ messages)

[PATCH v1 1/6] tools/ocaml/libs/xc: Fix ambiguous documentation comment
 2020-08-17 18:46 UTC  (10+ messages)
` [PATCH v1 2/6] tools/ocaml/xenstored: fix deprecation warning
` [PATCH v1 3/6] tools/ocaml/xenstored: replace hand rolled GC with weak GC references
` [PATCH v1 4/6] tools/ocaml/xenstored: drop select based
` [PATCH v1 5/6] tools/ocaml/xenstored: use more efficient node trees
` [PATCH v1 6/6] tools/ocaml/xenstored: use more efficient tries

[PATCH v3 0/6] tools/ocaml/xenstored: simplify code
 2020-08-17 18:45 UTC  (7+ messages)
` [PATCH v3 1/6] tools/ocaml/libs/xc: Fix ambiguous documentation comment
` [PATCH v3 2/6] tools/ocaml/xenstored: fix deprecation warning
` [PATCH v3 3/6] tools/ocaml/xenstored: replace hand rolled GC with weak GC references
` [PATCH v3 4/6] tools/ocaml/xenstored: drop select based socket watching
` [PATCH v3 5/6] tools/ocaml/xenstored: use more efficient node trees
` [PATCH v3 6/6] tools/ocaml/xenstored: use more efficient tries

[PATCH v2 0/6] tools/ocaml/xenstored: simplify code
 2020-08-17 18:39 UTC  (7+ messages)
` [PATCH v2 1/6] tools/ocaml/libs/xc: Fix ambiguous documentation comment
` [PATCH v2 2/6] tools/ocaml/xenstored: fix deprecation warning
` [PATCH v2 3/6] tools/ocaml/xenstored: replace hand rolled GC with weak GC references
` [PATCH v2 4/6] tools/ocaml/xenstored: drop select based socket watching
` [PATCH v2 5/6] tools/ocaml/xenstored: use more efficient node trees
` [PATCH v2 6/6] tools/ocaml/xenstored: use more efficient tries

[OSSTEST PATCH 1/2] Tcl: Use tclsh8.6
 2020-08-17 18:23 UTC  (2+ messages)
` [OSSTEST PATCH 2/2] tcl: JobDB: Do not require particular Pgtcl version

[PATCH] xen/x86: irq: Avoid a TOCTOU race in pirq_spin_lock_irq_desc()
 2020-08-17 17:56 UTC  (13+ messages)

Planned osstest outage, around 17th August
 2020-08-17 17:16 UTC  (3+ messages)

[RFC] efi/boot: Unified Xen executable for UEFI Secure Boot support
 2020-08-17 16:15 UTC  (8+ messages)

[PATCH 0/3] x86: M2P maintenance adjustments (step 1)
 2020-08-17 16:11 UTC  (4+ messages)
` [PATCH 3/3] x86: don't override INVALID_M2P_ENTRY with SHARED_M2P_ENTRY

[PATCH 0/4] build: corrections to .init.o generation logic
 2020-08-17 16:04 UTC  (12+ messages)
` [PATCH 3/4] build: also check for empty .bss.* in .o -> .init.o conversion
` [PATCH 4/4] EFI: free unused boot mem in at least some cases

[PATCH 0/8] x86: switch default MSR behavior
 2020-08-17 15:57 UTC  (9+ messages)
` [PATCH 1/8] x86/vmx: handle writes to MISC_ENABLE MSR
` [PATCH 2/8] x86/svm: silently drop writes to SYSCFG and related MSRs
` [PATCH 3/8] x86/pv: handle writes to the EFER MSR
` [PATCH 4/8] x86/pv: handle reads to the PAT MSR
` [PATCH 5/8] x86/pv: allow reading APIC_BASE MSR
` [PATCH 6/8] x86/pv: allow reading FEATURE_CONTROL MSR
` [PATCH 7/8] x86/pv: disallow access to unknown MSRs
` [PATCH 8/8] x86/hvm: Disallow "

[RFC PATCH 0/2] add function support to IDL
 2020-08-17 15:44 UTC  (7+ messages)
` [RFC PATCH 1/2] libxl: add Function class "
` [RFC PATCH 2/2] libxl: prototype libxl_device_nic_add/remove with IDL

[PATCH v2 0/7] x86: build adjustments
 2020-08-17 15:20 UTC  (5+ messages)
` [PATCH v2 1/7] x86/EFI: sanitize build logic

CI loop working group
 2020-08-17 13:46 UTC 

[PATCH I v2.1 6/6] tools: generate most contents of library make variables
 2020-08-17 12:51 UTC  (2+ messages)

[PATCH II v2 00/17] move libxenctrl to tools/libs directory
 2020-08-17 11:07 UTC  (21+ messages)
` [PATCH II v2 01/17] stubdom: add correct dependencies for Xen libraries
` [PATCH II v2 02/17] tools: drop explicit path specifications for qemu build
` [PATCH II v2 03/17] tools: tweak tools/libs/libs.mk for being able to support libxenctrl
` [PATCH II v2 04/17] tools/python: drop libxenguest from setup.py
` [PATCH II v2 05/17] tools: fix pkg-config file for libxenguest
` [PATCH II v2 06/17] tools: don't assume libxenguest and libxenctrl to be in same directory
` [PATCH II v2 07/17] tools/misc: don't use libxenctrl internals from xen-hptool
` [PATCH II v2 08/17] tools/misc: don't include xg_save_restore.h from xen-mfndump.c
` [PATCH II v2 09/17] tools/misc: replace PAGE_SIZE with XC_PAGE_SIZE in xen-mfndump.c
` [PATCH II v2 10/17] tools/misc: drop all libxc internals from xen-mfndump.c
` [PATCH II v2 11/17] tools/libxc: remove unused headers xc_efi.h and xc_elf.h
` [PATCH II v2 12/17] tools/libxc: move xc_[un]map_domain_meminfo() into new source xg_domain.c
` [PATCH II v2 13/17] tools/libxc: rename all libxenguest sources to xg_*
` [PATCH II v2 14/17] tools/libxc: rename libxenguest internal headers
` [PATCH II v2 15/17] tools/misc: rename xc_dom.h do xenctrl_dom.h
` [PATCH II v2 16/17] tools/libxc: untangle libxenctrl from libxenguest
` [PATCH II v2 17/17] tools: move libxenctrl below tools/libs

[PATCH] mini-os: correct memory access rights for pvh mode
 2020-08-17  9:56 UTC  (3+ messages)

[PATCH] mini-os: fix do_map_frames() for pvh
 2020-08-17  9:55 UTC  (3+ messages)

[PATCH] efi: discover ESRT table on Xen PV too
 2020-08-17  9:00 UTC  (3+ messages)

u-boot vs. uefi as boot loaders on ARM
 2020-08-16 20:45 UTC  (3+ messages)

[PATCH v4 0/6] x86/paravirt: cleanup after 32-bit PV removal
 2020-08-16 18:44 UTC  (9+ messages)
` [PATCH v4 1/6] x86/paravirt: remove 32-bit support from PARAVIRT_XXL
` [PATCH v4 2/6] x86/paravirt: cleanup paravirt macros
` [PATCH v4 3/6] x86/paravirt: use CONFIG_PARAVIRT_XXL instead of CONFIG_PARAVIRT
` [PATCH v4 4/6] x86/entry/32: revert "Fix XEN_PV build dependency"
` [PATCH v4 5/6] x86/paravirt: remove set_pte_at pv-op
` [PATCH v4 6/6] x86/paravirt: avoid needless paravirt step clearing page table entries

[PATCH I v2 0/6] tools: streamline tools/libs/ building
 2020-08-16 11:47 UTC  (8+ messages)
` [PATCH I v2 1/6] stubdom: add stubdom/mini-os.mk for Xen paths used by Mini-OS
` [PATCH I v2 2/6] tools: switch XEN_LIBXEN* make variables to lower case (XEN_libxen*)
` [PATCH I v2 3/6] tools: add a copy of library headers in tools/include
` [PATCH I v2 4/6] tools: don't call make recursively from libs.mk
` [PATCH I v2 5/6] tools: define ROUNDUP() in tools/include/xen-tools/libs.h
` [PATCH I v2 6/6] tools: generate most contents of library make variables

[PATCH] qemu-trad: remove Xen path dependencies
 2020-08-15 11:18 UTC  (2+ messages)

[linux-linus test] 152599: regressions - FAIL
 2020-08-15  0:58 UTC 

[GIT PULL] xen: branch for v5.9-rc1b
 2020-08-14 20:42 UTC  (2+ messages)

[RESEND][PATCH v2 0/7] xen: Consolidate asm-*/guest_access.h in xen/guest_access.h
 2020-08-14 19:18 UTC  (21+ messages)
` [RESEND][PATCH v2 1/7] xen/guest_access: Add emacs magics
` [RESEND][PATCH v2 3/7] xen/arm: decode: Re-order the includes
` [RESEND][PATCH v2 4/7] xen/arm: guestcopy: "
` [RESEND][PATCH v2 5/7] xen: include xen/guest_access.h rather than asm/guest_access.h
` [RESEND][PATCH v2 6/7] xen/guest_access: Consolidate guest access helpers in xen/guest_access.h
` [RESEND][PATCH v2 7/7] xen/guest_access: Fix coding style "

[OSSTEST PATCH 00/60] Speed up sg-report-job-history
 2020-08-14 17:22 UTC  (55+ messages)
` [OSSTEST PATCH 03/60] history reporting: Delete two debug prints
` [OSSTEST PATCH 06/60] history reporting (nfc): Rename jobquery to cacheable_query
` [OSSTEST PATCH 07/60] history reporting (nfc): Break out cache_row_lookup_prep
` [OSSTEST PATCH 08/60] history reporting (nfc): Rename "existing" to "previous"
` [OSSTEST PATCH 10/60] history reporting (nfc): Bind by name in cacheable_query
` [OSSTEST PATCH 12/60] history reporting (nfc): Record query-specific stats
` [OSSTEST PATCH 13/60] history reporting (nfc): Move cacheable_* further up the file
` [OSSTEST PATCH 14/60] history reporting (nfc): Use cacheable_fn for power methods
` [OSSTEST PATCH 15/60] history reporting (nfc): Introduce cache_set_key_cols
` [OSSTEST PATCH 16/60] history reporting (nfc): Record more row-specific stats
` [OSSTEST PATCH 17/60] history reporting: Cache stats reporting: Centralise and rework
` [OSSTEST PATCH 18/60] history reporting (nfc): Remove now-obsolete stats variables
` [OSSTEST PATCH 19/60] history reporting (nfc): Introduce empty HistoryReport module
` [OSSTEST PATCH 20/60] history reporting (nfc): Move cache code into "
` [OSSTEST PATCH 21/60] history reporting (nfc): Rename some module variables, remove "cache"
` [OSSTEST PATCH 22/60] history reporting: Skip undefined keys
` [OSSTEST PATCH 23/60] history reporting (nfc): Documentation for the new module
` [OSSTEST PATCH 24/60] history reporting: Cache data limit now in History module
` [OSSTEST PATCH 25/60] history reporting: Print debug for cache misses
` [OSSTEST PATCH 26/60] history reporting: Improve an error message slightly
` [OSSTEST PATCH 27/60] sg-report-host-history: Write cache entry for unfinished jobs
` [OSSTEST PATCH 28/60] parallel by fork: Break out into HistoryReport
` [OSSTEST PATCH 29/60] parallel by fork: Disconnect $dbh_tests as well as undefing it
` [OSSTEST PATCH 30/60] parallel by fork: Fix a variable name to $task
` [OSSTEST PATCH 31/60] sg-report-job-history: Prep for fork: Move $buildsq query
` [OSSTEST PATCH 32/60] sg-report-job-history: Prep for fork: Move $revisionsq query
` [OSSTEST PATCH 33/60] sg-report-job-history: Use fork-based parallelism
` [OSSTEST PATCH 34/60] sg-report-job-history: Use one child per report
` [OSSTEST PATCH 35/60] sg-report-job-history (nfc): Have main program decide HTML filename
` [OSSTEST PATCH 36/60] sg-report-job-history: Always write HTML output
` [OSSTEST PATCH 37/60] sg-report-job-history (nfc): Remove needless conditional
` [OSSTEST PATCH 38/60] history reporting (nfc): Add another test rune to the notes
` [OSSTEST PATCH 39/60] history reporting (nfc): Make cacheable_fn work without cache
` [OSSTEST PATCH 40/60] sg-report-job-history: Refactor "ALL" handling
` [OSSTEST PATCH 41/60] sg-report-job-history (nfc): Make $ri->{Hosts} a hash
` [OSSTEST PATCH 42/60] sg-report-job-history (nfc): Add new hostvarcols calculation
` [OSSTEST PATCH 43/60] sg-report-job-history (nfc): Query hosts runvars in one go
` [OSSTEST PATCH 44/60] sg-report-job-history (nfc): Drop $hostsq query
` [OSSTEST PATCH 45/60] history reporting (nfc): Provide cache_set_task_print
` [OSSTEST PATCH 46/60] sg-report-job-history: Introduce use of cache, for hosts query
` [OSSTEST PATCH 47/60] history reporting (nfc): Break out url_quote
` [OSSTEST PATCH 48/60] history reporting (nfc): Break out url_unquote
` [OSSTEST PATCH 49/60] history reporting (nfc): Break out $url_ok_chars
` [OSSTEST PATCH 50/60] history reporting (nfc): url-quoting: quote = too
` [OSSTEST PATCH 51/60] history reporting (nfc): Quote keys too
` [OSSTEST PATCH 52/60] sg-report-job-history: Cache the per-flight revisions
` [OSSTEST PATCH 53/60] sg-report-job-history (nfc): Refactor osstestrevs code
` [OSSTEST PATCH 54/60] sg-report-job-history: Cache osstestrevs
` [OSSTEST PATCH 55/60] history reporting: Break out minflight_by_time
` [OSSTEST PATCH 56/60] sg-report-job-history (nfc): Abolish $fromstuff
` [OSSTEST PATCH 57/60] sg-report-job-history: Cache report_run_getinfo
` [OSSTEST PATCH 58/60] sg-report-host-history: "
` [OSSTEST PATCH 59/60] sg-report-job-history: Provide --time-limit
` [OSSTEST PATCH 60/60] sg-report-job-history: Increase default limit


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).