xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-11-23 21:39:11 to 2020-11-24 22:24:47 UTC [more...]

[PATCH 000/141] Fix fall-through warnings for Clang
 2020-11-24 22:24 UTC  (28+ messages)
` [PATCH 058/141] xen-blkfront: "
                  ` [Intel-wired-lan] [PATCH 000/141] "

merge struct block_device and struct hd_struct v2
 2020-11-24 21:20 UTC  (70+ messages)
` [PATCH 01/45] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats
` [PATCH 02/45] filemap: consistently use ->f_mapping over ->i_mapping
` [PATCH 03/45] fs: remove get_super_thawed and get_super_exclusive_thawed
` [PATCH 04/45] fs: simplify freeze_bdev/thaw_bdev
` [PATCH 05/45] mtip32xx: remove the call to fsync_bdev on removal
` [PATCH 06/45] zram: remove the claim mechanism
` [PATCH 07/45] zram: do not call set_blocksize
` [PATCH 08/45] loop: "
` [PATCH 09/45] dm: simplify flush_bio initialization in __send_empty_flush
` [PATCH 10/45] dm: remove the block_device reference in struct mapped_device
` [PATCH 11/45] block: remove a duplicate __disk_get_part prototype
` [PATCH 12/45] block: remove a superflous check in blkpg_do_ioctl
` [PATCH 13/45] block: add a bdev_kobj helper
` [PATCH 14/45] block: use disk_part_iter_exit in disk_part_iter_next
` [PATCH 15/45] block: use put_device in put_disk
` [PATCH 16/45] block: change the hash used for looking up block devices
` [PATCH 17/45] init: refactor name_to_dev_t
` [PATCH 18/45] init: refactor devt_from_partuuid
` [PATCH 19/45] init: cleanup match_dev_by_uuid and match_dev_by_label
` [PATCH 20/45] block: refactor __blkdev_put
` [PATCH 21/45] block: refactor blkdev_get
` [PATCH 22/45] block: opencode devcgroup_inode_permission
` [PATCH 23/45] block: remove i_bdev
` [PATCH 24/45] blk-cgroup: stop abusing get_gendisk
` [PATCH 25/45] block: reference struct block_device from struct hd_struct
` [PATCH 26/45] block: remove ->bd_contains
` [PATCH 27/45] block: simplify the block device claiming interface
` [PATCH 28/45] block: simplify part_to_disk
` [PATCH 29/45] block: initialize struct block_device in bdev_alloc
` [PATCH 30/45] block: remove the nr_sects field in struct hd_struct
` [PATCH 31/45] block: move disk stat accounting to struct block_device
` [PATCH 32/45] block: move the start_sect field "
` [PATCH 33/45] block: move the partition_meta_info "
` [PATCH 34/45] block: move holder_dir "
` [PATCH 35/45] block: move make_it_fail "
` [PATCH 36/45] block: move the policy field "
` [PATCH 37/45] block: allocate struct hd_struct as part of struct bdev_inode
` [PATCH 38/45] block: switch partition lookup to use struct block_device
` [PATCH 39/45] block: remove the partno field from struct hd_struct
` [PATCH 40/45] block: pass a block_device to blk_alloc_devt
` [PATCH 41/45] block: pass a block_device to invalidate_partition
` [PATCH 42/45] block: switch disk_part_iter_* to use a struct block_device
` [PATCH 43/45] f2fs: remove a few bd_part checks
` [PATCH 44/45] block: merge struct block_device and struct hd_struct
` [PATCH 45/45] block: stop using bdget_disk for partition 0

[PATCH v3 00/13] viridian: add support for ExProcessorMasks
 2020-11-24 19:07 UTC  (14+ messages)
` [PATCH v3 01/13] viridian: don't blindly write to 32-bit registers is 'mode' is invalid
` [PATCH v3 02/13] viridian: move flush hypercall implementation into separate function
` [PATCH v3 03/13] viridian: move IPI "
` [PATCH v3 04/13] viridian: introduce a per-cpu hypercall_vpmask and accessor functions
` [PATCH v3 05/13] viridian: use hypercall_vpmask in hvcall_ipi()
` [PATCH v3 06/13] viridian: use softirq batching "
` [PATCH v3 07/13] xen/include: import sizeof_field() macro from Linux stddef.h
` [PATCH v3 08/13] viridian: add ExProcessorMasks variants of the flush hypercalls
` [PATCH v3 09/13] viridian: add ExProcessorMasks variant of the IPI hypercall
` [PATCH v3 10/13] viridian: log initial invocation of each type of hypercall
` [PATCH v3 11/13] viridian: add a new '_HVMPV_ex_processor_masks' bit into HVM_PARAM_VIRIDIAN
` [PATCH v3 12/13] xl / libxl: add 'ex_processor_mask' into 'libxl_viridian_enlightenment'
` [PATCH v3 13/13] x86: replace open-coded occurrences of sizeof_field()

[linux-linus test] 156981: regressions - FAIL
 2020-11-24 19:26 UTC 

[PATCH v4 0/3] evtchn: Introduce a per-guest knob to control FIFO ABI
 2020-11-24 19:17 UTC  (4+ messages)
` [PATCH v4 1/3] domctl: introduce a new domain create flag, XEN_DOMCTL_CDF_disable_fifo,
` [PATCH v4 2/3] libxl: add a 'disable_fifo_evtchn' flag to libxl_domain_build_info
` [PATCH v4 3/3] xl: add 'disable_evtchn_fifo' boolean option into xl.cfg(5)

[PATCH v2 00/12] viridian: add support for ExProcessorMasks
 2020-11-24 18:40 UTC  (6+ messages)
` [PATCH v2 08/12] viridian: add ExProcessorMasks variants of the flush hypercalls
` [PATCH v2 09/12] viridian: add ExProcessorMasks variant of the IPI hypercall

[PATCH RFC 0/6] xen/arm: mm: Add limited support for superpages
 2020-11-24 18:13 UTC  (14+ messages)
` [PATCH RFC 1/6] xen/arm: mm: Remove special case for CPU0 in dump_hyp_walk()
` [PATCH RFC 2/6] xen/arm: mm: Remove ; at the end of mm_printk()
` [PATCH RFC 3/6] xen/arm: setup: Call unregister_init_virtual_region() after the last init function
` [PATCH RFC 4/6] xen/arm: mm: Allow other mapping size in xen_pt_update_entry()

[PATCH] xen/arm: Add workaround for Cortex-A55 erratum #1530923
 2020-11-24 17:44 UTC  (3+ messages)

[qemu-mainline test] 156978: regressions - FAIL
 2020-11-24 17:41 UTC 

[PATCH] evtchn: double per-channel locking can't hit identical channels
 2020-11-24 17:03 UTC 

merge struct block_device and struct hd_struct
 2020-11-24 16:59 UTC  (5+ messages)
` [PATCH 01/20] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats
` [PATCH 11/20] block: reference struct block_device from struct hd_struct

[PATCH v2 0/8] xen: beginnings of moving library-like code into an archive
 2020-11-24 16:57 UTC  (11+ messages)
` [PATCH v2 4/8] lib: move parse_size_and_unit()
` [PATCH v2 7/8] lib: move bsearch code

[xen-unstable-smoke test] 156991: tolerable all pass - PUSHED
 2020-11-24 16:44 UTC 

[PATCH v7 0/3] xen/events: further locking adjustments
 2020-11-24 16:32 UTC  (11+ messages)
` [PATCH v7 1/3] xen/events: access last_priority and last_vcpu_id together
` [PATCH v7 2/3] xen/events: modify struct evtchn layout
` [PATCH v7 3/3] xen/events: rework fifo queue locking

NetBSD dom0 PVH: hardware interrupts stalls
 2020-11-24 16:09 UTC  (27+ messages)

[xen-unstable-smoke test] 156982: tolerable all pass - PUSHED
 2020-11-24 13:50 UTC 

Xen Security Advisory 355 v2 - stack corruption from XSA-346 change
 2020-11-24 12:44 UTC 

[PATCH v2] xen: add support for automatic debug key actions in case of crash
 2020-11-24 12:23 UTC  (3+ messages)

Xen Security Advisory 355 v2 - stack corruption from XSA-346 change
 2020-11-24 12:03 UTC 

[xen-unstable test] 156975: tolerable FAIL
 2020-11-24 11:47 UTC 

[PATCH 0/4] x86: ACPI and DMI table mapping fixes
 2020-11-24 11:04 UTC  (7+ messages)
` [PATCH 2/4] x86/ACPI: fix S3 wakeup vector mapping

[PATCH v3 0/3] xen/arm: Make PCI passthrough code non-x86 specific
 2020-11-24 10:49 UTC  (18+ messages)
` [PATCH v3 1/3] xen/ns16550: Make ns16550 driver usable on ARM with HAS_PCI enabled

[libvirt test] 156977: regressions - FAIL
 2020-11-24 10:46 UTC 

[PATCH v2 0/3] ns16550: #ifdef-ary
 2020-11-24  9:52 UTC  (10+ messages)
` [PATCH v2 1/3] ns16550: move PCI arrays next to the function using them
` [PATCH v2 2/3] ns16550: "com<N>=" command line options are x86-specific
` [PATCH v2 3/3] ns16550: drop stray "#ifdef CONFIG_HAS_PCI"

[PATCH v4 00/23] xl / libxl: named PCI pass-through devices
 2020-11-24  8:01 UTC  (24+ messages)
` [PATCH v4 01/23] xl / libxl: s/pcidev/pci and remove DEFINE_DEVICE_TYPE_STRUCT_X
` [PATCH v4 02/23] libxl: make libxl__device_list() work correctly for LIBXL__DEVICE_KIND_PCI
` [PATCH v4 03/23] libxl: Make sure devices added by pci-attach are reflected in the config
` [PATCH v4 04/23] libxl: add/recover 'rdm_policy' to/from PCI backend in xenstore
` [PATCH v4 05/23] libxl: s/detatched/detached in libxl_pci.c
` [PATCH v4 06/23] libxl: remove extraneous arguments to do_pci_remove() "
` [PATCH v4 07/23] libxl: stop using aodev->device_config in libxl__device_pci_add()
` [PATCH v4 08/23] libxl: generalise 'driver_path' xenstore access functions in libxl_pci.c
` [PATCH v4 09/23] libxl: remove unnecessary check from libxl__device_pci_add()
` [PATCH v4 10/23] libxl: remove get_all_assigned_devices() from libxl_pci.c
` [PATCH v4 11/23] libxl: make sure callers of libxl_device_pci_list() free the list after use
` [PATCH v4 12/23] libxl: add libxl_device_pci_assignable_list_free()
` [PATCH v4 13/23] libxl: use COMPARE_PCI() macro is_pci_in_array()
` [PATCH v4 14/23] docs/man: extract documentation of PCI_SPEC_STRING from the xl.cfg manpage
` [PATCH v4 15/23] docs/man: improve documentation of PCI_SPEC_STRING
` [PATCH v4 16/23] docs/man: fix xl(1) documentation for 'pci' operations
` [PATCH v4 17/23] libxl: introduce 'libxl_pci_bdf' in the idl
` [PATCH v4 18/23] libxlu: introduce xlu_pci_parse_spec_string()
` [PATCH v4 19/23] libxl: modify libxl_device_pci_assignable_add/remove/list/list_free()
` [PATCH v4 20/23] docs/man: modify xl(1) in preparation for naming of assignable devices
` [PATCH v4 21/23] xl / libxl: support "
` [PATCH v4 22/23] docs/man: modify xl-pci-configuration(5) to add 'name' field to PCI_SPEC_STRING
` [PATCH v4 23/23] xl / libxl: support 'xl pci-attach/detach' by name

[PATCH v3 00/23] xl / libxl: named PCI pass-through devices
 2020-11-24  7:45 UTC  (3+ messages)

[linux-linus test] 156972: regressions - FAIL
 2020-11-24  7:19 UTC 

zstd compressed kernels
 2020-11-23 23:01 UTC  (3+ messages)

[qemu-mainline test] 156970: regressions - FAIL
 2020-11-24  4:51 UTC 

[PATCH v2] xen: EXPERT clean-up and introduce UNSUPPORTED
 2020-11-23 22:41 UTC  (7+ messages)

AW: AW: AW: AW: Xen data from meta-virtualization layer
 2020-11-23 22:31 UTC  (6+ messages)
                    ` AW: "
                      `  "
                          ` AW: "

[linux-linus test] 156964: regressions - FAIL
 2020-11-23 21:38 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).