From: Stefano Stabellini <sstabellini@kernel.org>
To: Julien Grall <julien@xen.org>
Cc: Stefano Stabellini <sstabellini@kernel.org>,
xen-devel@lists.xenproject.org, Wei.Chen@arm.com,
Henry.Wang@arm.com, Penny.Zheng@arm.com,
Bertrand.Marquis@arm.com, Julien Grall <jgrall@amazon.com>,
Volodymyr Babchuk <Volodymyr_Babchuk@epam.com>
Subject: Re: [PATCH RFCv2 02/15] xen/arm: lpae: Use the generic helpers to defined the Xen PT helpers
Date: Wed, 12 May 2021 14:30:14 -0700 (PDT) [thread overview]
Message-ID: <alpine.DEB.2.21.2105121425500.5018@sstabellini-ThinkPad-T480s> (raw)
In-Reply-To: <94e364a7-de40-93ab-6cde-a2f493540439@xen.org>
On Wed, 12 May 2021, Julien Grall wrote:
> Hi Stefano,
>
> On 11/05/2021 23:26, Stefano Stabellini wrote:
> > On Sun, 25 Apr 2021, Julien Grall wrote:
> > > From: Julien Grall <jgrall@amazon.com>
> > >
> > > Currently, Xen PT helpers are only working with 4KB page granularity
> > > and open-code the generic helpers. To allow more flexibility, we can
> > > re-use the generic helpers and pass Xen's page granularity
> > > (PAGE_SHIFT).
> > >
> > > As Xen PT helpers are used in both C and assembly, we need to move
> > > the generic helpers definition outside of the !__ASSEMBLY__ section.
> > >
> > > Note the aliases for each level are still kept for the time being so we
> > > can avoid a massive patch to change all the callers.
> > >
> > > Signed-off-by: Julien Grall <jgrall@amazon.com>
> >
> > The patch is OK as is. I have a couple of suggestions for improvement
> > below. If you feel like making them, good, otherwise I am also OK if you
> > don't want to change anything.
> >
> >
> > > ---
> > > Changes in v2:
> > > - New patch
> > > ---
> > > xen/include/asm-arm/lpae.h | 71 +++++++++++++++++++++-----------------
> > > 1 file changed, 40 insertions(+), 31 deletions(-)
> > >
> > > diff --git a/xen/include/asm-arm/lpae.h b/xen/include/asm-arm/lpae.h
> > > index 4fb9a40a4ca9..310f5225e056 100644
> > > --- a/xen/include/asm-arm/lpae.h
> > > +++ b/xen/include/asm-arm/lpae.h
> > > @@ -159,6 +159,17 @@ static inline bool lpae_is_superpage(lpae_t pte,
> > > unsigned int level)
> > > #define lpae_get_mfn(pte) (_mfn((pte).walk.base))
> > > #define lpae_set_mfn(pte, mfn) ((pte).walk.base = mfn_x(mfn))
> > > +/* Generate an array @var containing the offset for each level from
> > > @addr */
> > > +#define DECLARE_OFFSETS(var, addr) \
> > > + const unsigned int var[4] = { \
> > > + zeroeth_table_offset(addr), \
> > > + first_table_offset(addr), \
> > > + second_table_offset(addr), \
> > > + third_table_offset(addr) \
> > > + }
> > > +
> > > +#endif /* __ASSEMBLY__ */
> > > +
> > > /*
> > > * AArch64 supports pages with different sizes (4K, 16K, and 64K).
> > > * Provide a set of generic helpers that will compute various
> > > @@ -190,17 +201,6 @@ static inline bool lpae_is_superpage(lpae_t pte,
> > > unsigned int level)
> > > #define LPAE_TABLE_INDEX_GS(gs, lvl, addr) \
> > > (((addr) >> LEVEL_SHIFT_GS(gs, lvl)) & LPAE_ENTRY_MASK_GS(gs))
> > > -/* Generate an array @var containing the offset for each level from
> > > @addr */
> > > -#define DECLARE_OFFSETS(var, addr) \
> > > - const unsigned int var[4] = { \
> > > - zeroeth_table_offset(addr), \
> > > - first_table_offset(addr), \
> > > - second_table_offset(addr), \
> > > - third_table_offset(addr) \
> > > - }
> > > -
> > > -#endif /* __ASSEMBLY__ */
> > > -
> > > /*
> > > * These numbers add up to a 48-bit input address space.
> > > *
> > > @@ -211,26 +211,35 @@ static inline bool lpae_is_superpage(lpae_t pte,
> > > unsigned int level)
> > > * therefore 39-bits are sufficient.
> > > */
> > > -#define LPAE_SHIFT 9
> > > -#define LPAE_ENTRIES (_AC(1,U) << LPAE_SHIFT)
> > > -#define LPAE_ENTRY_MASK (LPAE_ENTRIES - 1)
> > > -
> > > -#define THIRD_SHIFT (PAGE_SHIFT)
> > > -#define THIRD_ORDER (THIRD_SHIFT - PAGE_SHIFT)
> > > -#define THIRD_SIZE (_AT(paddr_t, 1) << THIRD_SHIFT)
> > > -#define THIRD_MASK (~(THIRD_SIZE - 1))
> > > -#define SECOND_SHIFT (THIRD_SHIFT + LPAE_SHIFT)
> > > -#define SECOND_ORDER (SECOND_SHIFT - PAGE_SHIFT)
> > > -#define SECOND_SIZE (_AT(paddr_t, 1) << SECOND_SHIFT)
> > > -#define SECOND_MASK (~(SECOND_SIZE - 1))
> > > -#define FIRST_SHIFT (SECOND_SHIFT + LPAE_SHIFT)
> > > -#define FIRST_ORDER (FIRST_SHIFT - PAGE_SHIFT)
> > > -#define FIRST_SIZE (_AT(paddr_t, 1) << FIRST_SHIFT)
> > > -#define FIRST_MASK (~(FIRST_SIZE - 1))
> > > -#define ZEROETH_SHIFT (FIRST_SHIFT + LPAE_SHIFT)
> > > -#define ZEROETH_ORDER (ZEROETH_SHIFT - PAGE_SHIFT)
> > > -#define ZEROETH_SIZE (_AT(paddr_t, 1) << ZEROETH_SHIFT)
> > > -#define ZEROETH_MASK (~(ZEROETH_SIZE - 1))
> >
> > Should we add a one-line in-code comment saying that the definitions
> > below are for 4KB pages? It is not immediately obvious any longer.
>
> Because they are not meant to be for 4KB pages. They are meant to be for Xen
> page size.
>
> Today, it is always 4KB but I would like the Xen code to not rely on that.
>
> I can clarify it in an in-code comment.
That would help I think
> > > +#define LPAE_SHIFT LPAE_SHIFT_GS(PAGE_SHIFT)
> > > +#define LPAE_ENTRIES LPAE_ENTRIES_GS(PAGE_SHIFT)
> > > +#define LPAE_ENTRY_MASK LPAE_ENTRY_MASK_GS(PAGE_SHIFT)
> > >
> > > +#define LEVEL_SHIFT(lvl) LEVEL_SHIFT_GS(PAGE_SHIFT, lvl)
> > > +#define LEVEL_ORDER(lvl) LEVEL_ORDER_GS(PAGE_SHIFT, lvl)
> > > +#define LEVEL_SIZE(lvl) LEVEL_SIZE_GS(PAGE_SHIFT, lvl)
> > > +#define LEVEL_MASK(lvl) (~(LEVEL_SIZE(lvl) - 1))
> >
> > I would avoid adding these 4 macros. It would be OK if they were just
> > used within this file but lpae.h is a header: they could end up be used
> > anywhere in the xen/ code and they have a very generic name. My
> > suggestion would be to skip them and just do:
>
> Those macros will be used in follow-up patches. They are pretty useful to
> avoid introduce static array with the different information for each level.
>
> Would prefix them with XEN_ be better?
Maybe. The concern I have is that there are multiple page granularities
(4kb, 16kb, etc) and multiple page sizes (4kb, 2mb, etc). If I just see
LEVEL_ORDER it is not immediately obvious what granularity and what size
we are talking about.
I think using a name that makes it clear that they are referring to Xen
pages, currently 4kb, it would make sense. Or maybe a in-code comment
would be sufficient.
I don't have a great suggestion here so I'll leave it to you. I am also
OK to keep them as is.
> > #define THIRD_SHIFT LEVEL_SHIFT_GS(PAGE_SHIFT, 3)
> >
> > etc.
> >
> >
> > > +/* Convenience aliases */
> > > +#define THIRD_SHIFT LEVEL_SHIFT(3)
> > > +#define THIRD_ORDER LEVEL_ORDER(3)
> > > +#define THIRD_SIZE LEVEL_SIZE(3)
> > > +#define THIRD_MASK LEVEL_MASK(3)
> > > +
> > > +#define SECOND_SHIFT LEVEL_SHIFT(2)
> > > +#define SECOND_ORDER LEVEL_ORDER(2)
> > > +#define SECOND_SIZE LEVEL_SIZE(2)
> > > +#define SECOND_MASK LEVEL_MASK(2)
> > > +
> > > +#define FIRST_SHIFT LEVEL_SHIFT(1)
> > > +#define FIRST_ORDER LEVEL_ORDER(1)
> > > +#define FIRST_SIZE LEVEL_SIZE(1)
> > > +#define FIRST_MASK LEVEL_MASK(1)
> > > +
> > > +#define ZEROETH_SHIFT LEVEL_SHIFT(0)
> > > +#define ZEROETH_ORDER LEVEL_ORDER(0)
> > > +#define ZEROETH_SIZE LEVEL_SIZE(0)
> > > +#define ZEROETH_MASK LEVEL_MASK(0)
> > > /* Calculate the offsets into the pagetables for a given VA */
> > > #define zeroeth_linear_offset(va) ((va) >> ZEROETH_SHIFT)
> > > --
> > > 2.17.1
> > >
>
> Cheers,
>
> --
> Julien Grall
>
next prev parent reply other threads:[~2021-05-12 21:30 UTC|newest]
Thread overview: 59+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-04-25 20:13 [PATCH RFCv2 00/15] xen/arm: mm: Remove open-coding mappings Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 01/15] xen/arm: lpae: Rename LPAE_ENTRIES_MASK_GS to LPAE_ENTRY_MASK_GS Julien Grall
2021-05-11 22:12 ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 02/15] xen/arm: lpae: Use the generic helpers to defined the Xen PT helpers Julien Grall
2021-05-11 22:26 ` Stefano Stabellini
2021-05-12 14:26 ` Julien Grall
2021-05-12 21:30 ` Stefano Stabellini [this message]
2021-05-12 22:16 ` Julien Grall
2021-05-13 22:44 ` Stefano Stabellini
2021-07-03 17:32 ` Julien Grall
2021-07-13 20:53 ` Stefano Stabellini
2021-07-14 17:40 ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 03/15] xen/arm: p2m: Replace level_{orders, masks} arrays with LEVEL_{ORDER, MASK} Julien Grall
2021-05-11 22:33 ` Stefano Stabellini
2021-05-12 14:39 ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 04/15] xen/arm: mm: Allow other mapping size in xen_pt_update_entry() Julien Grall
2021-05-11 22:42 ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 05/15] xen/arm: mm: Avoid flushing the TLBs when mapping are inserted Julien Grall
2021-05-11 22:51 ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 06/15] xen/arm: mm: Don't open-code Xen PT update in remove_early_mappings() Julien Grall
2021-05-11 22:58 ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 07/15] xen/arm: mm: Re-implement early_fdt_map() using map_pages_to_xen() Julien Grall
2021-05-12 21:41 ` Stefano Stabellini
2021-05-12 22:18 ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 08/15] xen/arm32: mm: Check if the virtual address is shared before updating it Julien Grall
2021-05-12 22:00 ` Stefano Stabellini
2021-05-12 22:23 ` Julien Grall
2021-05-13 22:32 ` Stefano Stabellini
2021-05-13 22:59 ` Julien Grall
2021-05-14 1:04 ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 09/15] xen/arm32: mm: Re-implement setup_xenheap_mappings() using map_pages_to_xen() Julien Grall
2021-05-12 22:07 ` Stefano Stabellini
2021-05-13 17:55 ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 10/15] xen/arm: mm: Allocate xen page tables in domheap rather than xenheap Julien Grall
2021-05-12 22:44 ` Stefano Stabellini
2021-05-13 18:09 ` Julien Grall
2021-05-13 22:27 ` Stefano Stabellini
2021-05-15 8:48 ` Julien Grall
2021-05-18 0:37 ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 11/15] xen/arm: mm: Allow page-table allocation from the boot allocator Julien Grall
2021-05-13 22:58 ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 12/15] xen/arm: add Persistent Map (PMAP) infrastructure Julien Grall
2021-04-26 9:41 ` Xia, Hongyan
2021-07-03 17:57 ` Julien Grall
2021-04-28 21:47 ` Wei Liu
2021-05-14 23:25 ` Stefano Stabellini
2021-05-15 8:54 ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 13/15] xen/arm: mm: Use the PMAP helpers in xen_{,un}map_table() Julien Grall
2021-05-14 23:35 ` Stefano Stabellini
2021-05-15 9:03 ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 14/15] xen/arm: mm: Rework setup_xenheap_mappings() Julien Grall
2021-05-14 23:51 ` Stefano Stabellini
2021-05-15 9:21 ` Julien Grall
2021-05-18 0:50 ` Stefano Stabellini
2022-02-12 19:16 ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 15/15] xen/arm: mm: Re-implement setup_frame_table_mappings() with map_pages_to_xen() Julien Grall
2021-05-15 0:02 ` Stefano Stabellini
2021-05-15 9:25 ` Julien Grall
2021-05-18 0:51 ` Stefano Stabellini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.21.2105121425500.5018@sstabellini-ThinkPad-T480s \
--to=sstabellini@kernel.org \
--cc=Bertrand.Marquis@arm.com \
--cc=Henry.Wang@arm.com \
--cc=Penny.Zheng@arm.com \
--cc=Volodymyr_Babchuk@epam.com \
--cc=Wei.Chen@arm.com \
--cc=jgrall@amazon.com \
--cc=julien@xen.org \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).