All of lore.kernel.org
 help / color / mirror / Atom feed
From: James Morse <james.morse@arm.com>
To: Will Deacon <will.deacon@arm.com>,
	"AKASHI, Takahiro" <takahiro.akashi@linaro.org>
Cc: Rob Herring <robh+dt@kernel.org>,
	Catalin Marinas <catalin.marinas@arm.com>,
	David Howells <dhowells@redhat.com>,
	Vivek Goyal <vgoyal@redhat.com>,
	Herbert Xu <herbert@gondor.apana.org.au>,
	David Miller <davem@davemloft.net>,
	dyoung@redhat.com, Baoquan He <bhe@redhat.com>,
	Arnd Bergmann <arnd@arndb.de>,
	Martin Schwidefsky <schwidefsky@de.ibm.com>,
	Heiko Carstens <heiko.carstens@de.ibm.com>,
	prudo@linux.ibm.com, Ard Biesheuvel <ard.biesheuvel@linaro.org>,
	bhsharma@redhat.com, kexec@lists.infradead.org,
	"moderated list:ARM/FREESCALE IMX / MXC ARM ARCHITECTURE" 
	<linux-arm-kernel@lists.infradead.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Frank Rowand <frowand.list@gmail.com>,
	devicetree@vger.kernel.org
Subject: Re: [PATCH v16 06/16] lib: fdt: add a helper function for handling memory range property
Date: Fri, 7 Dec 2018 10:12:47 +0000	[thread overview]
Message-ID: <681e1265-2f0c-2a62-3778-09911b2be7fc@arm.com> (raw)
In-Reply-To: <20181206155424.GA4422@arm.com>

Hi Akashi, Will,

On 06/12/2018 15:54, Will Deacon wrote:
> On Thu, Dec 06, 2018 at 08:47:04AM -0600, Rob Herring wrote:
>> On Wed, Nov 14, 2018 at 11:52 PM AKASHI Takahiro
>> <takahiro.akashi@linaro.org> wrote:
>>>
>>> Added function, fdt_setprop_reg(), will be used later to handle
>>> kexec-specific property in arm64's kexec_file implementation.
>>> It will possibly be merged into libfdt in the future.
>>
>> You generally can't modify libfdt files. Any changes will be blown
>> away with the next dtc sync (there's one in -next now). Though here
>> you are creating a new location with fdt code. lib/ is just a shim to
>> the actual libfdt code. Don't put any implementation there. You can
>> add this to drivers/of/fdt_address.c for the short term, but it still
>> needs to go upstream.
>>
>> Otherwise, the implementation looks fine to me.
> 
> I agree, but I don't think there's a real need for us to hack
> drivers/of/fdt_address.c in the meantime -- let's just target upstream
> and not carry this in the kernel.
> 
> Akashi -- for now, I'll drop the kdump parts of this series which rely
> on this helper. The majority of the series is actually independent and
> can go in as-is.
> 
> I've pushed out a kexec branch to the arm64 tree for you to take a look
> at:
> 
> https://git.kernel.org/pub/scm/linux/kernel/git/arm64/linux.git/log/?h=kexec

I gave this a quick spin. Without the elfcorehdr/usable-memory-range arm64 needs
to explicitly forbid kdump via kexec_file_load. (like powerpc does already).
Without this kdump works, but the second kernel overwrites the first as those DT
properties are missing.

I'll post a patch momentarily,


Thanks,

James


WARNING: multiple messages have this Message-ID (diff)
From: James Morse <james.morse@arm.com>
To: Will Deacon <will.deacon@arm.com>,
	"AKASHI, Takahiro" <takahiro.akashi@linaro.org>
Cc: prudo@linux.ibm.com, Herbert Xu <herbert@gondor.apana.org.au>,
	Baoquan He <bhe@redhat.com>,
	Ard Biesheuvel <ard.biesheuvel@linaro.org>,
	Catalin Marinas <catalin.marinas@arm.com>,
	bhsharma@redhat.com, Frank Rowand <frowand.list@gmail.com>,
	Heiko Carstens <heiko.carstens@de.ibm.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	David Howells <dhowells@redhat.com>,
	devicetree@vger.kernel.org, Rob Herring <robh+dt@kernel.org>,
	Arnd Bergmann <arnd@arndb.de>,
	"moderated list:ARM/FREESCALE IMX / MXC ARM ARCHITECTURE"
	<linux-arm-kernel@lists.infradead.org>,
	kexec@lists.infradead.org,
	Martin Schwidefsky <schwidefsky@de.ibm.com>,
	dyoung@redhat.com, David Miller <davem@davemloft.net>,
	Vivek Goyal <vgoyal@redhat.com>
Subject: Re: [PATCH v16 06/16] lib: fdt: add a helper function for handling memory range property
Date: Fri, 7 Dec 2018 10:12:47 +0000	[thread overview]
Message-ID: <681e1265-2f0c-2a62-3778-09911b2be7fc@arm.com> (raw)
In-Reply-To: <20181206155424.GA4422@arm.com>

Hi Akashi, Will,

On 06/12/2018 15:54, Will Deacon wrote:
> On Thu, Dec 06, 2018 at 08:47:04AM -0600, Rob Herring wrote:
>> On Wed, Nov 14, 2018 at 11:52 PM AKASHI Takahiro
>> <takahiro.akashi@linaro.org> wrote:
>>>
>>> Added function, fdt_setprop_reg(), will be used later to handle
>>> kexec-specific property in arm64's kexec_file implementation.
>>> It will possibly be merged into libfdt in the future.
>>
>> You generally can't modify libfdt files. Any changes will be blown
>> away with the next dtc sync (there's one in -next now). Though here
>> you are creating a new location with fdt code. lib/ is just a shim to
>> the actual libfdt code. Don't put any implementation there. You can
>> add this to drivers/of/fdt_address.c for the short term, but it still
>> needs to go upstream.
>>
>> Otherwise, the implementation looks fine to me.
> 
> I agree, but I don't think there's a real need for us to hack
> drivers/of/fdt_address.c in the meantime -- let's just target upstream
> and not carry this in the kernel.
> 
> Akashi -- for now, I'll drop the kdump parts of this series which rely
> on this helper. The majority of the series is actually independent and
> can go in as-is.
> 
> I've pushed out a kexec branch to the arm64 tree for you to take a look
> at:
> 
> https://git.kernel.org/pub/scm/linux/kernel/git/arm64/linux.git/log/?h=kexec

I gave this a quick spin. Without the elfcorehdr/usable-memory-range arm64 needs
to explicitly forbid kdump via kexec_file_load. (like powerpc does already).
Without this kdump works, but the second kernel overwrites the first as those DT
properties are missing.

I'll post a patch momentarily,


Thanks,

James


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

WARNING: multiple messages have this Message-ID (diff)
From: James Morse <james.morse@arm.com>
To: Will Deacon <will.deacon@arm.com>,
	"AKASHI, Takahiro" <takahiro.akashi@linaro.org>
Cc: prudo@linux.ibm.com, Herbert Xu <herbert@gondor.apana.org.au>,
	Baoquan He <bhe@redhat.com>,
	Ard Biesheuvel <ard.biesheuvel@linaro.org>,
	Catalin Marinas <catalin.marinas@arm.com>,
	bhsharma@redhat.com, Frank Rowand <frowand.list@gmail.com>,
	Heiko Carstens <heiko.carstens@de.ibm.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	David Howells <dhowells@redhat.com>,
	devicetree@vger.kernel.org, Rob Herring <robh+dt@kernel.org>,
	Arnd Bergmann <arnd@arndb.de>,
	"moderated list:ARM/FREESCALE IMX / MXC ARM ARCHITECTURE"
	<linux-arm-kernel@lists.infradead.org>,
	kexec@lists.infradead.org,
	Martin Schwidefsky <schwidefsky@de.ibm.com>,
	dyoung@redhat.com, David Miller <davem@davemloft.net>,
	Vivek Goyal <vgoyal@redhat.com>
Subject: Re: [PATCH v16 06/16] lib: fdt: add a helper function for handling memory range property
Date: Fri, 7 Dec 2018 10:12:47 +0000	[thread overview]
Message-ID: <681e1265-2f0c-2a62-3778-09911b2be7fc@arm.com> (raw)
In-Reply-To: <20181206155424.GA4422@arm.com>

Hi Akashi, Will,

On 06/12/2018 15:54, Will Deacon wrote:
> On Thu, Dec 06, 2018 at 08:47:04AM -0600, Rob Herring wrote:
>> On Wed, Nov 14, 2018 at 11:52 PM AKASHI Takahiro
>> <takahiro.akashi@linaro.org> wrote:
>>>
>>> Added function, fdt_setprop_reg(), will be used later to handle
>>> kexec-specific property in arm64's kexec_file implementation.
>>> It will possibly be merged into libfdt in the future.
>>
>> You generally can't modify libfdt files. Any changes will be blown
>> away with the next dtc sync (there's one in -next now). Though here
>> you are creating a new location with fdt code. lib/ is just a shim to
>> the actual libfdt code. Don't put any implementation there. You can
>> add this to drivers/of/fdt_address.c for the short term, but it still
>> needs to go upstream.
>>
>> Otherwise, the implementation looks fine to me.
> 
> I agree, but I don't think there's a real need for us to hack
> drivers/of/fdt_address.c in the meantime -- let's just target upstream
> and not carry this in the kernel.
> 
> Akashi -- for now, I'll drop the kdump parts of this series which rely
> on this helper. The majority of the series is actually independent and
> can go in as-is.
> 
> I've pushed out a kexec branch to the arm64 tree for you to take a look
> at:
> 
> https://git.kernel.org/pub/scm/linux/kernel/git/arm64/linux.git/log/?h=kexec

I gave this a quick spin. Without the elfcorehdr/usable-memory-range arm64 needs
to explicitly forbid kdump via kexec_file_load. (like powerpc does already).
Without this kdump works, but the second kernel overwrites the first as those DT
properties are missing.

I'll post a patch momentarily,


Thanks,

James


_______________________________________________
kexec mailing list
kexec@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/kexec

  reply	other threads:[~2018-12-07 10:12 UTC|newest]

Thread overview: 93+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-11-15  5:52 [PATCH v16 00/16] arm64: kexec: add kexec_file_load() support AKASHI Takahiro
2018-11-15  5:52 ` AKASHI Takahiro
2018-11-15  5:52 ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 01/16] asm-generic: add kexec_file_load system call to unistd.h AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 02/16] kexec_file: make kexec_image_post_load_cleanup_default() global AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 03/16] s390, kexec_file: drop arch_kexec_mem_walk() AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 04/16] powerpc, kexec_file: factor out memblock-based arch_kexec_walk_mem() AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 05/16] kexec_file: kexec_walk_memblock() only walks a dedicated region at kdump AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 06/16] lib: fdt: add a helper function for handling memory range property AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-30 13:21   ` Will Deacon
2018-11-30 13:21     ` Will Deacon
2018-11-30 13:21     ` Will Deacon
2018-12-06 14:47   ` Rob Herring
2018-12-06 14:47     ` Rob Herring
2018-12-06 14:47     ` Rob Herring
2018-12-06 14:47     ` Rob Herring
2018-12-06 15:54     ` Will Deacon
2018-12-06 15:54       ` Will Deacon
2018-12-06 15:54       ` Will Deacon
2018-12-06 15:54       ` Will Deacon
2018-12-07 10:12       ` James Morse [this message]
2018-12-07 10:12         ` James Morse
2018-12-07 10:12         ` James Morse
2018-12-07 10:12         ` James Morse
2018-12-11  6:17         ` AKASHI, Takahiro
2018-12-11  6:17           ` AKASHI, Takahiro
2018-12-11  6:17           ` AKASHI, Takahiro
2018-12-11  6:17           ` AKASHI, Takahiro
2018-12-11 10:09           ` James Morse
2018-12-11 10:09             ` James Morse
2018-12-11 10:09             ` James Morse
2018-12-11 10:09             ` James Morse
2018-12-12  1:28             ` AKASHI, Takahiro
2018-12-12  1:28               ` AKASHI, Takahiro
2018-12-12  1:28               ` AKASHI, Takahiro
2018-12-12  1:28               ` AKASHI, Takahiro
2018-11-15  5:52 ` [PATCH v16 07/16] arm64: add image head flag definitions AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 08/16] arm64: cpufeature: add MMFR0 helper functions AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 09/16] arm64: enable KEXEC_FILE config AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 10/16] arm64: kexec_file: load initrd and device-tree AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 11/16] arm64: kexec_file: allow for loading Image-format kernel AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 12/16] arm64: kexec_file: add crash dump support AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 13/16] arm64: kexec_file: invoke the kernel without purgatory AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 14/16] include: pe.h: remove message[] from mz header definition AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 15/16] arm64: kexec_file: add kernel signature verification support AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-30 13:21   ` Will Deacon
2018-11-30 13:21     ` Will Deacon
2018-11-30 13:21     ` Will Deacon
2018-12-11  5:42     ` AKASHI Takahiro
2018-12-11  5:42       ` AKASHI Takahiro
2018-12-11  5:42       ` AKASHI Takahiro
2018-11-15  5:52 ` [PATCH v16 16/16] arm64: kexec_file: add kaslr support AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-15  5:52   ` AKASHI Takahiro
2018-11-30 13:19   ` Will Deacon
2018-11-30 13:19     ` Will Deacon
2018-11-30 13:19     ` Will Deacon
2018-12-11  5:50     ` AKASHI Takahiro
2018-12-11  5:50       ` AKASHI Takahiro
2018-12-11  5:50       ` AKASHI Takahiro
2018-12-11  7:51       ` AKASHI Takahiro
2018-12-11  7:51         ` AKASHI Takahiro
2018-12-11  7:51         ` AKASHI Takahiro

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=681e1265-2f0c-2a62-3778-09911b2be7fc@arm.com \
    --to=james.morse@arm.com \
    --cc=ard.biesheuvel@linaro.org \
    --cc=arnd@arndb.de \
    --cc=bhe@redhat.com \
    --cc=bhsharma@redhat.com \
    --cc=catalin.marinas@arm.com \
    --cc=davem@davemloft.net \
    --cc=devicetree@vger.kernel.org \
    --cc=dhowells@redhat.com \
    --cc=dyoung@redhat.com \
    --cc=frowand.list@gmail.com \
    --cc=heiko.carstens@de.ibm.com \
    --cc=herbert@gondor.apana.org.au \
    --cc=kexec@lists.infradead.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=prudo@linux.ibm.com \
    --cc=robh+dt@kernel.org \
    --cc=schwidefsky@de.ibm.com \
    --cc=takahiro.akashi@linaro.org \
    --cc=vgoyal@redhat.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.