All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] btrfs: Rename BTRFS_INODE_ORDERED_DATA_CLOSE flag
@ 2020-10-01  6:40 Nikolay Borisov
  2020-10-01 14:28 ` David Sterba
  0 siblings, 1 reply; 2+ messages in thread
From: Nikolay Borisov @ 2020-10-01  6:40 UTC (permalink / raw)
  To: linux-btrfs; +Cc: Nikolay Borisov

Commit 8d875f95da43 ("btrfs: disable strict file flushes for
renames and truncates") eliminated the notion of ordered operations and
instead BTRFS_INODE_ORDERED_DATA_CLOSE only remained as a flag
indicating that a file's content should be synced to disk in case a
file is truncated and any writes happen to it concurrently. In fact
this intendend behavior was broken until it was fixed in
f6dc45c7a93a ("Btrfs: fix filemap_flush call in btrfs_file_release").

All things considered let's give the flag a more descriptive name. Also
slightly reword comments.

Signed-off-by: Nikolay Borisov <nborisov@suse.com>
---
 fs/btrfs/btrfs_inode.h |  2 +-
 fs/btrfs/file.c        | 10 +++++-----
 fs/btrfs/inode.c       |  6 +++---
 3 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/fs/btrfs/btrfs_inode.h b/fs/btrfs/btrfs_inode.h
index 6fdb46d58299..1aff6187f3ab 100644
--- a/fs/btrfs/btrfs_inode.h
+++ b/fs/btrfs/btrfs_inode.h
@@ -21,7 +21,7 @@
  * new data the application may have written before commit.
  */
 enum {
-	BTRFS_INODE_ORDERED_DATA_CLOSE,
+	BTRFS_INODE_FLUSH_ON_CLOSE,
 	BTRFS_INODE_DUMMY,
 	BTRFS_INODE_IN_DEFRAG,
 	BTRFS_INODE_HAS_ASYNC_EXTENT,
diff --git a/fs/btrfs/file.c b/fs/btrfs/file.c
index d64ca6abea86..b8826aec3656 100644
--- a/fs/btrfs/file.c
+++ b/fs/btrfs/file.c
@@ -2091,12 +2091,12 @@ int btrfs_release_file(struct inode *inode, struct file *filp)
 	filp->private_data = NULL;
 
 	/*
-	 * ordered_data_close is set by setattr when we are about to truncate
-	 * a file from a non-zero size to a zero size.  This tries to
-	 * flush down new bytes that may have been written if the
-	 * application were using truncate to replace a file in place.
+	 * Set by setattr when we are about to truncate a file from a non-zero
+	 * size to a zero size.  This tries to flush down new bytes that may
+	 * have been written if the application were using truncate to replace
+	 * a file in place.
 	 */
-	if (test_and_clear_bit(BTRFS_INODE_ORDERED_DATA_CLOSE,
+	if (test_and_clear_bit(BTRFS_INODE_FLUSH_ON_CLOSE,
 			       &BTRFS_I(inode)->runtime_flags))
 			filemap_flush(inode->i_mapping);
 	return 0;
diff --git a/fs/btrfs/inode.c b/fs/btrfs/inode.c
index 7f9eaa009971..9f70e8299efc 100644
--- a/fs/btrfs/inode.c
+++ b/fs/btrfs/inode.c
@@ -4818,11 +4818,11 @@ static int btrfs_setsize(struct inode *inode, struct iattr *attr)
 
 		/*
 		 * We're truncating a file that used to have good data down to
-		 * zero. Make sure it gets into the ordered flush list so that
-		 * any new writes get down to disk quickly.
+		 * zero. Make sure any new writes to the file get on disk
+		 * on close.
 		 */
 		if (newsize == 0)
-			set_bit(BTRFS_INODE_ORDERED_DATA_CLOSE,
+			set_bit(BTRFS_INODE_FLUSH_ON_CLOSE,
 				&BTRFS_I(inode)->runtime_flags);
 
 		truncate_setsize(inode, newsize);
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] btrfs: Rename BTRFS_INODE_ORDERED_DATA_CLOSE flag
  2020-10-01  6:40 [PATCH] btrfs: Rename BTRFS_INODE_ORDERED_DATA_CLOSE flag Nikolay Borisov
@ 2020-10-01 14:28 ` David Sterba
  0 siblings, 0 replies; 2+ messages in thread
From: David Sterba @ 2020-10-01 14:28 UTC (permalink / raw)
  To: Nikolay Borisov; +Cc: linux-btrfs

On Thu, Oct 01, 2020 at 09:40:39AM +0300, Nikolay Borisov wrote:
> Commit 8d875f95da43 ("btrfs: disable strict file flushes for
> renames and truncates") eliminated the notion of ordered operations and
> instead BTRFS_INODE_ORDERED_DATA_CLOSE only remained as a flag
> indicating that a file's content should be synced to disk in case a
> file is truncated and any writes happen to it concurrently. In fact
> this intendend behavior was broken until it was fixed in
> f6dc45c7a93a ("Btrfs: fix filemap_flush call in btrfs_file_release").
> 
> All things considered let's give the flag a more descriptive name. Also
> slightly reword comments.

Added to misc-next, thanks.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-10-01 14:29 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-01  6:40 [PATCH] btrfs: Rename BTRFS_INODE_ORDERED_DATA_CLOSE flag Nikolay Borisov
2020-10-01 14:28 ` David Sterba

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.