All of lore.kernel.org
 help / color / mirror / Atom feed
From: Anthony Yznaga <anthony.yznaga@oracle.com>
To: Vineet Gupta <vineet.gupta1@synopsys.com>, linux-kernel@vger.kernel.org
Cc: linux-snps-arc@lists.infradead.org, linux-mm@kvack.org,
	peterz@infradead.org, Miklos Szeredi <mszeredi@redhat.com>,
	Ingo Molnar <mingo@kernel.org>,
	Jani Nikula <jani.nikula@intel.com>,
	Chris Wilson <chris@chris-wilson.co.uk>,
	Andrew Morton <akpm@linux-foundation.org>,
	Will Deacon <will.deacon@arm.com>
Subject: Re: [PATCH 3/3] bitops.h: set_mask_bits() to return old value
Date: Thu, 10 Jan 2019 20:25:09 -0800	[thread overview]
Message-ID: <693b30a9-96dc-a5e6-9708-c215b90146b0@oracle.com> (raw)
In-Reply-To: <1547166387-19785-4-git-send-email-vgupta@synopsys.com>



On 1/10/19 4:26 PM, Vineet Gupta wrote:
> | > Also, set_mask_bits is used in fs quite a bit and we can possibly come up
> | > with a generic llsc based implementation (w/o the cmpxchg loop)
> |
> | May I also suggest changing the return value of set_mask_bits() to old.
> |
> | You can compute the new value given old, but you cannot compute the old
> | value given new, therefore old is the better return value. Also, no
> | current user seems to use the return value, so changing it is without
> | risk.
>
> Link: http://lkml.kernel.org/g/20150807110955.GH16853@twins.programming.kicks-ass.net
> Suggested-by: Peter Zijlstra <peterz@infradead.org>
> Cc: Miklos Szeredi <mszeredi@redhat.com>
> Cc: Ingo Molnar <mingo@kernel.org>
> Cc: Jani Nikula <jani.nikula@intel.com>
> Cc: Chris Wilson <chris@chris-wilson.co.uk>
> Cc: Andrew Morton <akpm@linux-foundation.org>
> Cc: Will Deacon <will.deacon@arm.com>
> Signed-off-by: Vineet Gupta <vgupta@synopsys.com>
>

Reviewed-by: Anthony Yznaga <anthony.yznaga@oracle.com>

WARNING: multiple messages have this Message-ID (diff)
From: anthony.yznaga@oracle.com (Anthony Yznaga)
To: linux-snps-arc@lists.infradead.org
Subject: [PATCH 3/3] bitops.h: set_mask_bits() to return old value
Date: Thu, 10 Jan 2019 20:25:09 -0800	[thread overview]
Message-ID: <693b30a9-96dc-a5e6-9708-c215b90146b0@oracle.com> (raw)
In-Reply-To: <1547166387-19785-4-git-send-email-vgupta@synopsys.com>



On 1/10/19 4:26 PM, Vineet Gupta wrote:
> | > Also, set_mask_bits is used in fs quite a bit and we can possibly come up
> | > with a generic llsc based implementation (w/o the cmpxchg loop)
> |
> | May I also suggest changing the return value of set_mask_bits() to old.
> |
> | You can compute the new value given old, but you cannot compute the old
> | value given new, therefore old is the better return value. Also, no
> | current user seems to use the return value, so changing it is without
> | risk.
>
> Link: http://lkml.kernel.org/g/20150807110955.GH16853 at twins.programming.kicks-ass.net
> Suggested-by: Peter Zijlstra <peterz at infradead.org>
> Cc: Miklos Szeredi <mszeredi at redhat.com>
> Cc: Ingo Molnar <mingo at kernel.org>
> Cc: Jani Nikula <jani.nikula at intel.com>
> Cc: Chris Wilson <chris at chris-wilson.co.uk>
> Cc: Andrew Morton <akpm at linux-foundation.org>
> Cc: Will Deacon <will.deacon at arm.com>
> Signed-off-by: Vineet Gupta <vgupta at synopsys.com>
>

Reviewed-by: Anthony Yznaga <anthony.yznaga at oracle.com>

  reply	other threads:[~2019-01-11  4:25 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-01-11  0:26 [PATCH 0/3] Replace opencoded set_mask_bits Vineet Gupta
2019-01-11  0:26 ` Vineet Gupta
2019-01-11  0:26 ` Vineet Gupta
2019-01-11  0:26 ` [PATCH 1/3] coredump: Replace opencoded set_mask_bits() Vineet Gupta
2019-01-11  0:26   ` Vineet Gupta
2019-01-11  0:26   ` Vineet Gupta
2019-01-11  4:24   ` Anthony Yznaga
2019-01-11  4:24     ` Anthony Yznaga
2019-01-11  4:24     ` Anthony Yznaga
2019-01-11  0:26 ` [PATCH 2/3] fs: inode_set_flags() replace " Vineet Gupta
2019-01-11  0:26   ` Vineet Gupta
2019-01-11  0:26   ` Vineet Gupta
2019-01-11  0:26   ` Vineet Gupta
2019-01-11  4:24   ` Anthony Yznaga
2019-01-11  4:24     ` Anthony Yznaga
2019-01-11  4:24     ` Anthony Yznaga
2019-01-11  0:26 ` [PATCH 3/3] bitops.h: set_mask_bits() to return old value Vineet Gupta
2019-01-11  0:26   ` Vineet Gupta
2019-01-11  0:26   ` Vineet Gupta
2019-01-11  0:26   ` Vineet Gupta
2019-01-11  4:25   ` Anthony Yznaga [this message]
2019-01-11  4:25     ` Anthony Yznaga
2019-01-11  9:24   ` Peter Zijlstra
2019-01-11  9:24     ` Peter Zijlstra
2019-01-11 20:58     ` Vineet Gupta
2019-01-11 20:58       ` Vineet Gupta
2019-01-11 20:58       ` Vineet Gupta
2019-01-14 19:00   ` Will Deacon
2019-01-14 19:00     ` Will Deacon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=693b30a9-96dc-a5e6-9708-c215b90146b0@oracle.com \
    --to=anthony.yznaga@oracle.com \
    --cc=akpm@linux-foundation.org \
    --cc=chris@chris-wilson.co.uk \
    --cc=jani.nikula@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-snps-arc@lists.infradead.org \
    --cc=mingo@kernel.org \
    --cc=mszeredi@redhat.com \
    --cc=peterz@infradead.org \
    --cc=vineet.gupta1@synopsys.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.