All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH net-next] tcp: use REXMIT_NEW instead of magic number
@ 2020-01-02 14:02 ` Mao Wenan
  0 siblings, 0 replies; 6+ messages in thread
From: Mao Wenan @ 2020-01-02 14:02 UTC (permalink / raw)
  To: edumazet, davem, kuznet, yoshfuji; +Cc: netdev, linux-kernel, kernel-janitors

REXMIT_NEW is a macro for "FRTO-style
transmit of unsent/new packets", this patch
makes it more readable.

Signed-off-by: Mao Wenan <maowenan@huawei.com>
---
 net/ipv4/tcp_input.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/ipv4/tcp_input.c b/net/ipv4/tcp_input.c
index 88b987ca9ebb..1d1e3493965f 100644
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
@@ -3550,7 +3550,7 @@ static void tcp_xmit_recovery(struct sock *sk, int rexmit)
 	if (rexmit == REXMIT_NONE || sk->sk_state == TCP_SYN_SENT)
 		return;
 
-	if (unlikely(rexmit == 2)) {
+	if (unlikely(rexmit == REXMIT_NEW)) {
 		__tcp_push_pending_frames(sk, tcp_current_mss(sk),
 					  TCP_NAGLE_OFF);
 		if (after(tp->snd_nxt, tp->high_seq))
-- 
2.20.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH net-next] tcp: use REXMIT_NEW instead of magic number
@ 2020-01-02 14:02 ` Mao Wenan
  0 siblings, 0 replies; 6+ messages in thread
From: Mao Wenan @ 2020-01-02 14:02 UTC (permalink / raw)
  To: edumazet, davem, kuznet, yoshfuji; +Cc: netdev, linux-kernel, kernel-janitors

REXMIT_NEW is a macro for "FRTO-style
transmit of unsent/new packets", this patch
makes it more readable.

Signed-off-by: Mao Wenan <maowenan@huawei.com>
---
 net/ipv4/tcp_input.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/ipv4/tcp_input.c b/net/ipv4/tcp_input.c
index 88b987ca9ebb..1d1e3493965f 100644
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
@@ -3550,7 +3550,7 @@ static void tcp_xmit_recovery(struct sock *sk, int rexmit)
 	if (rexmit = REXMIT_NONE || sk->sk_state = TCP_SYN_SENT)
 		return;
 
-	if (unlikely(rexmit = 2)) {
+	if (unlikely(rexmit = REXMIT_NEW)) {
 		__tcp_push_pending_frames(sk, tcp_current_mss(sk),
 					  TCP_NAGLE_OFF);
 		if (after(tp->snd_nxt, tp->high_seq))
-- 
2.20.1

^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH net-next] tcp: use REXMIT_NEW instead of magic number
  2020-01-02 14:02 ` Mao Wenan
@ 2020-01-02 16:45   ` Neal Cardwell
  -1 siblings, 0 replies; 6+ messages in thread
From: Neal Cardwell @ 2020-01-02 16:45 UTC (permalink / raw)
  To: Mao Wenan
  Cc: Eric Dumazet, David Miller, Alexey Kuznetsov, Hideaki YOSHIFUJI,
	Netdev, LKML, kernel-janitors, Yuchung Cheng

On Thu, Jan 2, 2020 at 9:07 AM Mao Wenan <maowenan@huawei.com> wrote:
>
> REXMIT_NEW is a macro for "FRTO-style
> transmit of unsent/new packets", this patch
> makes it more readable.
>
> Signed-off-by: Mao Wenan <maowenan@huawei.com>
> ---
>  net/ipv4/tcp_input.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/net/ipv4/tcp_input.c b/net/ipv4/tcp_input.c
> index 88b987ca9ebb..1d1e3493965f 100644
> --- a/net/ipv4/tcp_input.c
> +++ b/net/ipv4/tcp_input.c
> @@ -3550,7 +3550,7 @@ static void tcp_xmit_recovery(struct sock *sk, int rexmit)
>         if (rexmit == REXMIT_NONE || sk->sk_state == TCP_SYN_SENT)
>                 return;
>
> -       if (unlikely(rexmit == 2)) {
> +       if (unlikely(rexmit == REXMIT_NEW)) {
>                 __tcp_push_pending_frames(sk, tcp_current_mss(sk),
>                                           TCP_NAGLE_OFF);
>                 if (after(tp->snd_nxt, tp->high_seq))
> --

Acked-by: Neal Cardwell <ncardwell@google.com>

Thanks for sending this patch!

neal

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH net-next] tcp: use REXMIT_NEW instead of magic number
@ 2020-01-02 16:45   ` Neal Cardwell
  0 siblings, 0 replies; 6+ messages in thread
From: Neal Cardwell @ 2020-01-02 16:45 UTC (permalink / raw)
  To: Mao Wenan
  Cc: Eric Dumazet, David Miller, Alexey Kuznetsov, Hideaki YOSHIFUJI,
	Netdev, LKML, kernel-janitors, Yuchung Cheng

On Thu, Jan 2, 2020 at 9:07 AM Mao Wenan <maowenan@huawei.com> wrote:
>
> REXMIT_NEW is a macro for "FRTO-style
> transmit of unsent/new packets", this patch
> makes it more readable.
>
> Signed-off-by: Mao Wenan <maowenan@huawei.com>
> ---
>  net/ipv4/tcp_input.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/net/ipv4/tcp_input.c b/net/ipv4/tcp_input.c
> index 88b987ca9ebb..1d1e3493965f 100644
> --- a/net/ipv4/tcp_input.c
> +++ b/net/ipv4/tcp_input.c
> @@ -3550,7 +3550,7 @@ static void tcp_xmit_recovery(struct sock *sk, int rexmit)
>         if (rexmit = REXMIT_NONE || sk->sk_state = TCP_SYN_SENT)
>                 return;
>
> -       if (unlikely(rexmit = 2)) {
> +       if (unlikely(rexmit = REXMIT_NEW)) {
>                 __tcp_push_pending_frames(sk, tcp_current_mss(sk),
>                                           TCP_NAGLE_OFF);
>                 if (after(tp->snd_nxt, tp->high_seq))
> --

Acked-by: Neal Cardwell <ncardwell@google.com>

Thanks for sending this patch!

neal

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH net-next] tcp: use REXMIT_NEW instead of magic number
  2020-01-02 14:02 ` Mao Wenan
@ 2020-01-03  0:37   ` David Miller
  -1 siblings, 0 replies; 6+ messages in thread
From: David Miller @ 2020-01-03  0:37 UTC (permalink / raw)
  To: maowenan
  Cc: edumazet, kuznet, yoshfuji, netdev, linux-kernel, kernel-janitors

From: Mao Wenan <maowenan@huawei.com>
Date: Thu, 2 Jan 2020 22:02:27 +0800

> REXMIT_NEW is a macro for "FRTO-style
> transmit of unsent/new packets", this patch
> makes it more readable.
> 
> Signed-off-by: Mao Wenan <maowenan@huawei.com>

Applied.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH net-next] tcp: use REXMIT_NEW instead of magic number
@ 2020-01-03  0:37   ` David Miller
  0 siblings, 0 replies; 6+ messages in thread
From: David Miller @ 2020-01-03  0:37 UTC (permalink / raw)
  To: maowenan
  Cc: edumazet, kuznet, yoshfuji, netdev, linux-kernel, kernel-janitors

From: Mao Wenan <maowenan@huawei.com>
Date: Thu, 2 Jan 2020 22:02:27 +0800

> REXMIT_NEW is a macro for "FRTO-style
> transmit of unsent/new packets", this patch
> makes it more readable.
> 
> Signed-off-by: Mao Wenan <maowenan@huawei.com>

Applied.

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2020-01-03  0:37 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-01-02 14:02 [PATCH net-next] tcp: use REXMIT_NEW instead of magic number Mao Wenan
2020-01-02 14:02 ` Mao Wenan
2020-01-02 16:45 ` Neal Cardwell
2020-01-02 16:45   ` Neal Cardwell
2020-01-03  0:37 ` David Miller
2020-01-03  0:37   ` David Miller

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.