All of lore.kernel.org
 help / color / mirror / Atom feed
From: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
To: Robin Murphy <robin.murphy@arm.com>
Cc: "linux-renesas-soc@vger.kernel.org" 
	<linux-renesas-soc@vger.kernel.org>,
	"linux-mmc@vger.kernel.org" <linux-mmc@vger.kernel.org>,
	"linux-block@vger.kernel.org" <linux-block@vger.kernel.org>,
	"iommu@lists.linux-foundation.org"
	<iommu@lists.linux-foundation.org>, "hch@lst.de" <hch@lst.de>,
	"joro@8bytes.org" <joro@8bytes.org>,
	"axboe@kernel.dk" <axboe@kernel.dk>,
	"ulf.hansson@linaro.org" <ulf.hansson@linaro.org>,
	"wsa+renesas@sang-engineering.com"
	<wsa+renesas@sang-engineering.com>
Subject: RE: [RFC PATCH v6 3/5] block: add a helper function to merge the segments by an IOMMU
Date: Mon, 17 Jun 2019 06:29:31 +0000	[thread overview]
Message-ID: <OSBPR01MB3590A1AA199894E8220777EFD8EB0@OSBPR01MB3590.jpnprd01.prod.outlook.com> (raw)
In-Reply-To: <039d7388-ed24-c7e7-dd6a-656c719a5ed9@arm.com>

Hi Robin,

> From: Robin Murphy, Sent: Friday, June 14, 2019 6:55 PM
> 
> On 13/06/2019 11:20, Yoshihiro Shimoda wrote:
<snip>
> > +bool blk_queue_can_use_iommu_merging(struct request_queue *q,
> > +				     struct device *dev)
> > +{
> > +	struct iommu_domain *domain;
> > +
> > +	/*
> > +	 * If the device DMA is translated by an IOMMU, we can assume
> > +	 * the device can merge the segments.
> > +	 */
> > +	if (!device_iommu_mapped(dev))
> 
> Careful here - I think this validates the comment I made when this
> function was introduced, in that that name doesn't necesarily mean what
> it sounds like it might mean - "iommu_mapped" was as close as we managed
> to get to a convenient shorthand for "performs DMA through an
> IOMMU-API-enabled IOMMU". Specifically, it does not imply that
> translation is *currently* active; if you boot with "iommu=pt" or
> equivalent this will still return true even though the device will be
> using direct/SWIOTLB DMA ops without any IOMMU translation.

Thank you for your comments. I understood the mean of "iommu_mapped" and
this patch's condition causes a problem on iommu=pt.
So, I'll add and additional condition like
"domain->type == IOMMU_DOMAIN_DMA" to check whether the translation is
currently active on the domain or not.

Best regards,
Yoshihiro Shimoda


WARNING: multiple messages have this Message-ID (diff)
From: Yoshihiro Shimoda <yoshihiro.shimoda.uh-zM6kxYcvzFBBDgjK7y7TUQ@public.gmane.org>
To: Robin Murphy <robin.murphy-5wv7dgnIgG8@public.gmane.org>
Cc: "axboe-tSWWG44O7X1aa/9Udqfwiw@public.gmane.org"
	<axboe-tSWWG44O7X1aa/9Udqfwiw@public.gmane.org>,
	"linux-block-u79uwXL29TY76Z2rM5mHXA@public.gmane.org"
	<linux-block-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>,
	"ulf.hansson-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org"
	<ulf.hansson-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>,
	"linux-mmc-u79uwXL29TY76Z2rM5mHXA@public.gmane.org"
	<linux-mmc-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>,
	"linux-renesas-soc-u79uwXL29TY76Z2rM5mHXA@public.gmane.org"
	<linux-renesas-soc-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>,
	"wsa+renesas-jBu1N2QxHDJrcw3mvpCnnVaTQe2KTcn/@public.gmane.org"
	<wsa+renesas-jBu1N2QxHDJrcw3mvpCnnVaTQe2KTcn/@public.gmane.org>,
	"iommu-cunTk1MwBs9QetFLy7KEm3xJsTq8ys+cHZ5vskTnxNA@public.gmane.org"
	<iommu-cunTk1MwBs9QetFLy7KEm3xJsTq8ys+cHZ5vskTnxNA@public.gmane.org>,
	"hch-jcswGhMUV9g@public.gmane.org"
	<hch-jcswGhMUV9g@public.gmane.org>
Subject: RE: [RFC PATCH v6 3/5] block: add a helper function to merge the segments by an IOMMU
Date: Mon, 17 Jun 2019 06:29:31 +0000	[thread overview]
Message-ID: <OSBPR01MB3590A1AA199894E8220777EFD8EB0@OSBPR01MB3590.jpnprd01.prod.outlook.com> (raw)
In-Reply-To: <039d7388-ed24-c7e7-dd6a-656c719a5ed9-5wv7dgnIgG8@public.gmane.org>

Hi Robin,

> From: Robin Murphy, Sent: Friday, June 14, 2019 6:55 PM
> 
> On 13/06/2019 11:20, Yoshihiro Shimoda wrote:
<snip>
> > +bool blk_queue_can_use_iommu_merging(struct request_queue *q,
> > +				     struct device *dev)
> > +{
> > +	struct iommu_domain *domain;
> > +
> > +	/*
> > +	 * If the device DMA is translated by an IOMMU, we can assume
> > +	 * the device can merge the segments.
> > +	 */
> > +	if (!device_iommu_mapped(dev))
> 
> Careful here - I think this validates the comment I made when this
> function was introduced, in that that name doesn't necesarily mean what
> it sounds like it might mean - "iommu_mapped" was as close as we managed
> to get to a convenient shorthand for "performs DMA through an
> IOMMU-API-enabled IOMMU". Specifically, it does not imply that
> translation is *currently* active; if you boot with "iommu=pt" or
> equivalent this will still return true even though the device will be
> using direct/SWIOTLB DMA ops without any IOMMU translation.

Thank you for your comments. I understood the mean of "iommu_mapped" and
this patch's condition causes a problem on iommu=pt.
So, I'll add and additional condition like
"domain->type == IOMMU_DOMAIN_DMA" to check whether the translation is
currently active on the domain or not.

Best regards,
Yoshihiro Shimoda

WARNING: multiple messages have this Message-ID (diff)
From: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
To: Robin Murphy <robin.murphy@arm.com>
Cc: "axboe@kernel.dk" <axboe@kernel.dk>,
	"linux-block@vger.kernel.org" <linux-block@vger.kernel.org>,
	"ulf.hansson@linaro.org" <ulf.hansson@linaro.org>,
	"linux-mmc@vger.kernel.org" <linux-mmc@vger.kernel.org>,
	"linux-renesas-soc@vger.kernel.org"
	<linux-renesas-soc@vger.kernel.org>,
	"wsa+renesas@sang-engineering.com"
	<wsa+renesas@sang-engineering.com>,
	"iommu@lists.linux-foundation.org"
	<iommu@lists.linux-foundation.org>, "hch@lst.de" <hch@lst.de>
Subject: RE: [RFC PATCH v6 3/5] block: add a helper function to merge the segments by an IOMMU
Date: Mon, 17 Jun 2019 06:29:31 +0000	[thread overview]
Message-ID: <OSBPR01MB3590A1AA199894E8220777EFD8EB0@OSBPR01MB3590.jpnprd01.prod.outlook.com> (raw)
In-Reply-To: <039d7388-ed24-c7e7-dd6a-656c719a5ed9@arm.com>

Hi Robin,

> From: Robin Murphy, Sent: Friday, June 14, 2019 6:55 PM
> 
> On 13/06/2019 11:20, Yoshihiro Shimoda wrote:
<snip>
> > +bool blk_queue_can_use_iommu_merging(struct request_queue *q,
> > +				     struct device *dev)
> > +{
> > +	struct iommu_domain *domain;
> > +
> > +	/*
> > +	 * If the device DMA is translated by an IOMMU, we can assume
> > +	 * the device can merge the segments.
> > +	 */
> > +	if (!device_iommu_mapped(dev))
> 
> Careful here - I think this validates the comment I made when this
> function was introduced, in that that name doesn't necesarily mean what
> it sounds like it might mean - "iommu_mapped" was as close as we managed
> to get to a convenient shorthand for "performs DMA through an
> IOMMU-API-enabled IOMMU". Specifically, it does not imply that
> translation is *currently* active; if you boot with "iommu=pt" or
> equivalent this will still return true even though the device will be
> using direct/SWIOTLB DMA ops without any IOMMU translation.

Thank you for your comments. I understood the mean of "iommu_mapped" and
this patch's condition causes a problem on iommu=pt.
So, I'll add and additional condition like
"domain->type == IOMMU_DOMAIN_DMA" to check whether the translation is
currently active on the domain or not.

Best regards,
Yoshihiro Shimoda

_______________________________________________
iommu mailing list
iommu@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/iommu

  reply	other threads:[~2019-06-17  6:29 UTC|newest]

Thread overview: 93+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-06-13 10:20 [RFC PATCH v6 0/5] treewide: improve R-Car SDHI performance Yoshihiro Shimoda
2019-06-13 10:20 ` Yoshihiro Shimoda
2019-06-13 10:20 ` Yoshihiro Shimoda
2019-06-13 10:20 ` [RFC PATCH v6 1/5] iommu: add an exported function to get minimum page size for a domain Yoshihiro Shimoda
2019-06-13 10:20   ` Yoshihiro Shimoda
2019-06-13 10:20   ` Yoshihiro Shimoda
2019-06-13 19:37   ` Wolfram Sang
2019-06-13 19:37     ` Wolfram Sang
2019-06-13 19:37     ` Wolfram Sang
2019-06-14  7:16     ` Christoph Hellwig
2019-06-14  7:16       ` Christoph Hellwig
2019-06-14  7:16       ` Christoph Hellwig
2019-06-17  5:08     ` Yoshihiro Shimoda
2019-06-17  5:08       ` Yoshihiro Shimoda
2019-06-17  5:08       ` Yoshihiro Shimoda
2019-06-14  9:41   ` Robin Murphy
2019-06-14  9:41     ` Robin Murphy
2019-06-14  9:41     ` Robin Murphy
2019-06-17  5:23     ` Yoshihiro Shimoda
2019-06-17  5:23       ` Yoshihiro Shimoda
2019-06-17  5:23       ` Yoshihiro Shimoda
2019-06-13 10:20 ` [RFC PATCH v6 2/5] block: sort headers on blk-setting.c Yoshihiro Shimoda
2019-06-13 10:20   ` Yoshihiro Shimoda
2019-06-13 10:20   ` Yoshihiro Shimoda
2019-06-13 19:40   ` Wolfram Sang
2019-06-13 19:40     ` Wolfram Sang
2019-06-13 19:40     ` Wolfram Sang
2019-06-13 10:20 ` [RFC PATCH v6 3/5] block: add a helper function to merge the segments by an IOMMU Yoshihiro Shimoda
2019-06-13 10:20   ` Yoshihiro Shimoda
2019-06-13 10:20   ` Yoshihiro Shimoda
2019-06-14  7:22   ` Christoph Hellwig
2019-06-14  7:22     ` Christoph Hellwig
2019-06-14  7:22     ` Christoph Hellwig
2019-06-14  9:54   ` Robin Murphy
2019-06-14  9:54     ` Robin Murphy
2019-06-14  9:54     ` Robin Murphy
2019-06-17  6:29     ` Yoshihiro Shimoda [this message]
2019-06-17  6:29       ` Yoshihiro Shimoda
2019-06-17  6:29       ` Yoshihiro Shimoda
2019-06-13 10:20 ` [RFC PATCH v6 4/5] mmc: tmio: Use dma_max_mapping_size() instead of a workaround Yoshihiro Shimoda
2019-06-13 10:20   ` Yoshihiro Shimoda
2019-06-13 10:20   ` Yoshihiro Shimoda
2019-06-13 19:45   ` Wolfram Sang
2019-06-13 19:45     ` Wolfram Sang
2019-06-13 19:45     ` Wolfram Sang
2019-06-17  4:25     ` Yoshihiro Shimoda
2019-06-17  4:25       ` Yoshihiro Shimoda
2019-06-17  4:25       ` Yoshihiro Shimoda
2019-06-13 20:35   ` Geert Uytterhoeven
2019-06-13 20:35     ` Geert Uytterhoeven
2019-06-13 20:35     ` Geert Uytterhoeven
2019-06-14  7:18     ` Christoph Hellwig
2019-06-14  7:18       ` Christoph Hellwig
2019-06-14  7:18       ` Christoph Hellwig
2019-06-14  7:27       ` Geert Uytterhoeven
2019-06-14  7:27         ` Geert Uytterhoeven
2019-06-14  7:27         ` Geert Uytterhoeven
2019-06-17  4:54         ` Yoshihiro Shimoda
2019-06-17  4:54           ` Yoshihiro Shimoda
2019-06-17  4:54           ` Yoshihiro Shimoda
2019-06-17  6:23           ` Geert Uytterhoeven
2019-06-17  6:23             ` Geert Uytterhoeven
2019-06-17  6:23             ` Geert Uytterhoeven
2019-06-17  6:54             ` Yoshihiro Shimoda
2019-06-17  6:54               ` Yoshihiro Shimoda
2019-06-17  6:54               ` Yoshihiro Shimoda
2019-06-13 10:20 ` [RFC PATCH v6 5/5] mmc: queue: Use bigger segments if IOMMU can merge the segments Yoshihiro Shimoda
2019-06-13 10:20   ` Yoshihiro Shimoda
2019-06-13 10:20   ` Yoshihiro Shimoda
2019-06-13 19:58   ` Wolfram Sang
2019-06-13 19:58     ` Wolfram Sang
2019-06-13 19:58     ` Wolfram Sang
2019-06-17  6:38     ` Yoshihiro Shimoda
2019-06-17  6:38       ` Yoshihiro Shimoda
2019-06-17  6:38       ` Yoshihiro Shimoda
2019-06-14  7:24   ` Christoph Hellwig
2019-06-14  7:24     ` Christoph Hellwig
2019-06-14  7:24     ` Christoph Hellwig
2019-06-14 10:42     ` Wolfram Sang
2019-06-14 10:42       ` Wolfram Sang
2019-06-14 10:42       ` Wolfram Sang
2019-06-17  6:46     ` Yoshihiro Shimoda
2019-06-17  6:46       ` Yoshihiro Shimoda
2019-06-17  6:46       ` Yoshihiro Shimoda
2019-06-17  6:53       ` Christoph Hellwig
2019-06-17  6:53         ` Christoph Hellwig
2019-06-17  6:53         ` Christoph Hellwig
2019-06-17  7:02         ` Yoshihiro Shimoda
2019-06-17  7:02           ` Yoshihiro Shimoda
2019-06-17  7:02           ` Yoshihiro Shimoda
2019-06-13 19:36 ` [RFC PATCH v6 0/5] treewide: improve R-Car SDHI performance Wolfram Sang
2019-06-13 19:36   ` Wolfram Sang
2019-06-13 19:36   ` Wolfram Sang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=OSBPR01MB3590A1AA199894E8220777EFD8EB0@OSBPR01MB3590.jpnprd01.prod.outlook.com \
    --to=yoshihiro.shimoda.uh@renesas.com \
    --cc=axboe@kernel.dk \
    --cc=hch@lst.de \
    --cc=iommu@lists.linux-foundation.org \
    --cc=joro@8bytes.org \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-mmc@vger.kernel.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=robin.murphy@arm.com \
    --cc=ulf.hansson@linaro.org \
    --cc=wsa+renesas@sang-engineering.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.