All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mark Brown <broonie@kernel.org>
To: Dave Martin <Dave.Martin@arm.com>
Cc: Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will@kernel.org>,
	Szabolcs Nagy <szabolcs.nagy@arm.com>,
	Jeremy Linton <jeremy.linton@arm.com>,
	"H . J . Lu" <hjl.tools@gmail.com>,
	Yu-cheng Yu <yu-cheng.yu@intel.com>,
	linux-arch@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	libc-alpha@sourceware.org
Subject: Re: [PATCH v2 2/3] arm64: Enable BTI for main executable as well as the interpreter
Date: Thu, 10 Jun 2021 14:19:05 +0100	[thread overview]
Message-ID: <YMIRSSMnP3UMwdRy@sirena.org.uk> (raw)
In-Reply-To: <20210609151713.GL4187@arm.com>

[-- Attachment #1: Type: text/plain, Size: 1436 bytes --]

On Wed, Jun 09, 2021 at 04:17:13PM +0100, Dave Martin wrote:
> On Fri, Jun 04, 2021 at 12:24:49PM +0100, Mark Brown wrote:

> > -		if (system_supports_bti() && has_interp == is_interp &&
> > -		    (*p & GNU_PROPERTY_AARCH64_FEATURE_1_BTI))
> > -			arch->flags |= ARM64_ELF_BTI;
> > +		if (system_supports_bti() &&
> > +		    (*p & GNU_PROPERTY_AARCH64_FEATURE_1_BTI)) {
> > +			if (is_interp) {
> > +				arch->flags |= ARM64_ELF_INTERP_BTI;
> > +			} else {
> > +				arch->flags |= ARM64_ELF_EXEC_BTI;
> > +			}

> Nit: surplus curlies? (coding-style.rst does actually say to drop them
> when all branches of an if are single-statement one-liners -- I had
> presumed I was just being pedantic...)

I really think this hurts readability with the nested if inside
another if with a multi-line condition.

> > -	if (prot & PROT_EXEC)
> > -		prot |= PROT_BTI;
> > +		if (state->flags & ARM64_ELF_EXEC_BTI && !is_interp)
> > +			prot |= PROT_BTI;
> > +	}

> Is it worth adding () around the bitwise-& expressions?  I'm always a
> little uneasy about the operator precedence of binary &, although
> without looking it up I think you're correct.

Sure.  I'm fairly sure the compiler would've complained about
this case if it were ambiguous, I'm vaguely surprised it didn't
already.

> Feel free to adopt if this appeals to you, otherwise I'm also fine with
> your version.)

I'll see what I think when I get back to looking at this
properly.

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

WARNING: multiple messages have this Message-ID (diff)
From: Mark Brown <broonie@kernel.org>
To: Dave Martin <Dave.Martin@arm.com>
Cc: Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will@kernel.org>,
	Szabolcs Nagy <szabolcs.nagy@arm.com>,
	Jeremy Linton <jeremy.linton@arm.com>,
	"H . J . Lu" <hjl.tools@gmail.com>,
	Yu-cheng Yu <yu-cheng.yu@intel.com>,
	linux-arch@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	libc-alpha@sourceware.org
Subject: Re: [PATCH v2 2/3] arm64: Enable BTI for main executable as well as the interpreter
Date: Thu, 10 Jun 2021 14:19:05 +0100	[thread overview]
Message-ID: <YMIRSSMnP3UMwdRy@sirena.org.uk> (raw)
In-Reply-To: <20210609151713.GL4187@arm.com>


[-- Attachment #1.1: Type: text/plain, Size: 1436 bytes --]

On Wed, Jun 09, 2021 at 04:17:13PM +0100, Dave Martin wrote:
> On Fri, Jun 04, 2021 at 12:24:49PM +0100, Mark Brown wrote:

> > -		if (system_supports_bti() && has_interp == is_interp &&
> > -		    (*p & GNU_PROPERTY_AARCH64_FEATURE_1_BTI))
> > -			arch->flags |= ARM64_ELF_BTI;
> > +		if (system_supports_bti() &&
> > +		    (*p & GNU_PROPERTY_AARCH64_FEATURE_1_BTI)) {
> > +			if (is_interp) {
> > +				arch->flags |= ARM64_ELF_INTERP_BTI;
> > +			} else {
> > +				arch->flags |= ARM64_ELF_EXEC_BTI;
> > +			}

> Nit: surplus curlies? (coding-style.rst does actually say to drop them
> when all branches of an if are single-statement one-liners -- I had
> presumed I was just being pedantic...)

I really think this hurts readability with the nested if inside
another if with a multi-line condition.

> > -	if (prot & PROT_EXEC)
> > -		prot |= PROT_BTI;
> > +		if (state->flags & ARM64_ELF_EXEC_BTI && !is_interp)
> > +			prot |= PROT_BTI;
> > +	}

> Is it worth adding () around the bitwise-& expressions?  I'm always a
> little uneasy about the operator precedence of binary &, although
> without looking it up I think you're correct.

Sure.  I'm fairly sure the compiler would've complained about
this case if it were ambiguous, I'm vaguely surprised it didn't
already.

> Feel free to adopt if this appeals to you, otherwise I'm also fine with
> your version.)

I'll see what I think when I get back to looking at this
properly.

[-- Attachment #1.2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

[-- Attachment #2: Type: text/plain, Size: 176 bytes --]

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2021-06-10 13:54 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-04 11:24 [PATCH v2 0/3] arm64: Enable BTI for the executable as well as the interpreter Mark Brown
2021-06-04 11:24 ` Mark Brown
2021-06-04 11:24 ` [PATCH v2 1/3] elf: Allow architectures to parse properties on the main executable Mark Brown
2021-06-04 11:24   ` Mark Brown
2021-06-09 15:16   ` Dave Martin
2021-06-09 15:16     ` Dave Martin
2021-06-10 13:41     ` Mark Brown
2021-06-10 13:41       ` Mark Brown
2021-06-04 11:24 ` [PATCH v2 2/3] arm64: Enable BTI for main executable as well as the interpreter Mark Brown
2021-06-04 11:24   ` Mark Brown
2021-06-09 15:17   ` Dave Martin
2021-06-09 15:17     ` Dave Martin
2021-06-10 13:19     ` Mark Brown [this message]
2021-06-10 13:19       ` Mark Brown
2021-06-10 15:34       ` Dave Martin
2021-06-10 15:34         ` Dave Martin
2021-06-04 11:24 ` [PATCH v2 3/3] elf: Remove has_interp property from arch_adjust_elf_prot() Mark Brown
2021-06-04 11:24   ` Mark Brown
2021-06-09 15:17   ` Dave Martin
2021-06-09 15:17     ` Dave Martin
2021-06-09 16:55     ` Yu, Yu-cheng
2021-06-09 16:55       ` Yu, Yu-cheng
2021-06-10  9:58       ` Dave Martin
2021-06-10  9:58         ` Dave Martin
2021-06-10 18:17         ` Yu, Yu-cheng
2021-06-10 18:17           ` Yu, Yu-cheng
2021-06-10 13:34     ` Mark Brown
2021-06-10 13:34       ` Mark Brown
2021-06-10 15:40       ` Dave Martin
2021-06-10 15:40         ` Dave Martin
2021-06-10 16:28 ` [PATCH v2 0/3] arm64: Enable BTI for the executable as well as the interpreter Jeremy Linton
2021-06-10 16:28   ` Jeremy Linton
2021-06-14 16:00   ` Mark Brown
2021-06-14 16:00     ` Mark Brown
2021-06-15 15:22   ` Dave Martin
2021-06-15 15:22     ` Dave Martin
2021-06-15 15:33     ` Mark Brown
2021-06-15 15:33       ` Mark Brown
2021-06-15 15:41       ` Dave Martin
2021-06-15 15:41         ` Dave Martin
2021-06-16  5:12         ` Jeremy Linton
2021-06-16  5:12           ` Jeremy Linton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YMIRSSMnP3UMwdRy@sirena.org.uk \
    --to=broonie@kernel.org \
    --cc=Dave.Martin@arm.com \
    --cc=catalin.marinas@arm.com \
    --cc=hjl.tools@gmail.com \
    --cc=jeremy.linton@arm.com \
    --cc=libc-alpha@sourceware.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=szabolcs.nagy@arm.com \
    --cc=will@kernel.org \
    --cc=yu-cheng.yu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.