dm-devel.redhat.com archive mirror
 help / color / mirror / Atom feed
From: Jan Kara <jack@suse.cz>
To: Christoph Hellwig <hch@lst.de>
Cc: Jens Axboe <axboe@kernel.dk>, Chao Yu <yuchao0@huawei.com>,
	Jan Kara <jack@suse.cz>, Mike Snitzer <snitzer@redhat.com>,
	linux-mm@kvack.org,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Jan Kara <jack@suse.com>, Josef Bacik <josef@toxicpanda.com>,
	Coly Li <colyli@suse.de>,
	linux-block@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	dm-devel@redhat.com, linux-mtd@lists.infradead.org,
	Johannes Thumshirn <johannes.thumshirn@wdc.com>,
	Tejun Heo <tj@kernel.org>,
	linux-bcache@vger.kernel.org
Subject: Re: [dm-devel] [PATCH 29/44] block: remove the nr_sects field in struct hd_struct
Date: Thu, 26 Nov 2020 17:50:36 +0100	[thread overview]
Message-ID: <20201126165036.GO422@quack2.suse.cz> (raw)
In-Reply-To: <20201126130422.92945-30-hch@lst.de>

On Thu 26-11-20 14:04:07, Christoph Hellwig wrote:
> Now that the hd_struct always has a block device attached to it, there is
> no need for having two size field that just get out of sync.
> 
> Additional the field in hd_struct did not use proper serializiation,
   ^^ Additionaly					^^^ serialization

> possibly allowing for torn writes.  By only using the block_device field
> this problem also gets fixed.
> 
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> Reviewed-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
> Acked-by: Coly Li <colyli@suse.de>			[bcache]
> Acked-by: Chao Yu <yuchao0@huawei.com>			[f2fs]

Nice, just two nits below.

> @@ -47,18 +57,22 @@ static void disk_release_events(struct gendisk *disk);
>  bool set_capacity_and_notify(struct gendisk *disk, sector_t size)
>  {
>  	sector_t capacity = get_capacity(disk);
> +	char *envp[] = { "RESIZE=1", NULL };
>  
>  	set_capacity(disk, size);
> -	revalidate_disk_size(disk, true);
> -
> -	if (capacity != size && capacity != 0 && size != 0) {
> -		char *envp[] = { "RESIZE=1", NULL };
> -
> -		kobject_uevent_env(&disk_to_dev(disk)->kobj, KOBJ_CHANGE, envp);
> -		return true;
> -	}
>  
> -	return false;
> +	/*
> +	 * Only print a message and send a uevent if the gendisk is user visible
> +	 * and alive.  This avoids spamming the log and udev when setting the
> +	 * initial capacity during probing.
> +	 */
> +	if (size == capacity ||
> +	    (disk->flags & (GENHD_FL_UP | GENHD_FL_HIDDEN)) != GENHD_FL_UP)
> +		return false;
> +	pr_info("%s: detected capacity change from %lld to %lld\n",
> +		disk->disk_name, size, capacity);
> +	kobject_uevent_env(&disk_to_dev(disk)->kobj, KOBJ_CHANGE, envp);

I think we don't want to generate resize event for changes from / to 0...
Also the return value of this function is now different.

> diff --git a/drivers/target/target_core_pscsi.c b/drivers/target/target_core_pscsi.c
> index 4e37fa9b409d52..a70c33c49f0960 100644
> --- a/drivers/target/target_core_pscsi.c
> +++ b/drivers/target/target_core_pscsi.c
> @@ -1027,12 +1027,7 @@ static u32 pscsi_get_device_type(struct se_device *dev)
>  
>  static sector_t pscsi_get_blocks(struct se_device *dev)
>  {
> -	struct pscsi_dev_virt *pdv = PSCSI_DEV(dev);
> -
> -	if (pdv->pdv_bd && pdv->pdv_bd->bd_part)
> -		return pdv->pdv_bd->bd_part->nr_sects;
> -
> -	return 0;
> +	return bdev_nr_sectors(PSCSI_DEV(dev)->pdv_bd);

I pdv_bd guaranteed to be non-NULL in pscsi_dev_virt?

								Honza
-- 
Jan Kara <jack@suse.com>
SUSE Labs, CR

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel


  reply	other threads:[~2020-11-26 16:50 UTC|newest]

Thread overview: 89+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-26 13:03 [dm-devel] merge struct block_device and struct hd_struct v3 Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 01/44] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 02/44] filemap: consistently use ->f_mapping over ->i_mapping Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 03/44] fs: remove get_super_thawed and get_super_exclusive_thawed Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 04/44] fs: simplify freeze_bdev/thaw_bdev Christoph Hellwig
2020-11-26 14:13   ` Jan Kara
2020-11-26 13:03 ` [dm-devel] [PATCH 05/44] mtip32xx: remove the call to fsync_bdev on removal Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 06/44] zram: do not call set_blocksize Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 07/44] loop: " Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 08/44] dm: simplify flush_bio initialization in __send_empty_flush Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 09/44] dm: remove the block_device reference in struct mapped_device Christoph Hellwig
2020-11-27 10:36   ` Hannes Reinecke
2020-11-26 13:03 ` [dm-devel] [PATCH 10/44] block: remove a duplicate __disk_get_part prototype Christoph Hellwig
2020-11-27 10:36   ` Hannes Reinecke
2020-11-26 13:03 ` [dm-devel] [PATCH 11/44] block: remove a superflous check in blkpg_do_ioctl Christoph Hellwig
2020-11-27 10:37   ` Hannes Reinecke
2020-11-26 13:03 ` [dm-devel] [PATCH 12/44] block: add a bdev_kobj helper Christoph Hellwig
2020-11-26 14:47   ` David Sterba
2020-11-27 12:03   ` Hannes Reinecke
2020-11-26 13:03 ` [dm-devel] [PATCH 13/44] block: use disk_part_iter_exit in disk_part_iter_next Christoph Hellwig
2020-11-27 12:04   ` Hannes Reinecke
2020-11-26 13:03 ` [dm-devel] [PATCH 14/44] block: use put_device in put_disk Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 15/44] block: change the hash used for looking up block devices Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 16/44] init: refactor name_to_dev_t Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 17/44] init: refactor devt_from_partuuid Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 18/44] init: cleanup match_dev_by_uuid and match_dev_by_label Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 19/44] block: refactor __blkdev_put Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 20/44] block: refactor blkdev_get Christoph Hellwig
2020-11-26 14:55   ` Jan Kara
2020-11-26 13:03 ` [dm-devel] [PATCH 21/44] block: move bdput() to the callers of __blkdev_get Christoph Hellwig
2020-11-26 15:05   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 22/44] block: opencode devcgroup_inode_permission Christoph Hellwig
2020-11-26 15:07   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 23/44] block: remove i_bdev Christoph Hellwig
2020-11-26 15:45   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 24/44] block: simplify bdev/disk lookup in blkdev_get Christoph Hellwig
2020-11-26 16:33   ` Jan Kara
2020-11-26 17:42     ` Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 25/44] block: remove ->bd_contains Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 26/44] block: simplify the block device claiming interface Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 27/44] block: simplify part_to_disk Christoph Hellwig
2020-11-26 16:36   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 28/44] block: initialize struct block_device in bdev_alloc Christoph Hellwig
2020-11-26 16:37   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 29/44] block: remove the nr_sects field in struct hd_struct Christoph Hellwig
2020-11-26 16:50   ` Jan Kara [this message]
2020-11-26 17:52     ` Christoph Hellwig
2020-11-26 18:04       ` Jan Kara
2020-11-27  9:41         ` Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 30/44] block: move disk stat accounting to struct block_device Christoph Hellwig
2020-11-26 16:53   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 31/44] block: move the start_sect field " Christoph Hellwig
2020-11-26 16:56   ` Jan Kara
2020-11-26 18:02     ` Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 32/44] block: move the partition_meta_info " Christoph Hellwig
2020-11-26 16:58   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 33/44] block: move holder_dir " Christoph Hellwig
2020-11-26 17:00   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 34/44] block: move make_it_fail " Christoph Hellwig
2020-11-26 17:01   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 35/44] block: move the policy field " Christoph Hellwig
2020-11-26 17:03   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 36/44] block: allocate struct hd_struct as part of struct bdev_inode Christoph Hellwig
2020-11-26 17:35   ` Jan Kara
2020-11-26 18:00     ` Jan Kara
2020-11-26 18:02       ` Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 37/44] block: switch partition lookup to use struct block_device Christoph Hellwig
2020-11-26 17:45   ` Jan Kara
2020-11-26 18:22   ` Jan Kara
2020-11-27  9:48     ` Christoph Hellwig
2020-11-27 12:45       ` Jan Kara
2020-11-27 15:36         ` Christoph Hellwig
2020-11-27 17:26           ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 38/44] block: remove the partno field from struct hd_struct Christoph Hellwig
2020-11-26 17:46   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 39/44] block: pass a block_device to blk_alloc_devt Christoph Hellwig
2020-11-26 17:47   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 40/44] block: pass a block_device to invalidate_partition Christoph Hellwig
2020-11-26 17:49   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 41/44] block: switch disk_part_iter_* to use a struct block_device Christoph Hellwig
2020-11-27 12:53   ` Jan Kara
2020-11-27 15:24     ` Christoph Hellwig
2020-11-27 17:30       ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 42/44] f2fs: remove a few bd_part checks Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 43/44] block: merge struct block_device and struct hd_struct Christoph Hellwig
2020-11-27 13:19   ` Jan Kara
2020-11-27 15:47     ` Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 44/44] block: stop using bdget_disk for partition 0 Christoph Hellwig
2020-11-27 13:22   ` Jan Kara

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201126165036.GO422@quack2.suse.cz \
    --to=jack@suse.cz \
    --cc=axboe@kernel.dk \
    --cc=colyli@suse.de \
    --cc=dm-devel@redhat.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hch@lst.de \
    --cc=jack@suse.com \
    --cc=johannes.thumshirn@wdc.com \
    --cc=josef@toxicpanda.com \
    --cc=linux-bcache@vger.kernel.org \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=snitzer@redhat.com \
    --cc=tj@kernel.org \
    --cc=yuchao0@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).