dm-devel.redhat.com archive mirror
 help / color / mirror / Atom feed
From: Jan Kara <jack@suse.cz>
To: Christoph Hellwig <hch@lst.de>
Cc: Jens Axboe <axboe@kernel.dk>, Jan Kara <jack@suse.cz>,
	Mike Snitzer <snitzer@redhat.com>,
	linux-mm@kvack.org,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Jan Kara <jack@suse.com>, Josef Bacik <josef@toxicpanda.com>,
	Coly Li <colyli@suse.de>,
	linux-block@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	dm-devel@redhat.com, linux-mtd@lists.infradead.org,
	Johannes Thumshirn <johannes.thumshirn@wdc.com>,
	Tejun Heo <tj@kernel.org>,
	linux-bcache@vger.kernel.org
Subject: Re: [dm-devel] [PATCH 41/44] block: switch disk_part_iter_* to use a struct block_device
Date: Fri, 27 Nov 2020 18:30:10 +0100	[thread overview]
Message-ID: <20201127173010.GB4276@quack2.suse.cz> (raw)
In-Reply-To: <20201127152407.GA7115@lst.de>

On Fri 27-11-20 16:24:07, Christoph Hellwig wrote:
> On Fri, Nov 27, 2020 at 01:53:41PM +0100, Jan Kara wrote:
> > On Thu 26-11-20 14:04:19, Christoph Hellwig wrote:
> > 
> > There's:
> > 
> >         /* put the last partition */
> >         disk_put_part(piter->part);
> >         piter->part = NULL;
> > 
> > at the beginning of disk_part_iter_next() which also needs switching to
> > bdput(), doesn't it?
> 
> That is switched to call disk_part_iter_exit in patch 13.

I see, sorry for the noise.

> > > @@ -271,8 +271,7 @@ struct hd_struct *disk_part_iter_next(struct disk_part_iter *piter)
> > >  		      piter->idx == 0))
> > >  			continue;
> > >  
> > > -		get_device(part_to_dev(part->bd_part));
> > > -		piter->part = part->bd_part;
> > > +		piter->part = bdgrab(part);
> > 
> > bdgrab() could return NULL if we are racing with delete_partition() so I
> > think we need to take care of that.
> 
> bdgrab never retuns NULL..

Ah, that's what I misunderstood. I was confusing bdgrab() with igrab().
igrab() can return NULL but bdgrab() uses ihold() and thus cannot return
NULL. But for the lifetime rules to be safe, we should be indeed using
igrab() and check for NULL return...

								Honza

-- 
Jan Kara <jack@suse.com>
SUSE Labs, CR

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel


  reply	other threads:[~2020-11-27 17:30 UTC|newest]

Thread overview: 89+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-26 13:03 [dm-devel] merge struct block_device and struct hd_struct v3 Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 01/44] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 02/44] filemap: consistently use ->f_mapping over ->i_mapping Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 03/44] fs: remove get_super_thawed and get_super_exclusive_thawed Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 04/44] fs: simplify freeze_bdev/thaw_bdev Christoph Hellwig
2020-11-26 14:13   ` Jan Kara
2020-11-26 13:03 ` [dm-devel] [PATCH 05/44] mtip32xx: remove the call to fsync_bdev on removal Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 06/44] zram: do not call set_blocksize Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 07/44] loop: " Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 08/44] dm: simplify flush_bio initialization in __send_empty_flush Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 09/44] dm: remove the block_device reference in struct mapped_device Christoph Hellwig
2020-11-27 10:36   ` Hannes Reinecke
2020-11-26 13:03 ` [dm-devel] [PATCH 10/44] block: remove a duplicate __disk_get_part prototype Christoph Hellwig
2020-11-27 10:36   ` Hannes Reinecke
2020-11-26 13:03 ` [dm-devel] [PATCH 11/44] block: remove a superflous check in blkpg_do_ioctl Christoph Hellwig
2020-11-27 10:37   ` Hannes Reinecke
2020-11-26 13:03 ` [dm-devel] [PATCH 12/44] block: add a bdev_kobj helper Christoph Hellwig
2020-11-26 14:47   ` David Sterba
2020-11-27 12:03   ` Hannes Reinecke
2020-11-26 13:03 ` [dm-devel] [PATCH 13/44] block: use disk_part_iter_exit in disk_part_iter_next Christoph Hellwig
2020-11-27 12:04   ` Hannes Reinecke
2020-11-26 13:03 ` [dm-devel] [PATCH 14/44] block: use put_device in put_disk Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 15/44] block: change the hash used for looking up block devices Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 16/44] init: refactor name_to_dev_t Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 17/44] init: refactor devt_from_partuuid Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 18/44] init: cleanup match_dev_by_uuid and match_dev_by_label Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 19/44] block: refactor __blkdev_put Christoph Hellwig
2020-11-26 13:03 ` [dm-devel] [PATCH 20/44] block: refactor blkdev_get Christoph Hellwig
2020-11-26 14:55   ` Jan Kara
2020-11-26 13:03 ` [dm-devel] [PATCH 21/44] block: move bdput() to the callers of __blkdev_get Christoph Hellwig
2020-11-26 15:05   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 22/44] block: opencode devcgroup_inode_permission Christoph Hellwig
2020-11-26 15:07   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 23/44] block: remove i_bdev Christoph Hellwig
2020-11-26 15:45   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 24/44] block: simplify bdev/disk lookup in blkdev_get Christoph Hellwig
2020-11-26 16:33   ` Jan Kara
2020-11-26 17:42     ` Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 25/44] block: remove ->bd_contains Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 26/44] block: simplify the block device claiming interface Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 27/44] block: simplify part_to_disk Christoph Hellwig
2020-11-26 16:36   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 28/44] block: initialize struct block_device in bdev_alloc Christoph Hellwig
2020-11-26 16:37   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 29/44] block: remove the nr_sects field in struct hd_struct Christoph Hellwig
2020-11-26 16:50   ` Jan Kara
2020-11-26 17:52     ` Christoph Hellwig
2020-11-26 18:04       ` Jan Kara
2020-11-27  9:41         ` Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 30/44] block: move disk stat accounting to struct block_device Christoph Hellwig
2020-11-26 16:53   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 31/44] block: move the start_sect field " Christoph Hellwig
2020-11-26 16:56   ` Jan Kara
2020-11-26 18:02     ` Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 32/44] block: move the partition_meta_info " Christoph Hellwig
2020-11-26 16:58   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 33/44] block: move holder_dir " Christoph Hellwig
2020-11-26 17:00   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 34/44] block: move make_it_fail " Christoph Hellwig
2020-11-26 17:01   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 35/44] block: move the policy field " Christoph Hellwig
2020-11-26 17:03   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 36/44] block: allocate struct hd_struct as part of struct bdev_inode Christoph Hellwig
2020-11-26 17:35   ` Jan Kara
2020-11-26 18:00     ` Jan Kara
2020-11-26 18:02       ` Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 37/44] block: switch partition lookup to use struct block_device Christoph Hellwig
2020-11-26 17:45   ` Jan Kara
2020-11-26 18:22   ` Jan Kara
2020-11-27  9:48     ` Christoph Hellwig
2020-11-27 12:45       ` Jan Kara
2020-11-27 15:36         ` Christoph Hellwig
2020-11-27 17:26           ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 38/44] block: remove the partno field from struct hd_struct Christoph Hellwig
2020-11-26 17:46   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 39/44] block: pass a block_device to blk_alloc_devt Christoph Hellwig
2020-11-26 17:47   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 40/44] block: pass a block_device to invalidate_partition Christoph Hellwig
2020-11-26 17:49   ` Jan Kara
2020-11-26 13:04 ` [dm-devel] [PATCH 41/44] block: switch disk_part_iter_* to use a struct block_device Christoph Hellwig
2020-11-27 12:53   ` Jan Kara
2020-11-27 15:24     ` Christoph Hellwig
2020-11-27 17:30       ` Jan Kara [this message]
2020-11-26 13:04 ` [dm-devel] [PATCH 42/44] f2fs: remove a few bd_part checks Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 43/44] block: merge struct block_device and struct hd_struct Christoph Hellwig
2020-11-27 13:19   ` Jan Kara
2020-11-27 15:47     ` Christoph Hellwig
2020-11-26 13:04 ` [dm-devel] [PATCH 44/44] block: stop using bdget_disk for partition 0 Christoph Hellwig
2020-11-27 13:22   ` Jan Kara

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201127173010.GB4276@quack2.suse.cz \
    --to=jack@suse.cz \
    --cc=axboe@kernel.dk \
    --cc=colyli@suse.de \
    --cc=dm-devel@redhat.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hch@lst.de \
    --cc=jack@suse.com \
    --cc=johannes.thumshirn@wdc.com \
    --cc=josef@toxicpanda.com \
    --cc=linux-bcache@vger.kernel.org \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=snitzer@redhat.com \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).