linux-block.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-11-28 22:12:10 to 2020-12-01 14:08:07 UTC [more...]

[PATCH 000/141] Fix fall-through warnings for Clang
 2020-12-01 14:04 UTC  (8+ messages)

[PATCH 0/4] nvme: enable per-namespace char device
 2020-12-01 14:06 UTC  (9+ messages)
` [PATCH 1/4] nvme: remove unnecessary return values
` [PATCH 2/4] nvme: rename controller base dev_t char device
` [PATCH 3/4] nvme: rename bdev operations
` [PATCH 4/4] nvme: enable char device per namespace

[PATCH] block: add bio_iov_iter_nvecs for figuring out nr_vecs
 2020-12-01 13:48 UTC  (8+ messages)

[RFC PATCH 0/2] add simple copy support
 2020-12-01 13:22 UTC  (8+ messages)
    ` [RFC PATCH 1/2] block: "
    ` [RFC PATCH 2/2] nvme: "

[RFC PATCH] blk-mq: Clean up references when freeing rqs
 2020-12-01 13:02 UTC 

[bug report] Hang on sync after dd
 2020-12-01 12:34 UTC  (4+ messages)

[V5] nvme: enable ro namespace for ZNS without append
 2020-12-01 12:02 UTC 

[PATCH v4 0/9] Rework runtime suspend and SPI domain validation
 2020-12-01 11:33 UTC  (16+ messages)
` [PATCH v4 1/9] block: Fix a race in the runtime power management code
` [PATCH v4 2/9] block: Introduce BLK_MQ_REQ_PM
` [PATCH v4 3/9] ide: Do not set the RQF_PREEMPT flag for sense requests
` [PATCH v4 4/9] ide: Mark power management requests with RQF_PM instead of RQF_PREEMPT
` [PATCH v4 5/9] scsi: Do not wait for a request in scsi_eh_lock_door()
` [PATCH v4 6/9] scsi_transport_spi: Set RQF_PM for domain validation commands
` [PATCH v4 7/9] scsi: Only process PM requests if rpm_status != RPM_ACTIVE
` [PATCH v4 8/9] block: Remove RQF_PREEMPT and BLK_MQ_REQ_PREEMPT
` [PATCH v4 9/9] block: Do not accept any requests while suspended

[PATCH v1 1/3] add io_uring with IOPOLL support in scsi layer
 2020-12-01  9:49 UTC  (4+ messages)

[PATCH 0/9] nvmet: add genblk ZBD backend
 2020-12-01  7:51 UTC  (20+ messages)
` [PATCH V2 1/9] block: export __bio_iov_append_get_pages()
` [PATCH V2 2/9] nvmet: add ZNS support for bdev-ns
` [PATCH V2 3/9] nvmet: trim down id-desclist to use req->ns
` [PATCH V2 4/9] nvmet: add NVME_CSI_ZNS in ns-desc for zbdev
` [PATCH V2 5/9] nvmet: add cns-cs-ctrl in id-ctrl for ZNS bdev
` [PATCH V2 6/9] nvmet: add cns-cs-ns "
` [PATCH V2 7/9] nvmet: add zns cmd effects to support zbdev
` [PATCH V2 8/9] nvmet: add zns bdev config support
` [PATCH V2 9/9] nvmet: add ZNS based I/O cmds handlers

[PATCH V3 0/9] nvmet: add ZBD backend support
 2020-12-01  6:46 UTC  (11+ messages)
` [PATCH V3 1/9] block: export __bio_iov_append_get_pages()
` [PATCH V3 2/9] nvmet: add ZNS support for bdev-ns
` [PATCH V3 3/9] nvmet: trim down id-desclist to use req->ns
` [PATCH V3 4/9] nvmet: add NVME_CSI_ZNS in ns-desc for zbdev
` [PATCH V3 5/9] nvmet: add cns-cs-ctrl in id-ctrl for ZNS bdev
` [PATCH V3 6/9] nvmet: add cns-cs-ns "
` [PATCH V3 7/9] nvmet: add zns cmd effects to support zbdev
` [PATCH V3 8/9] nvmet: add zns bdev config support
` [PATCH V3 9/9] nvmet: add ZNS based I/O cmds handlers

[PATCH v4 0/9] null_blk fixes, improvements and cleanup
 2020-12-01  2:19 UTC  (2+ messages)

[PATCH v2] block: Improve blk_revalidate_disk_zones() checks
 2020-12-01  2:13 UTC  (2+ messages)

[PATCH] block: revert to using min_not_zero() when stacking chunk_sectors
 2020-12-01  2:12 UTC  (5+ messages)
  `  "

[PATCH v2] blk-mq: Remove 'running from the wrong CPU' warning
 2020-12-01  2:09 UTC  (3+ messages)

[PATCH] block: fix inflight statistics of part0
 2020-12-01  1:53 UTC  (4+ messages)

❌ FAIL: Test report for kernel 5.10.0-rc5 (block)
 2020-11-30 21:43 UTC  (2+ messages)

[PATCH v2] iosched: Add i10 I/O Scheduler
 2020-11-30 20:19 UTC 

[PATCH v1 3/3] scsi_debug: iouring iopoll support
 2020-11-30 19:42 UTC  (4+ messages)

[PATCH] iosched: Add i10 I/O Scheduler
 2020-11-30 19:20 UTC  (10+ messages)

block tracepoint cleanups
 2020-11-30 17:58 UTC  (6+ messages)
` [PATCH 1/5] block: remove the unused block_sleeprq tracepoint
` [PATCH 2/5] block: simplify and extended the block_bio_merge tracepoint class
` [PATCH 3/5] block: remove the request_queue argument to the block_split tracepoint
` [PATCH 4/5] block: remove the request_queue argument to the block_bio_remap tracepoint
` [PATCH 5/5] block: remove the request_queue to argument request based tracepoints

[PATCH] block: wbt: Remove unnecessary invoking of wbt_update_limits in wbt_init
 2020-11-30 18:10 UTC  (2+ messages)

merge struct block_device and struct hd_struct v4
 2020-11-30 17:55 UTC  (90+ messages)
` [PATCH 02/45] filemap: consistently use ->f_mapping over ->i_mapping
` [PATCH 04/45] fs: simplify freeze_bdev/thaw_bdev
` [PATCH 05/45] mtip32xx: remove the call to fsync_bdev on removal
` [PATCH 07/45] loop: do not call set_blocksize
` [PATCH 08/45] dm: simplify flush_bio initialization in __send_empty_flush
` [PATCH 11/45] block: remove a superflous check in blkpg_do_ioctl
` [PATCH 14/45] block: use put_device in put_disk
` [PATCH 15/45] block: change the hash used for looking up block devices
` [PATCH 16/45] block: switch bdgrab to use igrab
` [PATCH 17/45] init: refactor name_to_dev_t
` [PATCH 18/45] init: refactor devt_from_partuuid
` [PATCH 19/45] init: cleanup match_dev_by_uuid and match_dev_by_label
` [PATCH 20/45] block: refactor __blkdev_put
` [PATCH 21/45] block: refactor blkdev_get
` [PATCH 22/45] block: move bdput() to the callers of __blkdev_get
` [PATCH 23/45] block: opencode devcgroup_inode_permission
` [PATCH 24/45] block: remove i_bdev
` [PATCH 25/45] block: simplify bdev/disk lookup in blkdev_get
` [PATCH 26/45] block: remove ->bd_contains
` [PATCH 27/45] block: simplify the block device claiming interface
` [PATCH 28/45] block: simplify part_to_disk
` [PATCH 29/45] block: initialize struct block_device in bdev_alloc
` [PATCH 30/45] block: remove the nr_sects field in struct hd_struct
` [PATCH 31/45] block: move disk stat accounting to struct block_device
` [PATCH 32/45] block: move the start_sect field "
` [PATCH 33/45] block: move the partition_meta_info "
` [PATCH 34/45] block: move holder_dir "
` [PATCH 35/45] block: move make_it_fail "
` [PATCH 36/45] block: move the policy field "
` [PATCH 37/45] block: allocate struct hd_struct as part of struct bdev_inode
` [PATCH 38/45] block: switch partition lookup to use struct block_device
` [PATCH 39/45] block: remove the partno field from struct hd_struct
` [PATCH 40/45] block: pass a block_device to blk_alloc_devt
` [PATCH 41/45] block: pass a block_device to invalidate_partition
` [PATCH 42/45] block: switch disk_part_iter_* to use a struct block_device
` [PATCH 43/45] f2fs: remove a few bd_part checks
` [PATCH 44/45] block: merge struct block_device and struct hd_struct
` [PATCH 45/45] block: stop using bdget_disk for partition 0

[RFC] blk-mq/scsi: deadlock found on usb driver
 2020-11-30 15:03 UTC  (2+ messages)

[Race] data race between blkdev_ioctl() and generic_fadvise()
 2020-11-30 14:58 UTC 

[PATCH V1] block: Fix use-after-free while iterating over requests
 2020-11-30 14:58 UTC  (6+ messages)

[PATCH v1 2/3] megaraid_sas: iouring iopoll support
 2020-11-30  9:40 UTC  (5+ messages)

split hard read-only vs read-only policy v2
 2020-11-30  7:58 UTC  (11+ messages)
` [PATCH 1/4] block: add a hard-readonly flag to struct gendisk
` [PATCH 2/4] rbd: remove the ->set_read_only method
` [PATCH 3/4] nvme: allow revalidate to set a namespace read-only
` [PATCH 4/4] dm: use bdev_read_only to check if a device is read-only

[PATCH] drivers/lightnvm: fix a null-ptr-deref bug in pblk-core.c
 2020-11-30  7:23 UTC 

[PATCH 0/3] blk-mq/nvme-loop: use nvme-loop's lock class for addressing lockdep false positive warning
 2020-11-30  2:36 UTC  (2+ messages)

[PATCH 0/3] cleanups/fix for blk_mq_get_tag()
 2020-11-30  1:36 UTC  (4+ messages)
` [PATCH 1/3] blk-mq: use right tag offset after wait
` [PATCH 2/3] blk-mq: deduplicate blk_mq_get_tag() bits
` [PATCH 3/3] blk-mq: idiomatic use of WARN_ON_ONCE

[PATCH 0/9] nvmet: add genblk ZBD backend
 2020-11-30  0:21 UTC  (10+ messages)
` [PATCH 2/9] nvmet: add ZNS support for bdev-ns
` [PATCH 6/9] nvmet: add cns-cs-ns in id-ctrl for ZNS bdev

[PATCH 1/2] ALSA: ppc: drop if block with always false condition
 2020-11-29 17:31 UTC  (7+ messages)
` [PATCH 2/2] powerpc/ps3: make system bus's remove and shutdown callbacks return void

[RFC PATCH] blk-iocost: Optimize the ioc_refreash_vrate() function
 2020-11-29  2:37 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).