linux-fsdevel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] coredump: rename umh_pipe_setup() to coredump_pipe_setup()
@ 2018-05-07 23:30 Luis R. Rodriguez
  2018-05-10 23:19 ` Alexei Starovoitov
  0 siblings, 1 reply; 5+ messages in thread
From: Luis R. Rodriguez @ 2018-05-07 23:30 UTC (permalink / raw)
  To: viro; +Cc: ast, linux-fsdevel, linux-kernel, Luis R. Rodriguez

This makes it clearer this code is part of the coredump code, and
is not an exported generic helper from kernel/umh.c.

Signed-off-by: Luis R. Rodriguez <mcgrof@kernel.org>
---
 fs/coredump.c | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/fs/coredump.c b/fs/coredump.c
index 1e2c87acac9b..566504781683 100644
--- a/fs/coredump.c
+++ b/fs/coredump.c
@@ -508,7 +508,7 @@ static void wait_for_dump_helpers(struct file *file)
 }
 
 /*
- * umh_pipe_setup
+ * coredump_pipe_setup
  * helper function to customize the process used
  * to collect the core in userspace.  Specifically
  * it sets up a pipe and installs it as fd 0 (stdin)
@@ -518,7 +518,7 @@ static void wait_for_dump_helpers(struct file *file)
  * is a special value that we use to trap recursive
  * core dumps
  */
-static int umh_pipe_setup(struct subprocess_info *info, struct cred *new)
+static int coredump_pipe_setup(struct subprocess_info *info, struct cred *new)
 {
 	struct file *files[2];
 	struct coredump_params *cp = (struct coredump_params *)info->data;
@@ -606,7 +606,7 @@ void do_coredump(const siginfo_t *siginfo)
 		}
 
 		if (cprm.limit == 1) {
-			/* See umh_pipe_setup() which sets RLIMIT_CORE = 1.
+			/* See coredump_pipe_setup() which sets RLIMIT_CORE = 1.
 			 *
 			 * Normally core limits are irrelevant to pipes, since
 			 * we're not writing to the file system, but we use
@@ -647,7 +647,8 @@ void do_coredump(const siginfo_t *siginfo)
 		retval = -ENOMEM;
 		sub_info = call_usermodehelper_setup(helper_argv[0],
 						helper_argv, NULL, GFP_KERNEL,
-						umh_pipe_setup, NULL, &cprm);
+						coredump_pipe_setup, NULL,
+						&cprm);
 		if (sub_info)
 			retval = call_usermodehelper_exec(sub_info,
 							  UMH_WAIT_EXEC);
-- 
2.17.0

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] coredump: rename umh_pipe_setup() to coredump_pipe_setup()
  2018-05-07 23:30 [PATCH] coredump: rename umh_pipe_setup() to coredump_pipe_setup() Luis R. Rodriguez
@ 2018-05-10 23:19 ` Alexei Starovoitov
  2018-05-10 23:32   ` Luis R. Rodriguez
  0 siblings, 1 reply; 5+ messages in thread
From: Alexei Starovoitov @ 2018-05-10 23:19 UTC (permalink / raw)
  To: Luis R. Rodriguez
  Cc: viro, ast, linux-fsdevel, linux-kernel, David S. Miller, netdev

On Mon, May 07, 2018 at 04:30:02PM -0700, Luis R. Rodriguez wrote:
> This makes it clearer this code is part of the coredump code, and
> is not an exported generic helper from kernel/umh.c.
> 
> Signed-off-by: Luis R. Rodriguez <mcgrof@kernel.org>
> ---
>  fs/coredump.c | 9 +++++----
>  1 file changed, 5 insertions(+), 4 deletions(-)
> 
> diff --git a/fs/coredump.c b/fs/coredump.c
> index 1e2c87acac9b..566504781683 100644
> --- a/fs/coredump.c
> +++ b/fs/coredump.c
> @@ -508,7 +508,7 @@ static void wait_for_dump_helpers(struct file *file)
>  }
>  
>  /*
> - * umh_pipe_setup
> + * coredump_pipe_setup
>   * helper function to customize the process used
>   * to collect the core in userspace.  Specifically
>   * it sets up a pipe and installs it as fd 0 (stdin)
> @@ -518,7 +518,7 @@ static void wait_for_dump_helpers(struct file *file)
>   * is a special value that we use to trap recursive
>   * core dumps
>   */
> -static int umh_pipe_setup(struct subprocess_info *info, struct cred *new)
> +static int coredump_pipe_setup(struct subprocess_info *info, struct cred *new)

I think this renaming makes sense.
How do we want to proceed?
I can take it as part of my series and get the whole thing through net-next
or folks want to apply this separately?

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] coredump: rename umh_pipe_setup() to coredump_pipe_setup()
  2018-05-10 23:19 ` Alexei Starovoitov
@ 2018-05-10 23:32   ` Luis R. Rodriguez
  2018-05-11  2:48     ` Al Viro
  0 siblings, 1 reply; 5+ messages in thread
From: Luis R. Rodriguez @ 2018-05-10 23:32 UTC (permalink / raw)
  To: Alexei Starovoitov, Al Viro
  Cc: Luis R. Rodriguez, ast, linux-fsdevel, linux-kernel,
	David S. Miller, netdev

On Thu, May 10, 2018 at 04:19:09PM -0700, Alexei Starovoitov wrote:
> On Mon, May 07, 2018 at 04:30:02PM -0700, Luis R. Rodriguez wrote:
> > This makes it clearer this code is part of the coredump code, and
> > is not an exported generic helper from kernel/umh.c.
> > 
> > Signed-off-by: Luis R. Rodriguez <mcgrof@kernel.org>
> > ---
> >  fs/coredump.c | 9 +++++----
> >  1 file changed, 5 insertions(+), 4 deletions(-)
> > 
> > diff --git a/fs/coredump.c b/fs/coredump.c
> > index 1e2c87acac9b..566504781683 100644
> > --- a/fs/coredump.c
> > +++ b/fs/coredump.c
> > @@ -508,7 +508,7 @@ static void wait_for_dump_helpers(struct file *file)
> >  }
> >  
> >  /*
> > - * umh_pipe_setup
> > + * coredump_pipe_setup
> >   * helper function to customize the process used
> >   * to collect the core in userspace.  Specifically
> >   * it sets up a pipe and installs it as fd 0 (stdin)
> > @@ -518,7 +518,7 @@ static void wait_for_dump_helpers(struct file *file)
> >   * is a special value that we use to trap recursive
> >   * core dumps
> >   */
> > -static int umh_pipe_setup(struct subprocess_info *info, struct cred *new)
> > +static int coredump_pipe_setup(struct subprocess_info *info, struct cred *new)
> 
> I think this renaming makes sense.
> How do we want to proceed?
> I can take it as part of my series and get the whole thing through net-next
> or folks want to apply this separately?

I think net-next makes sense if Al Viro is OK with that. This way it could go
in regardless of the state of your series, but it also lines up with your work.

  Luis

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] coredump: rename umh_pipe_setup() to coredump_pipe_setup()
  2018-05-10 23:32   ` Luis R. Rodriguez
@ 2018-05-11  2:48     ` Al Viro
  2018-05-11 16:17       ` Luis R. Rodriguez
  0 siblings, 1 reply; 5+ messages in thread
From: Al Viro @ 2018-05-11  2:48 UTC (permalink / raw)
  To: Luis R. Rodriguez
  Cc: Alexei Starovoitov, ast, linux-fsdevel, linux-kernel,
	David S. Miller, netdev

On Thu, May 10, 2018 at 11:32:47PM +0000, Luis R. Rodriguez wrote:

> I think net-next makes sense if Al Viro is OK with that. This way it could go
> in regardless of the state of your series, but it also lines up with your work.

Fine by me...

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] coredump: rename umh_pipe_setup() to coredump_pipe_setup()
  2018-05-11  2:48     ` Al Viro
@ 2018-05-11 16:17       ` Luis R. Rodriguez
  0 siblings, 0 replies; 5+ messages in thread
From: Luis R. Rodriguez @ 2018-05-11 16:17 UTC (permalink / raw)
  To: Al Viro, David S. Miller
  Cc: Luis R. Rodriguez, Alexei Starovoitov, ast, linux-fsdevel,
	linux-kernel, netdev

On Fri, May 11, 2018 at 03:48:51AM +0100, Al Viro wrote:
> On Thu, May 10, 2018 at 11:32:47PM +0000, Luis R. Rodriguez wrote:
> 
> > I think net-next makes sense if Al Viro is OK with that. This way it could go
> > in regardless of the state of your series, but it also lines up with your work.
> 
> Fine by me...

OK thanks.

Dave, I'll bounce a copy of the original patch to you, if anything else is needed
please let me know.

  Luis

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2018-05-11 16:17 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-05-07 23:30 [PATCH] coredump: rename umh_pipe_setup() to coredump_pipe_setup() Luis R. Rodriguez
2018-05-10 23:19 ` Alexei Starovoitov
2018-05-10 23:32   ` Luis R. Rodriguez
2018-05-11  2:48     ` Al Viro
2018-05-11 16:17       ` Luis R. Rodriguez

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).