linux-fsdevel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jan Kara <jack@suse.cz>
To: Ojaswin Mujoo <ojaswin@linux.ibm.com>
Cc: linux-ext4@vger.kernel.org, Theodore Ts'o <tytso@mit.edu>,
	Ritesh Harjani <riteshh@linux.ibm.com>,
	linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org,
	Jan Kara <jack@suse.cz>, Kemeng Shi <shikemeng@huaweicloud.com>
Subject: Re: [PATCH v2 12/12] ext4: Give symbolic names to mballoc criterias
Date: Wed, 7 Jun 2023 12:39:36 +0200	[thread overview]
Message-ID: <20230607103936.wqtcrc76tqpbc2ya@quack3> (raw)
In-Reply-To: <a2dc6ec5aea5e5e68cf8e788c2a964ffead9c8b0.1685449706.git.ojaswin@linux.ibm.com>

On Tue 30-05-23 18:03:50, Ojaswin Mujoo wrote:
> mballoc criterias have historically been called by numbers
> like CR0, CR1... however this makes it confusing to understand
> what each criteria is about.
> 
> Change these criterias from numbers to symbolic names and add
> relevant comments. While we are at it, also reformat and add some
> comments to ext4_seq_mb_stats_show() for better readability.
> 
> Additionally, define CR_FAST which signifies the criteria
> below which we can make quicker decisions like:
>   * quitting early if (free block < requested len)
>   * avoiding to scan free extents smaller than required len.
>   * avoiding to initialize buddy cache and work with existing cache
>   * limiting prefetches
> 
> Suggested-by: Jan Kara <jack@suse.cz>
> Signed-off-by: Ojaswin Mujoo <ojaswin@linux.ibm.com>

Thanks for doing this!

> diff --git a/fs/ext4/ext4.h b/fs/ext4/ext4.h
> index 942e97026a60..c29a4e1fcd5d 100644
> --- a/fs/ext4/ext4.h
> +++ b/fs/ext4/ext4.h
> @@ -135,16 +135,45 @@ enum SHIFT_DIRECTION {
>   */
>  #define EXT4_MB_NUM_CRS 5
>  /*
> - * All possible allocation criterias for mballoc
> + * All possible allocation criterias for mballoc. Lower are faster.
>   */
>  enum criteria {
> -	CR0,
> -	CR1,
> -	CR1_5,
> -	CR2,
> -	CR3,
> +	/*
> +	 * Used when number of blocks needed is a power of 2. This doesn't
> +	 * trigger any disk IO except prefetch and is the fastest criteria.
> +	 */
> +	CR_POWER2_ALIGNED,
> +
> +	/*
> +	 * Tries to lookup in-memory data structures to find the most suitable
> +	 * group that satisfies goal request. No disk IO except block prefetch.
> +	 */
> +	CR_GOAL_LEN_FAST,
> +
> +        /*
> +	 * Same as CR_GOAL_LEN_FAST but is allowed to reduce the goal length to
> +         * the best available length for faster allocation.

Some whitespace damage here...

> +	 */
> +	CR_BEST_AVAIL_LEN,
> +
> +	/*
> +	 * Reads each block group sequentially, performing disk IO if necessary, to
> +	 * find find_suitable block group. Tries to allocate goal length but might trim

Too long line here.

> +	 * the request if nothing is found after enough tries.
> +	 */
> +	CR_GOAL_LEN_SLOW,
> +
> +	/*
> +	 * Finds the first free set of blocks and allocates those. This is only
> +	 * used in rare cases when CR_GOAL_LEN_SLOW also fails to allocate
> +	 * anything.
> +	 */
> +	CR_ANY_FREE,
>  };
>  
> +/* criteria below which we use fast block scanning and avoid unnecessary IO */
> +#define CR_FAST CR_GOAL_LEN_SLOW
> +

Maybe instead of defining CR_FAST value we could define

static inline bool mballoc_cr_expensive(enum criteria cr)
{
	return cr >= CR_GOAL_LEN_SLOW;
}

And use this. I think it will make the conditions more understandable.

...

> @@ -1064,7 +1068,7 @@ static inline int should_optimize_scan(struct ext4_allocation_context *ac)
>  {
>  	if (unlikely(!test_opt2(ac->ac_sb, MB_OPTIMIZE_SCAN)))
>  		return 0;
> -	if (ac->ac_criteria >= CR2)
> +	if (ac->ac_criteria >= CR_GOAL_LEN_SLOW)

Maybe we should use CR_FAST (or the new function) here?

Otherwise the patch looks good!

								Honza
-- 
Jan Kara <jack@suse.com>
SUSE Labs, CR

  reply	other threads:[~2023-06-07 10:39 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-05-30 12:33 [PATCH v2 00/12] multiblock allocator improvements Ojaswin Mujoo
2023-05-30 12:33 ` [PATCH v2 01/12] Revert "ext4: remove ac->ac_found > sbi->s_mb_min_to_scan dead check in ext4_mb_check_limits" Ojaswin Mujoo
2023-05-30 16:28   ` Sedat Dilek
2023-05-31  8:57     ` Ojaswin Mujoo
2023-06-02 13:45       ` Thorsten Leemhuis
2023-06-02 16:45         ` Theodore Ts'o
2023-05-30 12:33 ` [PATCH v2 02/12] ext4: mballoc: Remove useless setting of ac_criteria Ojaswin Mujoo
2023-05-30 12:33 ` [PATCH v2 03/12] ext4: Remove unused extern variables declaration Ojaswin Mujoo
2023-05-30 12:33 ` [PATCH v2 04/12] ext4: Convert mballoc cr (criteria) to enum Ojaswin Mujoo
2023-06-06 13:13   ` Jan Kara
2023-05-30 12:33 ` [PATCH v2 05/12] ext4: Add per CR extent scanned counter Ojaswin Mujoo
2023-05-30 12:33 ` [PATCH v2 06/12] ext4: Add counter to track successful allocation of goal length Ojaswin Mujoo
2023-05-30 12:33 ` [PATCH v2 07/12] ext4: Avoid scanning smaller extents in BG during CR1 Ojaswin Mujoo
2023-05-30 12:33 ` [PATCH v2 08/12] ext4: Don't skip prefetching BLOCK_UNINIT groups Ojaswin Mujoo
2023-05-30 12:33 ` [PATCH v2 09/12] ext4: Ensure ext4_mb_prefetch_fini() is called for all prefetched BGs Ojaswin Mujoo
2023-06-06 14:00   ` Guoqing Jiang
2023-06-27  6:51     ` Ojaswin Mujoo
2023-06-28  1:33       ` Guoqing Jiang
2023-05-30 12:33 ` [PATCH v2 10/12] ext4: Abstract out logic to search average fragment list Ojaswin Mujoo
2023-05-30 12:33 ` [PATCH v2 11/12] ext4: Add allocation criteria 1.5 (CR1_5) Ojaswin Mujoo
2023-06-07 10:21   ` Jan Kara
2023-06-08 14:45     ` Theodore Ts'o
2023-06-09 10:57       ` Ojaswin Mujoo
2023-05-30 12:33 ` [PATCH v2 12/12] ext4: Give symbolic names to mballoc criterias Ojaswin Mujoo
2023-06-07 10:39   ` Jan Kara [this message]
2023-06-09  3:14 ` [PATCH v2 00/12] multiblock allocator improvements Theodore Ts'o

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230607103936.wqtcrc76tqpbc2ya@quack3 \
    --to=jack@suse.cz \
    --cc=linux-ext4@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ojaswin@linux.ibm.com \
    --cc=riteshh@linux.ibm.com \
    --cc=shikemeng@huaweicloud.com \
    --cc=tytso@mit.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).